xmms (x11amp) glib/gtk+ RH6 Newbie install

xmms (x11amp) glib/gtk+ RH6 Newbie install

Post by Dave Esque » Sun, 31 Dec 1899 09:00:00



Greetings,
I'm trying to install xmms-0.9.1-1.i386.rpm and in doing an rpm -ivh, it
tells me that I have unresolved dependencies, namely glib and gtk+ must be

Quote:>1.2.2

I downloaded
        gtk+-1.2.2-1.i386.rpm and
        glib-1.2.2-1.i386.rpm

but also saw a glib-devel and gtk+-devel...rpm's

Do I need these "devel" libraries? Is it OK for the "devel" libraries to be
out of "synch"?

To install glib and gtk+, do I just
        rpm -Uvh glib-1.2.2-1.i386.rpm and
        rpm -Uvh gtk+-1.2.2-1.i386.rpm

and then
        rpm -ivh xmms-0.9.1-1.i386.rpm

Do I have to uninstall X11amp beta first? (rpm -e)

This sounds TOO easy and as you can tell, I'm worrying about screwing up
big time here. I've read that I can do that in searching about xmms and the
glib/gtk+ libraries!

(With rpm -q, I notice that I have glib and gtk+ versions of 1.2.1.2 and
1.2.1-10 respectively)

TIA,
Dave

------------------  Posted via SearchLinux  ------------------
                  http://www.searchlinux.com

 
 
 

xmms (x11amp) glib/gtk+ RH6 Newbie install

Post by Jeremi » Sun, 31 Dec 1899 09:00:00




Quote:> I'm trying to install xmms-0.9.1-1.i386.rpm and in doing an rpm -ivh, it
> tells me that I have unresolved dependencies, namely glib and gtk+ must be
>>1.2.2

> I downloaded
>    gtk+-1.2.2-1.i386.rpm and
>    glib-1.2.2-1.i386.rpm
> but also saw a glib-devel and gtk+-devel...rpm's
> Do I need these "devel" libraries?

        You only need them if you're planning on building things from
source, or building your own RPMs from source RPMs.

Quote:> Is it OK for the "devel" libraries to be out of "synch"?

        I don't believe that RPM will let you...  that is, if you
try to install glib-1.2.2 over glib-1.2.1 and glib-devel-1.2.1, you'll
get an error: 'glib-devel-1.2.1 needs glib-1.2.1' or something.  My
advice: use the -test flag to rpm to test things before you do them.

Quote:> To install glib and gtk+, do I just
>    rpm -Uvh glib-1.2.2-1.i386.rpm and
>    rpm -Uvh gtk+-1.2.2-1.i386.rpm

> and then
>    rpm -ivh xmms-0.9.1-1.i386.rpm

        Yeah, that sounds about right...  as I said, you might want to
try them all with the '-test' flag first, so that you don't run into
any unfortunate surprises.  It's a little redundant, but better safe
than sorry, IMO.

Quote:> Do I have to uninstall X11amp beta first? (rpm -e)

        It's probably a good idea.  I don't think Xmms will automatically
uninstall it, since it's a different name.  

Quote:> This sounds TOO easy

        Who said everything about Linux is difficult?   :)

Quote:> and as you can tell, I'm worrying about screwing up
> big time here. I've read that I can do that in searching about xmms and the
> glib/gtk+ libraries!

        There was a big change a while back going from glib-1.0.6 and
gtk+-1.0.6 to glib-1.2 and gtk+-1.0.6.  It was possible to royally
*up your system, especially since a lot of apps still required
gtk+-1.0.6 and glib-1.0.6.  You shouldn't have too many problems since
you're only going from 1.2.1 -> 1.2.2.  

Brian
--
email to bmeloon1 at twcny dot rr dot com.   evilquaker is a spam collector

 
 
 

xmms (x11amp) glib/gtk+ RH6 Newbie install

Post by Dave Esque » Sun, 31 Dec 1899 09:00:00


Thanks, Jeremiah, I'll give it a shot!

Dave

------------------  Posted via SearchLinux  ------------------
                  http://www.searchlinux.com

 
 
 

xmms (x11amp) glib/gtk+ RH6 Newbie install

Post by Dave Esque » Sun, 31 Dec 1899 09:00:00


Greetings,
I'm trying to install xmms-0.9.1-1.i386.rpm and in doing an rpm -ivh, it
tells me that I have unresolved dependencies, namely glib and gtk+ must be

Quote:>1.2.2

I downloaded
        gtk+-1.2.2-1.i386.rpm and
        glib-1.2.2-1.i386.rpm

but also saw a glib-devel and gtk+-devel...rpm's

Do I need these "devel" libraries? Is it OK for the "devel" libraries to be
out of "synch"?

To install glib and gtk+, do I just
        rpm -Uvh glib-1.2.2-1.i386.rpm and
        rpm -Uvh gtk+-1.2.2-1.i386.rpm

and then
        rpm -ivh xmms-0.9.1-1.i386.rpm

Do I have to uninstall X11amp beta first? (rpm -e)

This sounds TOO easy and as you can tell, I'm worrying about screwing up
big time here. I've read that I can do that in searching about xmms and the
glib/gtk+ libraries!

(With rpm -q, I notice that I have glib and gtk+ versions of 1.2.1.2 and
1.2.1-10 respectively)

TIA,
Dave

------------------  Posted via SearchLinux  ------------------
                  http://www.searchlinux.com

 
 
 

xmms (x11amp) glib/gtk+ RH6 Newbie install

Post by Dave Esque » Sun, 31 Dec 1899 09:00:00


Thanks, Jeremiah, I'll give it a shot!

Dave

------------------  Posted via SearchLinux  ------------------
                  http://www.searchlinux.com

 
 
 

xmms (x11amp) glib/gtk+ RH6 Newbie install

Post by Marc Childre » Sun, 31 Dec 1899 09:00:00


Current versions of glib and gtk are 1.2.6

Marc Childress



Quote:> Greetings,
> I'm trying to install xmms-0.9.1-1.i386.rpm and in doing an rpm -ivh, it
> tells me that I have unresolved dependencies, namely glib and gtk+ must be
>>1.2.2

> I downloaded
>    gtk+-1.2.2-1.i386.rpm and
>    glib-1.2.2-1.i386.rpm

> but also saw a glib-devel and gtk+-devel...rpm's

> Do I need these "devel" libraries? Is it OK for the "devel" libraries to be
> out of "synch"?

> To install glib and gtk+, do I just
>    rpm -Uvh glib-1.2.2-1.i386.rpm and
>    rpm -Uvh gtk+-1.2.2-1.i386.rpm

> and then
>    rpm -ivh xmms-0.9.1-1.i386.rpm

> Do I have to uninstall X11amp beta first? (rpm -e)

> This sounds TOO easy and as you can tell, I'm worrying about screwing up
> big time here. I've read that I can do that in searching about xmms and the
> glib/gtk+ libraries!

> (With rpm -q, I notice that I have glib and gtk+ versions of 1.2.1.2 and
> 1.2.1-10 respectively)

> TIA,
> Dave

> ------------------  Posted via SearchLinux  ------------------
>                   http://www.searchlinux.com

 
 
 

1. glib/gtk+/x11amp installation

Hi
    I need some help on installing x11amp on Redhat 5.2.
    Using rpm -q, the system reports I have glibc-2.0.7-29, glib-1.0.6-3
and gtk+-1.0.6-3 installed.
    I downloaded glib and gtk+ 1.2 in rpm form. However, when I tried to
install glib, I got the following error


failed dependencies:
        libc.so.6(GLIBC_2.0) is needed by glib-1.2.1-2
        libdl.so.2(GLIBC_2.1) is needed by glib-1.2.1-2
        libdl.so.2(GLIBC_2.0) is needed by glib-1.2.1-2
        libpthread.so.0(GLIBC_2.0) is needed by glib-1.2.1-2
        glib = 1.0.6 is needed by gtk+-1.0.6-3
        libglib.so.1 is needed by AfterStep-APPS-1.5-0.3
        libglib.so.1 is needed by control-panel-3.7-7
        libglib.so.1 is needed by gecko-1.6-0
        libglib.so.1 is needed by gnome-libs-0.20-3
        libglib.so.1 is needed by gnome-linuxconf-0.14-4rh
        libglib.so.1 is needed by usermode-1.4.3-1
        libglib.so.1 is needed by usernet-1.0.8-1
        libglib.so.1 is needed by wmakerconf-1.1.1-3

How should I proceed? Thanks for any suggestions.
W Gemini

2. Change email

3. gtk+ wont install because of glib

4. some permission issues

5. Compile/Install problem with glib-1.2.10 and gtk+1.2.10

6. FIPS does not recognize free space

7. Trouble installing GLIB and GTK+

8. passwd problems

9. How to install gtk+ and glib in Redhat 5.0

10. Can't install glib and gtk 1.2.1

11. Installing GTK+/glib

12. glib-1.2.3 and gtk-1.2.3 install problem

13. How to install gtk+ / glib