XFree86 Menus are Black on Black

XFree86 Menus are Black on Black

Post by Aril » Mon, 03 May 1999 04:00:00




> After many attempts at Xconfigurator I finally got X running using
> xf86config with my new Red Hat 5.2 Linux BUT:

> --  The menu items are all black writing on black background.  It took me 10
> minutes of random menu popping just to get X to shut down neatly.  A lot of
> the windows I have randomly started also seem to be black on black.

> --  Is there a file where I can change the background colours or the text
> colours on the menus??

> I have an ATI Mach64 video card if this matters.

> Can anyone please help.

> Anthony

  This is interesting.... I had an Mach64 Rage II+DVD and could'nt get it to
function on RH5.1 or 5.2. Whenever I did a startX I would get a black screen.
Could it be that it was black on black? I got the card working with the SVGA
sever but only at a really low resolution. Finally I bought a new card after
days of frustration. if you find anything out, please let us know. I could
really use that card on another box.

Thanx,
Arilu

 
 
 

XFree86 Menus are Black on Black

Post by Steve Smoog » Tue, 04 May 1999 04:00:00


Hi, you are probably running into the 256 or 16 color problem. What is
happening is that for some reason X is that the window manager and such
are "sucking" up all the colors so that xterms get allocated black for
the foreground and white as the background.

To test this try the following:

edit your ~/.xinitrc file to have the following entries:

xterm -fg white -bg black &
fvwm

and then run

startx &> startx.out

you should get normal output.



>> After many attempts at Xconfigurator I finally got X running using
>> xf86config with my new Red Hat 5.2 Linux BUT:

>> --  The menu items are all black writing on black background.  It took me 10
>> minutes of random menu popping just to get X to shut down neatly.  A lot of
>> the windows I have randomly started also seem to be black on black.

>> --  Is there a file where I can change the background colours or the text
>> colours on the menus??

>> I have an ATI Mach64 video card if this matters.

>> Can anyone please help.

>> Anthony

>  This is interesting.... I had an Mach64 Rage II+DVD and could'nt get it to
>function on RH5.1 or 5.2. Whenever I did a startX I would get a black screen.
>Could it be that it was black on black? I got the card working with the SVGA
>sever but only at a really low resolution. Finally I bought a new card after
>days of frustration. if you find anything out, please let us know. I could
>really use that card on another box.

>Thanx,
>Arilu

--

SJS

 
 
 

1. XFree86 Menus are Black on Black

After many attempts at Xconfigurator I finally got X running using
xf86config with my new Red Hat 5.2 Linux BUT:

--  The menu items are all black writing on black background.  It took me 10
minutes of randon memu popping just to get X to shut down neatly.  A lot of
the windows I have reandomly started also seem to be blanck on black.

--  Is there a file where I can change the background colours or the text
colours on the menus??

I have an ATI Mach64 video card if this matters.

Can anyone please help.

Anthony

2. runq

3. Netscape 3.0 menu text ok, 4.07 is black on black

4. How to print all man pages ?

5. Weird problem with Red Hat & Storm setup - text displays black on black background

6. Problems with CD-ROM and Busmouse and a question about SB16

7. Sol9: CDE: how to flip dtterm to white on black, yellow on black, ...?

8. Linux @ HP Netserver LH 5/100

9. terminal: black text on black background. Please help...

10. Exiting X -> nice black-on-black text on all VC

11. Soln: Mouse pointer lacks white border (black pointer on black background)

12. X11 question: black != black

13. Black text on a black background