HOSTNAME and hosts in /etc/ don't work

HOSTNAME and hosts in /etc/ don't work

Post by Robert W Curre » Fri, 03 Oct 1997 04:00:00



I edited my "HOSTNAME" and "hosts" in /etc/ to a new name "bohr" and when
I log in I still get the old host name "darwin" at the prompt and login
screens.

When I try to telnet to myself, I type "telnet darwin" and it doesn't
work, and I type "telnet bohr" and it does work.

If I do "hostname bohr" as root, it changes it, but as soon as I reboot,
it's back to the old name.  What am I doing wrong?

--
Robert Wesley Current Jr.
http://www.mainquad.com/web/rcurrent/

University of North Dakota         _/ | _
Department of Chemistry           /'  `'/
Office Phone (701)777-2541      <~    .'
ACS, AAAS, NDAS                 .'    |
                              _/      |
                            _/      `.`.
                    _______/ '   \__ | |______
##################_/ (|___/      /__\ \ \     \___.#######################
#################/    \___.'\_______)\_|_|        \#######################
################|\                                 -----\#################
################| \____________________________________/|#################
###############/   |                                    |#################

 
 
 

1. lp /etc/hosts get Get_local_host: hostname 'randm.' bad

Turbolinux 6.0

I can print by redirecting output to /dev/lp0 but lp and its associated
utilities lpc and lpq all return the subject message. The host name in the
hosts file is randm with no period. I have looked through the printcap file
(no hostname there) also looked through /etc/lpd.conf (everything is
commented out, it just documents the defaults). The /etc/hosts file looks
like

127.0.0.1            localhost
192.168.1.201     randm
192.168.1.1        woofer
192.168.1.202    2ndfloor
192.168.1.200    tr-lebowmarem

I dont get where lp is getting the hostname.

Also, when I do a startx, GNOME lets me know that it cannot find randm.
either.

2. uEmacs permissions/ownership bug?

3. Can't get this to work if Hostname and Domain don't match.

4. Reading FreeBSD partition from DOS

5. Use hostname or hostname.domain.name in /etc/hosts??

6. error notification AIX 4.1.5

7. HOSTNAME DON'T WORK IN DHCP CLIENT WIN98

8. SLIP

9. Win2k to Linux 7.2: hostnames worked, now they don't

10. 'host' command not using /etc/hosts?

11. SOLUTIONS TO: /etc/rc.net, /etc/host.conf and 'ps' problems

12. Virtual hosts don't work at all with Apache in SuSE 7.0

13. apache virtual hosts don't work with new kernel