Problem Running X-Windows (only root runs)

Problem Running X-Windows (only root runs)

Post by Jos » Mon, 24 May 1999 04:00:00



Hello!

I've installed recently the X11 (Release 6.3) that came with the PPC
Linux Release 4. The computer is a PowerMac G3, and was installed with
the Red Hat Distribution.

Running "startx" as root, works fine, but if I try to access using any
of the regular users account, I get this:

Fatal Server Error
Xpmac: Server must be setuid -root
Xconnection to: 0.0 broken (explicit kill or xserver shutdown)

I've been searching the man, but I've found nothing useful. Please,
help!

Thanks in advance

jose

 
 
 

Problem Running X-Windows (only root runs)

Post by Adrian Hand » Mon, 24 May 1999 04:00:00



> Hello!

> I've installed recently the X11 (Release 6.3) that came with the PPC
> Linux Release 4. The computer is a PowerMac G3, and was installed with
> the Red Hat Distribution.

> Running "startx" as root, works fine, but if I try to access using any
> of the regular users account, I get this:

> Fatal Server Error
> Xpmac: Server must be setuid -root
> Xconnection to: 0.0 broken (explicit kill or xserver shutdown)

I've never used a Mac, but on the Intels the file /usr/X11/bin/Xwrapper
must be setuid root:

$ ls -l /usr/X11/bin/Xwrapper
-rws--x--x   1 root     root         6116 Apr 18 19:33
/usr/X11/bin/Xwrapper
$

From the error message your getting, I'd assume you have a file named
Xpmac which shuld be setuid root but is not.  Find that file and "ls -l"
it.  The owner should be "root" and the fourth bit in the permissions
should be "s" (as above).  If it's not, "su" to root and do this:

# chown root Xpmac
# chmod u+s Xpmac

Then try it again!

-Adrian

 
 
 

Problem Running X-Windows (only root runs)

Post by David Tabachniko » Fri, 28 May 1999 04:00:00


You need to suid the server you use (Do an ln -l /usr/X11R6/bin/X, and see
where it points, and suid root it...)


> Hello!

> I've installed recently the X11 (Release 6.3) that came with the PPC
> Linux Release 4. The computer is a PowerMac G3, and was installed with
> the Red Hat Distribution.

> Running "startx" as root, works fine, but if I try to access using any
> of the regular users account, I get this:

> Fatal Server Error
> Xpmac: Server must be setuid -root
> Xconnection to: 0.0 broken (explicit kill or xserver shutdown)

> I've been searching the man, but I've found nothing useful. Please,
> help!

> Thanks in advance

> jose

--
David Tabachnikov
Second Horizon
Phone: (972) 53-451994 (Mobile);
          (972) 7-6710237 (Home)

UIN 3600179
--
DDT rox!!! Rock'n'roll lives!
Long live DDT 'n ROCK'n'ROLL!
 
 
 

1. After Install X-windows comes up I run Xterm, X-windows quits

Hi,
    I am trying to get X-Windows setup with an unknown
type of Cirrus Logic "SIIG" ISA graphics card. I only seem to get
some response when I set it up with Xconfigurator in 8-bit mode.
I am using Redhat 6.1 and KDE. The KDE desktop comes up
after a while. When I click on the Xterm icon, there is a delay,
the Xterm window comes up and just as it comes up, X-Windows
drops back to the Linux shell. There is a message:

QImage::color:Index out of range.

  What does this mean and how can I correct the problem.
   Is there any way that I can find out exactly what model
   of card that I have. There is a model number, but it does
   not look like anything related to what is in the Xconfigurator
   list nor on the SIIG site. The model is MVGA-AVGA3.
   I have a dual boot system and the card works with the Linux
   shell and Win95C with a resolution of 1024x768 and 16 bit
   hicolor.
                                                    Thanks
                                                                Mike

2. newbie beep assistance

3. Run X-Windows programs from Windows Workstation?

4. CD?

5. Problems running X-Windows

6. clock problem

7. problem running X-windows on DIAMOND S3 VIRGE 3D

8. Xerox Network printer problem

9. Problem Getting Exceed X-Windows Emulator to Run Through My Router

10. Problem in running X-Windows

11. problems running windows after running minilinux

12. X-windows in Windows 95 and type writers in X-windows

13. How can run X-Windows in my pc with mini-linux?