Kernel

Kernel

Post by Ernest Pellegrino » Tue, 21 Apr 1998 04:00:00



    I compiled 3 different kernels and can not get any of them to boot
i get :

          trying to unmout old root....okay

and then it just hangs.  i dir make dep; make clean then make zImage
then make modules then make modules_install then ran lilo it added the
kernel to the menu but when it boots it loads up to the point above
then hangs.  Any info would be appreciated.

Chip Pellegrino

 
 
 

1. aha1542, module vs kernel, kernel doesn't work, need kernel

The reason I need it as kernel code is so that I can put /usr on a
seperate 8.2g drive.

When aha1542 is built as a module, it pops up immediately before the
login screen, and everything works as planned.

Remaking the kernel with it set to be kernel code, it starts the bus
scan during the boot, not too long after the ide devices are found, but
then goes into a double loop of resetting the device 2-4 times, then the
whole bus, then repeats the device, all the while saying it can't abort
the call, but evertually it will find the drive at address 0 on the bus
and go on, at which point it repeats this procedure for address one,
each pass thru the loop taking about 5 minutes, finding the quatum 8.2g
at each addreess in turn until it gets to address 4, at which point the
discovery phase eventually finds a Colorado T4000s at address 4, which
is its correct address, then also at 5 & 6.

Then it apparently repeats the loop, asking each device for its capacity
details, and going through this same error recovery time killer, except
that this time it only gets partial answers only, and only at the
correct address for the device.

I let it go through all that, and finally got a login screen and did so,
but was unable to open either device, not even with fdisk /dev/sda.

I've used several of these cards in years past, and have always had to
edit the source to lower the address of its port by 0x100, to the 0x230
area, and to reset the irq from 11 to 10.  Without those changes the
module doesn't init itself, ever, and it has required those changes to
the code in order to function on 3 different motherboards I've run it
on.

But here, I need the direct in the kernel version so I can put /usr on
it.  Put it in the kernel, and it fails miserably, both for 2.2.18,
2.2.19, and 2.4.2.  The 2.4.2 failure surprised me as that code has a
diff that looks to be in excess of 10k from the older code.

So why can't I put aha1542.o into the (apparently any) kernel?
Inquiring minds want to know. (-;

Cheers, Gene
--

        email gene underscore heskett at iolinc dot net
#Amiga based X10 home automation program EZHome, see at:#
 <http://www.iolinc.net/gene_heskett>
This messages reply content, but not any previously quoted material,
is ? 2001 by Gene Heskett, all rights reserved.  Due to recent
changes in M$ lusers TOS, mail from msn.com, msn.net, microsoft.com,
microsoft.net, hotmail.com, and hotmail.net is auto-deleted, unread.
--

2. chroot security

3. proposal: feed smaller mailing lists into linux-kernel, add linux-kernel-core and linux-kernel-bugs

4. PHP Passing variables

5. Kernel configuration in kernel, kernel 2.4.20

6. Red Hat and PPP

7. redhat 9 kernel diff from kernel.org kernel?

8. switched console and dumb terminal! help!

9. Kernel configuration in kernel, kernel 2.5.53

10. ALERTE: VIRUS DETECTE DANS UN MESSAGE ENVOYE PAR linux-kernel-owner@vger.kernel.org

11. "kernel version needed..." problem creating RedHat kernel???

12. [Kernel Q} What happended to "sema" and other kernel symbols in aix4.3.2 ???

13. not inline code in kernel (reducing kernel size)