Hylafax "localhost" unknown host?

Hylafax "localhost" unknown host?

Post by Eliot Sabath-Levit » Mon, 23 Dec 1996 04:00:00



I just installed hylafax tonight.  (Latest version, 4.0pl1 or something
like that.)

I faxsetup claims that I do have a faxq running, but when I try to get
fastat to tell me how it's doing, I get a "localhost" unknown host
message.


localhost), but once I started getting that message, I rebooted and have
also changed my /var/spool/fax/etc/hosts file to list

Any clues?

Thanks!

(Newbie--Day 4!!!)

 
 
 

Hylafax "localhost" unknown host?

Post by Brian Wo » Sat, 28 Dec 1996 04:00:00


: I just installed hylafax tonight.  (Latest version, 4.0pl1 or something
: like that.)

: I faxsetup claims that I do have a faxq running, but when I try to get
: fastat to tell me how it's doing, I get a "localhost" unknown host
: message.


: localhost), but once I started getting that message, I rebooted and have
: also changed my /var/spool/fax/etc/hosts file to list

The "localhost" being referred to is not your (or anyone elses) machine
name but rather the "loopback" entry in your host table. Do a "route"
command to check that you have such an entry. Also make sure that your
kernel is configured for "loopback" support. Loopback is basically a
way for programs that communicate via network to talk to the local
machine even if you don't have any other network connection running.

: (Newbie--Day 4!!!)

If you have got this far in four days you are far above average :-)

--
Brian E.W. Wood

"Would you put your money in a bank which used Windows '95 to manage accounts?"

 
 
 

1. named: "found it", ping: "unknown host"

Dear All

Soory, this looks much like a standard Unix question:

Applications can't resolve some addresses of my domain and only from my
Linux PC: all those who starts with the same group of letters as the
Linux PC itself, i.e.: tvn_pc, tvn_xt, tvn_lap. The Linux box's name is
tvn_linux. I don't have such problem with my other Unix boes nor my
PC's.

1/ I've setup a local named to monitor the name resolution: it's Ok.
named finds it but the invoking application don't get it.
2/ My resolv.conf has a search onto my subdomain and main domain.
3/ My nsswitch.conf says  hosts: dns [NOTFOUND=continue] files

If I put an entry in the /etc/hosts: it works.

How can it be doing this?

Many thanks,
Thierry de Villeneuve

----


ping: unknown host tvn_pc

----

the /var/tpm/named.run (Intranet names and IPs edited) reports:

datagram from [192.4.209.73].1370, fd 22, len 35; now Fri Jun 12
09:46:44 1998
ns_req(from=[192.4.209.73].1370)
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 59847
;; flags: rd; Ques: 1, Ans: 0, Auth: 0, Addit: 0
;; QUESTIONS:
;;      tvn_pc.rbc.st.com, type = A, class = IN

req: nlookup(tvn_pc.rbc.tt.com) id 59847 type=1 class=1
req: found 'tvn_pc.rbc.tt.com' as 'tvn_pc.rbc.tt.com' (cname=0)
wanted(0x8079988, 1, 1) [IN A]
make_rr(tvn_pc.rbc.tt.com, 8079988, bffffc1b, 465, 1) 4 zone 0 ttl
897753892
finddata: added 1 class 1 type 1 RRs
req: foundname=1, count=1, founddata=1, cname=0
sort_response(1)
findns: np 0x8078140 'tvn_pc'
match(0x8079988, 1, 2) 1, 1
findns: np 0x8079d10 'rbc'
match(0x8077f28, 1, 2) 1, 6
match(0x80780a0, 1, 2) 1, 2
findns: 1 NS's added for 'rbc'
make_rr(rbc.st.com, 80780a0, bffffc2b, 449, 1) 17 zone 0 ttl 897754724
free_nsp: rbdns.rbc.tt.com rcnt 1
doaddinfo() addcount = 1
do additional "rbdns.rbc.tt.com" (from "rbc.tt.com")
found it
match(0x8078fd0, 1, 5) 1, 1
match(0x8078fd0, 1, 5) 1, 1
match(0x8078fd0, 1, 1) 1, 1
make_rr(rbdns.rbc.st.com, 8078fd0, bffffc49, 419, 0) 4 zone 0 ttl
897754724
addinfo: adding address data n = 16
ns_req: answer -> [192.4.209.73].1370 fd=22 id=59847 size=97 Local

2. Top for Solaris 2.5.1 x86?

3. GETSERVBYNAME()????????????????????"""""""""""""

4. compiling kernel 0.99p10 with 4.4 includes

5. ...after installing "Hylafax" and the dependecy "bash2" no editor working :-((

6. udma on a BX board

7. """"""""My SoundBlast 16 pnp isn't up yet""""""""""""

8. HP Colorado T3000, Exabyte TR-3, or Iomega DE 3200

9. sendmail saying "My unqualified hostname (localhost) unknown; sleeping for retry"

10. "127.1" works, but "localhost" does not!

11. Hylafax and it's "etc/hosts" file

12. "syslogd: unknown priority "24" " error - won't boot!

13. Help: "unallocated sectors", "unknown system for swap partition".