Debian Woody dependency libc6-2.2.5-13

Debian Woody dependency libc6-2.2.5-13

Post by Eike Lantzsch, ZP6CG » Sun, 12 Jan 2003 22:24:51



Hi:

On Debian Woody I install kde-theme-liquid-0.9.5.deb with
"dpkg --ignore-depends=libc6 -i" because it wants
libc6-2.2.5-13 but on my system is libc6-2.2.5-11.2.
Of course every "apt-get -f install" kicks my theme out with
this unmet dependency.
I think it doesn't matter if I have one or the other libc6.
It's just another build. But how can I solve the dependency
so apt-get leaves kde-theme-liquid as it is?

And no, kde-theme-liquid-0.9.6 is not an option because for
now I'll stay with KDE 3.0.5a

Thanx and kind regards, Eike

 
 
 

Debian Woody dependency libc6-2.2.5-13

Post by Colin Watso » Wed, 15 Jan 2003 11:17:00



Quote:>On Debian Woody I install kde-theme-liquid-0.9.5.deb with
>"dpkg --ignore-depends=libc6 -i" because it wants
>libc6-2.2.5-13 but on my system is libc6-2.2.5-11.2.

Fetch the source for that version of kde-theme-liquid and rebuild it on
your system. With build-essential and fakeroot installed plus whatever's
in the Build-Depends: field from debian/control in the unpacked source,
'dpkg-buildpackage -rfakeroot -B -uc -us' should get you a binary
package.

Quote:>Of course every "apt-get -f install" kicks my theme out with
>this unmet dependency.
>I think it doesn't matter if I have one or the other libc6.
>It's just another build.

The shared library dependency for packages built against libc6 was
bumped for a reason, and not a trivial one in the case of 2.2.5-13: its
minimum kernel support was changed and db1 support was removed. It
*might* not matter in this case, but I would strongly advise against
ignoring it. It will only bring you grief later.

Cheers,

--


 
 
 

Debian Woody dependency libc6-2.2.5-13

Post by Eike Lantzsch, ZP6CG » Sat, 18 Jan 2003 03:07:21


[original post snipped]

Quote:

>  Fetch the source for that version of kde-theme-liquid and rebuild it on
>  your system. With build-essential and fakeroot installed plus whatever's
>  in the Build-Depends: field from debian/control in the unpacked source,
>  'dpkg-buildpackage -rfakeroot -B -uc -us' should get you a binary
>  package.

Ah ha, yes I read the New Package Maintainer's Guide...
Also now I better understand the "little numbers", following
the version.

Quote:>  The shared library dependency for packages built against libc6 was
>  bumped for a reason, and not a trivial one in the case of 2.2.5-13: its
>  minimum kernel support was changed and db1 support was removed. It
>  *might* not matter in this case, but I would strongly advise against
>  ignoring it. It will only bring you grief later.

                   ^^^^      ^^^^^^^^^^^^^^^^^^^^^
Yes, especially with other packages than mosfet-liquid.
Thank you for the enlightenment. I pondered to compile but decided
now to upgrade to libc6-2.2.5-14 instead, because of the increasing
amount of packages demanding libc6 to be later than 2.2.5-13.
This worked out OK.

By the way: I find it amazing how easy upgrades are with Debian.
Especially glibc upgrades used to be a nightmare with other
distributions - not to mention Xfree86....

[F'up set to linux.debian.user]

Thank you again.
Kind regards, Eike

 
 
 

1. How I upgraded to debian-stable (potato) to debian-testing (woody)

How I upgraded to debian-stable (potato) to debian-testing (woody).

This is acctually a pretty straight forward problem. Start by checking
/etc/apt/sources.list this file contains arcives of .deb-packages.

My old file looked something like this:

deb http://http.us.debian.org/debian stable main contrib non-free
deb http://non-us.debian.org/debian-non-US stable/non-US main contrib
non-free
deb http://security.debian.org stable/updates main contrib non-free

change these lines to:

deb http://http.us.debian.org/debian testing main contrib non-free
deb http://http.us.debian.org/debian dists/proposed-updates/
deb http://non-us.debian.org/debian-non-US testing/non-US main contrib
non-free
deb http://non-us.debian.org/debian-non-US dists/proposed-updates/

You have to delete the security.debian.org site since there are no security
patches for testing/unstable.

when you have done this issue the following commands as root:

apt-get update
apt-get -f dist-upgrade

OBSERVE. THERE IS NO GUARANTEE THAT THIS WILL WORK. For me it did (no
problems what so ever). Be sure to backup anything important.

If a problem arises (the machine crashes or whatever) just issue the
commands again.

That should be it ;) (see how easy it is all you .rpm-ppl)

Bonus: how to install Ximian-GNOME 1.4beta and KDE 2.1

add the following lines to /etc/apt/sources.list

deb http://spidermonkey.ximian.com/1.4beta1/distributions/debian unstable
main
deb http://spidermonkey.ximian.com/evolution-snapshots/distributions/Debian
unstable main

deb http://kde.tdyc.com potato main crypto optional qt1apps

and run 'apt-get update' and then 'apt-get -f dist-upgrade'

(if you don't have KDE installed before do a 'apt-get install task-kde')

GNOME and KDE2 works in potato too. So you can skip the first part if you
want to run them in potato ;)

/john

2. NetBSD Networking Problems

3. S3 mx + xfree 3.3.2-13

4. Tru64 v5.1 Security

5. ATI Radeon O.S. driver XFree86-4.2.1-13 Locking up laptop

6. |& in csh--equivalent in ksh?

7. RedHat 7.2 and Geforce2mx with 2.4.9-13 Kernel

8. Problem with Soundblaster PRO compatible card

9. RedHat 2.4.7 & 2.4.9-13 Poweroff failure

10. A few problems using 2.2.17-13-ben1

11. KERNEL-COMPILE-GUIDE [-13]

12. Redhat 7.2: 1GIG ram = boot failures (2.4.9-13 kernel)

13. Booting Linux (2.4.9-13) hangs up