lost zip drive after kernel upgrade

lost zip drive after kernel upgrade

Post by Ramin Sin » Thu, 22 Oct 1998 04:00:00



Hi all,

I just ubgraded to 2.0.35 and, even though I enabled iomega parallel
port zip in the SCSI entry during the upgrade, I have lost usage of zip
drive: mount gives me an etror message that kernel does not recognize
/dev/sda4 as a block. How do I fix that?

Thanks,
Ramin Sina

 
 
 

lost zip drive after kernel upgrade

Post by Brian F. G. Biduloc » Fri, 23 Oct 1998 04:00:00



> I just ubgraded to 2.0.35 [...]

Recompile the kernel with Iomega ZIP/JAZ support
enabled.

--
Brian F. G. Bidulock, P. Eng.,
Group Leader - Innovation Center
Bell Emergis - Sonaris
613-725-6582

 
 
 

lost zip drive after kernel upgrade

Post by j » Fri, 23 Oct 1998 04:00:00




Quote:>I just ubgraded to 2.0.35 and, even though I enabled iomega parallel
>port zip in the SCSI entry during the upgrade, I have lost usage of zip
>drive: mount gives me an etror message that kernel does not recognize
>/dev/sda4 as a block. How do I fix that?

Have you turned on SCSI disk support in make xconfig?
 
 
 

lost zip drive after kernel upgrade

Post by Ramin Sin » Fri, 23 Oct 1998 04:00:00





> >I just ubgraded to 2.0.35 and, even though I enabled iomega parallel
> >port zip in the SCSI entry during the upgrade, I have lost usage of zip
> >drive: mount gives me an etror message that kernel does not recognize
> >/dev/sda4 as a block. How do I fix that?
> Have you turned on SCSI disk support in make xconfig?

 Hi jc and thaks for your response. As I said above, yes, I did enable
iomega in scsi in menuconfig. Maybe I need to do something with mknod or
insmod?? I am totally confused here.

Cheers,

--
--------------------------------------------------------

 
 
 

lost zip drive after kernel upgrade

Post by Kyle Dansi » Mon, 26 Oct 1998 03:00:00


If you set ppa as a module, then you need to insmod ppa before you can
use it.

Also make sure that the lp (printer) is also a module and that you load
ppa BEFORE you load lp. Sometimes lp will tie up the port so that ppa
can not get to it. You can use lsmod to list modules loaded already. Use
rmmod to remove a module, then use insmod to load it at a latter time.

Good Luck,
Kyle Dansie
--
--------------------------------------------------------
Linux Rules
          ZIP drive Mini-HOWTO
http://njtcom.com/dansie/zip-drive.html
                    or
http://sunsite.unc.edu/mdw/HOWTO/mini/ZIP-Drive.html                                  
--------------------------------------------------------

 
 
 

lost zip drive after kernel upgrade

Post by Jerry Lynn Krep » Mon, 26 Oct 1998 03:00:00



> If you set ppa as a module, then you need to insmod ppa before you can
> use it.

> Also make sure that the lp (printer) is also a module and that you load
> ppa BEFORE you load lp. Sometimes lp will tie up the port so that ppa
> can not get to it. You can use lsmod to list modules loaded already. Use
> rmmod to remove a module, then use insmod to load it at a latter time.

I found it easier and more reliable to purchase a cheap bi-directional
parallel printer card.  It cost about $30 and went in as lp1.  Never any
problems between the printer deamon and the ppa module that drives the
zip.
 
 
 

1. lost zip drive when upgrading to Mandrake 9.0?

Hi,

I can no longer mount my zip drive after upgrading to Mandrake 9.0

Here are the details:

mount: special device /dev/hdd4 does not exist

lr-xr-xr-x 1 root root 33 Apr 9 16:23 /dev/hdd4 ->
ide/host0/bus1/target1/lun0/part4

total 0
drwxr-xr-x 1 root root 0 Dec 31 1969 ./
drwxr-xr-x 1 root root 0 Dec 31 1969 ../
brw------- 1 root root 22, 64 Dec 31 1969 generic

isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found

Kernel command line: auto BOOT_IMAGE=linux ro root=306 devfs=mount
hdc=ide-scsi hdd=ide-scsi
ide_setup: hdd=ide-scsi
ide1: BM-DMA at 0xd808-0xd80f, BIOS settings: hdc:DMA, hdd:pio
hdd: IOMEGA ZIP 100 ATAPI Floppy, ATAPI FLOPPY drive

user,iocharset=iso8859-1,umask=0,sync,exec,codepa /dev/hdd4 /mnt/zip
auto ge=850,noauto 0 0

Any ideas?

Thanks in advance!

David

2. x86 boot diskette

3. lost slip in kernel compiled for zip drive

4. FTP Daemon.

5. Recompiled kernel, lost atapi zip drive,ppp permission

6. Help needed ! (scsi : aborting command due to timeout)

7. ppa (zip drive) module won't load after kernel upgrade

8. Does mgetty-sendfax work with Zoom Faxmodem?

9. upgraded kernel-- lost floppy drive

10. HELP: IDE ZIP drive and Red hat, cannot access Zip drive

11. lp1 is lost after installing Zip drive.

12. Newbie: Lost interrupt with Zip-100 drive

13. Mountin ZIP drive in RH7.1 after upgrade??