Cirrus 5434 with 50Mhz Bus

Cirrus 5434 with 50Mhz Bus

Post by Andrew Rive » Sat, 27 Jan 1996 04:00:00



I have a problem with my Cirrus Logic 5434 PCI 2MB Dram and a P-100 with
a bus speed of 50, or 66Mhz.  I can only run SVGA XFree86 3.1.2 Server with
the accelerated options disabled, which losses all the benfits of the card.  
I am running this all under Linux, Slackware 3.0.0, kernel 1.2.13.

Has anybody else had this problem, and know how to fix it?

Thanx,
Andrew Rivett

 
 
 

Cirrus 5434 with 50Mhz Bus

Post by Mats Andtbac » Sun, 28 Jan 1996 04:00:00



Quote:>I have a problem with my Cirrus Logic 5434 PCI 2MB Dram and a P-100 with
>a bus speed of 50, or 66Mhz.  I can only run SVGA XFree86 3.1.2 Server with
>the accelerated options disabled, which losses all the benfits of the card.  
>I am running this all under Linux, Slackware 3.0.0, kernel 1.2.13.
>Has anybody else had this problem, and know how to fix it?

i'm running a 1MB 5434 PCI accelerated under XFree86 3.1.1 with no
problems. are you sure that downclocking your PCI bus to something the
PCI bus is actually specified to run at is not an option? because you
seem to be running it about twice as fast as you should.
--
" ... this is the first day of my last days ... "     -- nin

 
 
 

Cirrus 5434 with 50Mhz Bus

Post by Andrew Rive » Mon, 29 Jan 1996 04:00:00



: >I have a problem with my Cirrus Logic 5434 PCI 2MB Dram and a P-100 with
: >a bus speed of 50, or 66Mhz.  I can only run SVGA XFree86 3.1.2 Server with
: >the accelerated options disabled, which losses all the benfits of the card.  
: >I am running this all under Linux, Slackware 3.0.0, kernel 1.2.13.
: >Has anybody else had this problem, and know how to fix it?

: i'm running a 1MB 5434 PCI accelerated under XFree86 3.1.1 with no
: problems. are you sure that downclocking your PCI bus to something the
: PCI bus is actually specified to run at is not an option? because you
: seem to be running it about twice as fast as you should.

I checked the manual for the motherboard, and the lowest setting is 50Mhz for
the bus.  It is the Intel Triton Chipset.

Andrew.

 
 
 

Cirrus 5434 with 50Mhz Bus

Post by Mats Andtbac » Tue, 30 Jan 1996 04:00:00




>: i'm running a 1MB 5434 PCI accelerated under XFree86 3.1.1 with no
>: problems. are you sure that downclocking your PCI bus to something the
>: PCI bus is actually specified to run at is not an option? because you
>: seem to be running it about twice as fast as you should.
>I checked the manual for the motherboard, and the lowest setting is 50Mhz for
>the bus.  It is the Intel Triton Chipset.

hm. i'm afraid i can't really help then, but thanks for confirming
that i'll never buy a Triton... AFAIK the PCI spec still mentions
33MHz as top speed, unless anyone can prove me wrong(?) seems odd that
Intel, one of the PCI developers, should violate this.
--
" ... this is the first day of my last days ... "     -- nin
 
 
 

1. >8bpp with Cirrus 5434 on ISA Bus

I've seen some traffic about getting >8bpp depth with Cirrus Chipsets so I have
decided share my limited experience on this matter. I have an ISA bus Diamond
SpeedStar64 Graphics 2200 (Cirrus 5434 Chipset) with 2Mbytes DRAM and this is
what worked for me. I was able to get 16bpp at 1024x768 on my Gateway 2000 486/33c
with upgraded BIOS and processor and 32Mbytes of RAM by doing the following:

1) adding the folowing lines to my XF86Config file:
   MemBase 0x04e00000
   Option "linear"
2) Creating a file .xserverrc in my home directory with the following line in it:
   exec X -bpp 16

I was then able to get 1024x768 resolution with 64k colors even though the XFree
documentation states that I can't. I have no idea why this worked. Although this
configuration is better for Web browsing, graphics really slow down. Just like
the documentation says, you lose your acceleration features when you go to this
mode. I was unable to run games like Xgalaga. It was way to slow on my 486DX4
machine. So I went back to 8bpp depth. I have no idea why this worked for me and I
will have no idea why it doesn't work for you but Good Luck to anyone that tries.

Note that I am assuming that you already have dot clocks and subsectins defined in
your XF86Config file for >8bpp.

--
Vernon John Van Steenkist

I speak for no one but myself.          ---o-(_)-o---  
MIME or UUencoded attachments OK

2. Puzzle Systems SoftNet: Investigation Query

3. 50MHz Busses & 50MHz chips

4. FS: HP 715/100 PA-RISC HP-UX Workstation with 256MB Ram, 4.3 GIG HD Space, etc TESTED currently at $5.00

5. XF86Config for Cirrus Logic CLGD5430/5434 needed ...

6. Finger problems

7. Bad News with X server & Cirrus 5434 PCI

8. Multi-part [Wincode format compatible] uudecode for Linux?

9. Cirrus Logic 5434 not supported

10. Cirrus Logic 5434 1MB in Xwindows (XFREE 86 3.2)

11. Problems using Cirrus Logic 5434 in >8 bitplanes under XFree86 3.1

12. dosemu on Cirrus 5434 Chip, Nitropci video adapter

13. Kelvin 64 (cirrus 5434 chipset) with XF86 v2.1.1 help