Configure 2 PnP 3c509 cards in RedHat 5.0

Configure 2 PnP 3c509 cards in RedHat 5.0

Post by Ferran Fo » Fri, 16 Jul 1999 04:00:00



 Hello,

 I've got two 3Com 509B Ethernet cards. I've plugged them in the
 computer that i want as router, but when i boot linux i can't
 detect them.

 I've got support for 3c509 inside the kernel, and i haven't changed
 the cards configuration with the DOS program that 3Com gives to
 configure them (disable PNP and the like).

 If i run dmesg there is no sign of eth??.
 I i run modprobe 3c509 i get the following:
 ----
  eth0:3c509 at 0x300 tag1, 10baseT port,adress 00 10 5a 53 15 53, IRQ
 10.

  eth1:3c509 at 0x300 tag2, 10baseT port,adress 00 10 5a 53 17 cb, IRQ
 5.

 ----
 I can't interpret this...

 I think the Plug and Play is not working because two cards
  are sharing a I/O base address (0x300).

 I've tryed to start the kernel with:
  lilo: ether=0,0,ethN
 (Is the syntax ok, do i have to replace N with something??)

 Have you configured two cards like those?

 Can you help me? What can i do... ??

 Thank you very much!

--

-- STE Consulting, SA http://www.ste.es

Sent via Deja.com http://www.deja.com/
Share what you know. Learn what you don't.

 
 
 

Configure 2 PnP 3c509 cards in RedHat 5.0

Post by kbo.. » Fri, 16 Jul 1999 04:00:00


I had the same issue uder slackware and it took several month to fix
here how to to it:

find an open base address and IRQ the boot with a dos
disk.

Run the 3com utlilty (Ithink its called something like 3c5x9cfg,exe
and chane one of the base address and IRQ
these are set on the firmware of the nick and you will be good to go
you may need to run modprobe twice.

Don't bother trying to force the base address from LILO or boot loader
it wont work.

good luck



>  Hello,

>  I've got two 3Com 509B Ethernet cards. I've plugged them in the
>  computer that i want as router, but when i boot linux i can't
>  detect them.

>  I've got support for 3c509 inside the kernel, and i haven't changed
>  the cards configuration with the DOS program that 3Com gives to
>  configure them (disable PNP and the like).

>  If i run dmesg there is no sign of eth??.
>  I i run modprobe 3c509 i get the following:
>  ----
>   eth0:3c509 at 0x300 tag1, 10baseT port,adress 00 10 5a 53 15 53, IRQ
>  10.

>   eth1:3c509 at 0x300 tag2, 10baseT port,adress 00 10 5a 53 17 cb, IRQ
>  5.

>  ----
>  I can't interpret this...

>  I think the Plug and Play is not working because two cards
>   are sharing a I/O base address (0x300).

>  I've tryed to start the kernel with:
>   lilo: ether=0,0,ethN
>  (Is the syntax ok, do i have to replace N with something??)

>  Have you configured two cards like those?

>  Can you help me? What can i do... ??

>  Thank you very much!

> --

> -- STE Consulting, SA http://www.ste.es

> Sent via Deja.com http://www.deja.com/
> Share what you know. Learn what you don't.

Sent via Deja.com http://www.deja.com/
Share what you know. Learn what you don't.

 
 
 

1. Setting Up two 3c509 ISA cards in RedHat Linux 5.0

I am having trouble getting two 3c509 network cards to work at the
same time. The kernel module loads OK and the first card works, but
the second one fails during the boot phase (both cards work, but not
when used together).

I have used the 3COM config tool to set up eth0 (irq=5 io=0x210) and
eth1 (irq=9 io=0x230). I have tried various settings in
/etc/conf.modules, but none appear to work. It is also interesting to
note that the working card has the settings irq=10 io=0x300 reported
by ifconfig.

It looks like the 3c509 module does some auto configuration of the
card, thus explaining why the settings do not match the ones set under
DOS with the 3COM utility.

Can anyone give me some tips ?

Thanks in advance

John Auld

Examples of conf.modules

alias eth0 3c509
alias eth1 3c509

'''''''''''''''''''''''''''''''''''
alias eth0 3c509 io=0x230
alias eth1 3c509 io=0x210

''''''''''''''''''''''''''''''''''''

alias eth0 3c509
alias eth1 3c509
options irq=5,9 io=0x230,0x210

2. 95c+: Selection --> nothing

3. need help configuring Creative ViBRA16C PnP sound card on RedHat-6.0 i386 Linux (29k)

4. Using ZIP drive from DOSEMU on lpt1

5. Mandrake screws up 3C509 ISA (non PNP) card for Windows 95.......

6. UPS

7. 3Com 3c509 PnP card...

8. Sophisticated problem (PPC): ld.so.1 fails to load objects

9. Network Card 3Com 3C509 in PnP-Mode

10. redhat 5.0 and 3c509 (a problem)

11. Help: How to configure 2 identical 3Com 3c509 ISA Network Card

12. How to configure two 3c509 network cards?

13. Problems configuring TCPIP (3c509 Etherlink III card)