3Com 3C509B-TPO Ethernet Board Not Recognized

3Com 3C509B-TPO Ethernet Board Not Recognized

Post by Charles W. Bailey, J » Tue, 26 Sep 1995 04:00:00



Linux will not recognize my 3Com 3C509B-TPO board on boot up (I've also tried a 3C509-TP).
I'm using version 1.2.11 (the kernel that supports the Adaptec 2940 SCSI controller).  The
distribution is the InfoMagic Linux Developer's Resource, August 1995.

I have tried all three configuration lines for the eth0 interface in /etc/rc.d/rc.inet1.  I have also tried
using an append = "reserve=0x300,32 ether=0,0x300,eth0" line in lilo.conf because the system is
probing for a  sound board on boot up at a number of addresses (there is no sound board).  (I've
also tried 0x100.)

Any help would be appreciated.  Thanks.

Best Regards,
Charles


 
 
 

3Com 3C509B-TPO Ethernet Board Not Recognized

Post by Kong Si » Thu, 28 Sep 1995 04:00:00



: >Linux will not recognize my 3Com 3C509B-TPO board on boot up (I've also tried a 3C509-TP).

: I have consistently found that if I ONLY compile 3c509/3c579 support, I can't
: get the network card recognized.

: I have had to compile in the last 2 of the 3 3com options (I forget, is it the
: 3c505?) and then everything is happier than clams.

: --
: Thumper!                                            Leporidae Extrordinhare

:                      "Life is to achieve the impossible"

I've just spend a good part of the day trying to get my 3c509B card
recognized.  The most important thing is to turn of the plug-and-play
feature of the card.  You can do this by running the 3c5X9cfg.exe from
DOS.  This utility is found on the Etherdisk, which can be ftp from
many sites.  Once the plug and play feature is turned off, booting
a kernel with 3c509 compiled into it will work like a charm.

Regards.

--

National Supercomputing Research Centre
Singapore

 
 
 

1. My 3com 3c509b-TPO is not working

However my 3com 3c905B (Cyclone/PCI) is working.  I have 2 cards in my
ma'chine.

On my router, the port 'lights' up for my Cyclone/PCI card, but does
NOT for my 3c509B-TPO card.  I have disable PNP, I am using modules to
load the cards.  Here is my /etc/conf.modules:

alias eth0 3c59x
alias eth1 3c509
options eth1 io=0x300
...

I've tried variations, but I do not think it is the file.  I do not
think my h/w is recognizing the card (3c509B-tpo)

Any suggestions?

Michael

2. MIPS - Serial port

3. Redhat Linux 5.1 and 3com 3c509b-TPO card troubleshooting

4. 2.5.5 don't compile (ALSA rtctimer and irda)

5. 3com 3C509B-TPO ISA card - no go

6. ld can't find libraries after crash

7. two BBC News links inc: M$ tech guru says Windows is dead

8. 3Com 3C509B-TPO and linux kernel

9. Redhat Linux 5.1 and 3com 3c509b-TPO card troubleshooting

10. 3Com EtherLink III ISA (3c509b-TPO) in Plug and Play

11. Is 3COM [3C509B-TPO] supported ?

12. RH5.1 won't initialize eth0 (3com 3C509B-TPO)