SCSI HD on AHA2940,IDE-CDROM setup

SCSI HD on AHA2940,IDE-CDROM setup

Post by Ryan Hage » Fri, 22 Nov 1996 04:00:00



I have an Adaptec 2940UW controller hooked up to a 4.3 gigabyte SCSI HD and
a ATAPI IDE cd-rom.  I cannot find a boot disk with these two supported.
Should I install Linux on another machine, and then make a Zdisk with
support for these two devices?  I would rather download a disk.  I need
this for an install. And actually I have everything setup up on the HD for
Linux. I have OS/2, Bootmanager, and win 95. I just cannot access my drive
through linux's fdisk. It does not find the Partition table. I have had
problems with drives over 2 gig and windows, but I created all the
partitions in OS/2 and formatted them with the respective operating systems
on them. And I know that you run into problems if boot partitions are not
in the first gigabyte. But linux is not finding my controller during boot,
and thus not the Hard Drive attached to it..

Ryan M. Hager

 
 
 

SCSI HD on AHA2940,IDE-CDROM setup

Post by LYMAN A. COPP » Fri, 22 Nov 1996 04:00:00



> I have an Adaptec 2940UW controller hooked up to a 4.3 gigabyte SCSI HD and
> a ATAPI IDE cd-rom.  I cannot find a boot disk with these two supported.
> Should I install Linux on another machine, and then make a Zdisk with
> support for these two devices?  I would rather download a disk.  I need
> this for an install. And actually I have everything setup up on the HD for
> Linux. I have OS/2, Bootmanager, and win 95. I just cannot access my drive
> through linux's fdisk. It does not find the Partition table. I have had
> problems with drives over 2 gig and windows, but I created all the
> partitions in OS/2 and formatted them with the respective operating systems
> on them. And I know that you run into problems if boot partitions are not
> in the first gigabyte. But linux is not finding my controller during boot,
> and thus not the Hard Drive attached to it..

> Ryan M. Hager


You did the proper thing by making the partitions with with OS/2, I
have done it using a Buslogic SCSI card and Linux worked fine above
cilinder 1024 using extended mapping. Since I upgraded my computer
to PCI and installed a 2940UW, I noticed that the 2940 device driver
does not work on the Ultra wide.  You need to Install a Patch from
ftp://ftp.teleport.com/users/deang/Linux/aic7xxx.  I have not
gotten around to messing with this. Please drop me an email
and tell me how it worked if you get around to it.

Lyman Copps


 
 
 

SCSI HD on AHA2940,IDE-CDROM setup

Post by Adrian L. Hose » Sat, 23 Nov 1996 04:00:00


Did you try the aha2x4x bootdisk? It works great with the 2940UW. If
the aha2x4x can't find your controller you have something else going
wrong - it's not the bootdisk.

Shanti,

        - A
--
It's a Zen thing. You already understand.

 
 
 

SCSI HD on AHA2940,IDE-CDROM setup

Post by Ryan Hage » Sun, 24 Nov 1996 04:00:00


Here is what I did to install Linux on my machine. I downloaded a copy of a
boot disk for 2940 and the whole thing worked.  

Ryan M. Hager

 
 
 

1. Dell Dimension + IDE HD + IDE CDROM + 2940 SCSI = PROBLEM???

Folks:

I'm desperate.  I just bought a Dell Dimension 90MHz Pentium, configured as
follows:

        1 IDE hard drive             - mastered off primary controller
        1 Mitsumi IDE CD-ROM         - mastered off secondary controller
        Adaptec 2940 SCSI controller - id 7
        1 2.1GB Conner SCSI drive    - id 0

        Red Hat Linux 2.0 (2940-nonet.img boot image).

I've tried every conceivable LILO option, and I can't get the machine
to recognize the CD-ROM.  It picks up the SCSI and IDE hard drives
beautifully, though.

One person who responded to my email said that he thought the problem was that
the IDE controllers on Dell motherboards were flaky... or maybe just flaky
under Linux.  This strikes me as rather unbelievable... especially since
it works beautifully under Windows 95.

Is ANYONE out there using a Dell for Linux, with IDE???  

Does ANYONE have $0.02 to throw into this issue?
--

   ____           __

 / __/ _/ / / , /     Hughes STX Corporation, NASA/Goddard Space Flight Cntr.
/___/_/ \  /\  /___    
        /_/ /_____/   http://selsvr.stx.com/~eryq/

2. SED or AWK script to delete a line if value in field 10 of filea is in fileb?

3. PROBLEM: 2.4.20 on ICH4 : ide-cdrom/ide-scsi problems reading cds

4. Question on iso9660

5. Redhat 5.0, Initio UW SCSI HD and IDE CDROM problem.

6. mapping and locking user memory

7. Getting an IDE cdrom to work while HD are SCSI

8. CERN - Can't find htadm!

9. Will SCSI HD & ATAPI IDE CDROM work ok?

10. AHA2940 seen, HD & CDROM not (1.3.40)

11. Which BOOTDSK for IDE HD and IDE CDROM?

12. Problems with an IDE HD and new SCSI HD

13. Setting up 2 new SCSI HD in a system with an IDE HD