Dial-in Speeds above 9600???

Dial-in Speeds above 9600???

Post by Barry Wheel » Wed, 01 Nov 1995 04:00:00



I have successfully installed linux 1.2.8 and have dial-in working fine
up to speeds of 9600.

I have 5 28.8 modems (4 Boca and 1 USR) that are hooked into a cyclades
16 port io board.

After modifying the inittab file for the settings above 9600 (I set the
line speed to 38400) and checking gettydefs for the correct settings, I
used the setserial command to set the ports to spd_vhi and made the
appropriate changes in the boot files.

I have also used init to re-initalize the ports and all seems to be fine
until I try to connect at speeds above 9600.  At 14.4, the machine either
hangs up or prints garbage on the screen and then hangs up.  At 19.2 it
hangs up or allows me to get access fine.  At 28.8, nothing except a
hangup.  If I do get a connection (very rarely), when I download a file
there are considerable errors (crc etc).

Using my slip accounts that I have configured, speeds above 9600 are not
a problem and all appears to be functioning fine.  I am using diplogin
for slip access.

Is there anyone out ther that can lend a poor netware administrator a
hand in this wonderful world of Linux???

PS. I have checked the faq and the serial-howto, but I can't find where
I'm gone wrong.

Thanks for reading.

--
       * Barry Wheeler *         |         * Barry Wheeler *
       Lan Administrator         |          Net Surfer Dude
      Westviking College         |           Box 3371, RR2
P.O. Box 822, Corner Brook, NF   |          Corner Brook, NF
       Canada, A2H 6H6           |          Canada, A2H 6B9

 
 
 

1. Dial-in Speeds above 9600???

Linux 1.2.8 running a cyclades 16 port, 5 modems (4 boca 28.8 and 1 USR
28.8).

modified inittab to pass the 38400 speed to uugetty, used setserial to
change the ports to spd_vhi, used init to re-initialize the ports but at
speeds of 14.4 my system hangs up or prints garbage, at 19.2 things work
ok sometimes or hang-up, at 28.8 just hangs-up.

When things do work (on a rare, very rare occassion) the downloads
produce massive errors and garbage on occasion.

Read the FAQ and the Serial-Howto, and thought that I followed the steps
to the letter, but no luck.

Can someone please help this Netware Administrator crack this problem on
Linux.

Thanks for Reading.

--
       * Barry Wheeler *         |         * Barry Wheeler *
       Lan Administrator         |          Net Surfer Dude
      Westviking College         |           Box 3371, RR2
P.O. Box 822, Corner Brook, NF   |          Corner Brook, NF
       Canada, A2H 6H6           |          Canada, A2H 6B9

2. Databases for Linux

3. Solaris dial-in modem won't work above 9600

4. Success with IP Masquerading

5. Modems above 9600

6. automake option for SUID?

7. modem doesnt work above 9600

8. NT crashed whole DOL network - nationwide

9. Cannot setup dialin modem above 9600 baud

10. PPP fails above 9600 baud (slackware, pppd 2.2, chat)

11. terminal speeds faster than 9600

12. SLIP problems: getting 9600 equivalent speed from 14.4k?

13. using modem with speed greater than 9600 in sco.