Ncurses.4 s ncurse.5

Ncurses.4 s ncurse.5

Post by Don Polett » Sun, 31 Dec 1899 09:00:00



I have a redhat 6.2 system with ncurse.so.4.  RPMs are starting to appear that
require ncurses.so.5. But when I try in install 5 it wants to remove version 4
and it says many thing are dependant on 4 (XFree being one of the more
import ones). I installed 5 usign the --nodeps option but that just made
everything that was dependant on 4 stop working so I reverted. Since apps
seem to look for the speific version is there any way to have both installed?
How does one move from version 4 to 5?
 
 
 

Ncurses.4 s ncurse.5

Post by dic.. » Sun, 31 Dec 1899 09:00:00



> I have a redhat 6.2 system with ncurse.so.4.  RPMs are starting to appear that

faq: Someone at Redhat was unable to comprehend the release notes for
ncurses 5.0 and decided to continue numbering new versions as 4.2
(adding to my bug reports).

Quote:> require ncurses.so.5. But when I try in install 5 it wants to remove version 4
> and it says many thing are dependant on 4 (XFree being one of the more
> import ones). I installed 5 usign the --nodeps option but that just made
> everything that was dependant on 4 stop working so I reverted. Since apps
> seem to look for the speific version is there any way to have both installed?
> How does one move from version 4 to 5?

--

http://dickey.his.com
ftp://dickey.his.com

 
 
 

Ncurses.4 s ncurse.5

Post by Don Polett » Sun, 31 Dec 1899 09:00:00


Well that clears it up a little but what is the solution?

Do I wait for RH to post RPMs that all use ncusres 5 and then upgrade them
all at teh same time?

Thanks for the tip.




>> I have a redhat 6.2 system with ncurse.so.4.  RPMs are starting to
>> appear that

> faq: Someone at Redhat was unable to comprehend the release notes for
> ncurses 5.0 and decided to continue numbering new versions as 4.2
> (adding to my bug reports).

>> require ncurses.so.5. But when I try in install 5 it wants to remove
>> version 4  and it says many thing are dependant on 4 (XFree being one
>> of the more  import ones). I installed 5 usign the --nodeps option but
>> that just made  everything that was dependant on 4 stop working so I
>> reverted. Since apps  seem to look for the speific version is there any
>> way to have both installed?  How does one move from version 4 to 5?