glibc errata for RedHat 7.0

glibc errata for RedHat 7.0

Post by James William » Fri, 23 Feb 2001 22:31:24



  I installed RedHat 7.0 ('workstation version') on
  a PII recently. The initial installation was fine.

  I then downloaded the errata rpms for RedHat 7.0.
  Included in the errata is a set of glibc rpms, which
  are now at ver 2.2-12. None of these 2.2-12 rpms will
  install on my stock RH 7.0 workstation --- in all cases,
  it says that I first need to have glibc 2.2 installed
  on the system. (The stock RH 7.0 installation will
  give you glibc 2.1.92, not 2.2.)

  The question, then, is how does one upgrade glibc
  to 2.2 on a stock RH 7.0 system? (I think the earlier
  2.2-9 glibc errata rpms worked, but the current 2.2-12
  won't work.) I do NOT want to use source rpms, either.
  I want all upgrades registered with rpm.

  Thanks for any help.

  --  Jim Williams  

 
 
 

glibc errata for RedHat 7.0

Post by Rex Diete » Sat, 24 Feb 2001 00:45:43



Quote:>   I installed RedHat 7.0 ('workstation version') on
>   a PII recently. The initial installation was fine.

>   I then downloaded the errata rpms for RedHat 7.0.
>   Included in the errata is a set of glibc rpms, which
>   are now at ver 2.2-12. None of these 2.2-12 rpms will
>   install on my stock RH 7.0 workstation --- in all cases,
>   it says that I first need to have glibc 2.2 installed
>   on the system. (The stock RH 7.0 installation will
>   give you glibc 2.1.92, not 2.2.)

They worked for me on several machines.

Perhaps you could post the exact procedure you're using to upgrade and the
exact errors you receive so that we can be diagnose your problem?

--
Rex Dieter
Computer System Administrator
Mathematics and Statistics
University of Nebraska Lincoln

 
 
 

1. Redhat 7.0: glibc-common = 2.2 is needed by glibc-2.2-12

Hi all,

I'm trying to run the update of glibc-2.2.12.i686.rpm on my Redhat 7.0 i686
with 2.2.16-22 kernel version.

The command : 'rpm -Fvh glibc-2.2-12.i686.rpm is failed with error:
failed dependencies:
       glibc-common = 2.2 is needed by glibc-2.2-12
       /usr/bin/getent is needed by stunnel-3.8-4

I only found the glibc-common-2.2-12.i386.rpm from ftp.redhat.com. I think
it's not for my i686 PC. The command 'rpm -Fvh glibc-common-2.2.12.i386.rpm'
did nothing. The command 'rpm -q glibc-common' didn't show anything.

Trying to install with 'rpm -Uvh glibc-common-2.2.12.i386.rpm', it failed
with error: failed dependencies:
            glibc < 2.2-12 conflicts with glibc-common-2.2-12

The current glibc installed by default with Redhat 7.0 is glibc-2.1.92-14.

Does someone see this problem before?

Thanks in advance for any help.

DH.

2. Solaris vs. Aix ... I don't want to start a war.

3. broken glibc & Redhat 7.0?

4. help: just got my new amd duron 1g msi k7t turbo2

5. 2 ISP questions

6. RPM won't install glibc rpm errata for 5.2

7. SysVinit2.50- rc.local won't load binaries

8. does errata need errata?

9. latest redhat 7.3 errata kernel crash

10. BUG REPORT: Redhat 5.1 errata (another one)

11. Errata for RedHat: how reliable?

12. Update from Redhat 7.0 to Redhat 7.3