Sound consensus

Sound consensus

Post by Zak Smit » Sat, 24 Apr 1999 04:00:00



It is interesting to read about the various sound troubles.  Some people
lose their sound capability when upgrading to Kernel 2.2.5 like Eric Bryant
and Neil.  Simon Price notes that there is no PCI Soundblaster Live support
for RH 5.2.

Others like jdafoe note that the his/her PNP sound card work fine with RH
5.1.  I would also add that my friends system worked with RH 5.1 but not
with RH 5.2.  Unfortunately I do not know what his sound card is.  I will
find out and post it later.

So what could be the problem?  Does sound work under RH 5.2, Kernel 2.2.5?
Please post working and non-working configurations for sound configurations
under RH.  Please use a common format like:

<example>
working=true, RH=5.2, K=2.2.5, cpu=P2_400, sound=AWE32_PCI
Notes: Had to change file x before it would work. :-)  (if only it were that
simple)
</example>

 
 
 

Sound consensus

Post by Todd Ostermeie » Sat, 24 Apr 1999 04:00:00


I think the largest problem, by far, is the reliance upon sndcfg to get
sound working in RedHat.  Assuming your card is supported, and you
compiled sound into the kernel or as a module for that specific card,
everything should be fine.  Anyway, here's my setup:

card: Yamaha OPL3SA built into the motherboard
Distribution: Currently SuSE 6.0, though it's worked with SuSE 5.3, RH
4.2, and Slack 3.3
kernel: anything from 2.0.30 to 2.2.6 (currently on 2.2.6)
method: Compiled kernel source to use the Microsoft Sound System,
supplying proper config data (IRQ, DMA, IO, etc).

If the kernel drivers won't work, there are several other options.  You
can try the OSS drivers ($20 to register), or the ALSA drivers.  In fact,
I plan on setting up ALSA sometime when I get the time.

: It is interesting to read about the various sound troubles.  Some people
: lose their sound capability when upgrading to Kernel 2.2.5 like Eric Bryant
: and Neil.  Simon Price notes that there is no PCI Soundblaster Live support
: for RH 5.2.
:
: Others like jdafoe note that the his/her PNP sound card work fine with RH
: 5.1.  I would also add that my friends system worked with RH 5.1 but not
: with RH 5.2.  Unfortunately I do not know what his sound card is.  I will
: find out and post it later.
:
: So what could be the problem?  Does sound work under RH 5.2, Kernel 2.2.5?
: Please post working and non-working configurations for sound configurations
: under RH.  Please use a common format like:
:
: <example>
: working=true, RH=5.2, K=2.2.5, cpu=P2_400, sound=AWE32_PCI
: Notes: Had to change file x before it would work. :-)  (if only it were that
: simple)
: </example>
:
:
:
:

________________________________

Todd Ostermeier                          

http://www.ews.uiuc.edu/~ostermer/index.html
ICQ UIN: 2253928                            
A-723
________________________________

 
 
 

Sound consensus

Post by Eggert.Eh.. » Sat, 24 Apr 1999 04:00:00



>It is interesting to read about the various sound troubles.  Some people
>lose their sound capability when upgrading to Kernel 2.2.5 like Eric Bryant
>and Neil.  Simon Price notes that there is no PCI Soundblaster Live support
>for RH 5.2.

That's my problem too (SuSE 6.0). Being a *y beginner, with Kernel 2.0.36
and isapnp I managed to setup Soundblaster without too much problems. Having
more experience now, but with kernel 2.2.5, I just can't do it. I will go for
OOS too, if nothing helps.

-----------------------------------------------------
Answers please in this newsgroup!

-----------------------------------------------------