AHA2940 SCSI and Linux Setup, Help!

AHA2940 SCSI and Linux Setup, Help!

Post by Not Hea » Thu, 04 Jan 1996 04:00:00



I am using the Sept release I believe and I was able to boot off the
disks, do the full install, create LILO, and then as soon as I try to
boot off the hard drive LiLo cannot handle the 2940 controller.  Asking
Info-Magic was no help, they ignored me.  I'm sure someone else has
already figured this one out but I cannot do it.  After buying three
later versions of Info-Magic I feel that I should at least be able to get
this machine to boot off the hard drive, especially when the last two
versions specifically state that the 2940 is supported.  I would
appreciate any help on this one also.  Thanks.


 
 
 

AHA2940 SCSI and Linux Setup, Help!

Post by Richard A. Findl » Thu, 04 Jan 1996 04:00:00


Folks,
        I have the Nov '95 release of InfoMagic's Linux.  I'm trying
to get it to boot (even off of the root, boot diskettes) and recognise
my Adaptec 2940 SCSI controller.  It says that it is an unrecognised
PCI device and ignores it completely.  Any ideas?  Please respond to

--
------------------------------------------------------
Richard Findlay - ITC Network Systems  (804) 982-4699


 
 
 

AHA2940 SCSI and Linux Setup, Help!

Post by Grant Lewi » Thu, 04 Jan 1996 04:00:00


I think your problem may be related to the fact that the boot image on your
hard drive probably doesn't have 2940 support compiled into it. You might try
mounting your boot floppy with the 2940 support and then copying your floppy
boot image into the root directory on your hard drive. You may need to tell
lilo when you boot to mount root=/dev/sda? instead of /dev/fd0. If you have any
problems, you can email me.

Grant

 
 
 

AHA2940 SCSI and Linux Setup, Help!

Post by David Macoli » Fri, 05 Jan 1996 04:00:00



Quote:>I think your problem may be related to the fact that the boot image on your
>hard drive probably doesn't have 2940 support compiled into it. You might try
>mounting your boot floppy with the 2940 support and then copying your floppy
>boot image into the root directory on your hard drive. You may need to tell
>lilo when you boot to mount root=/dev/sda? instead of /dev/fd0. If you have any
>problems, you can email me.
>Grant

I spent three days on this and this is what I believe to be the
the answer.  After battling with patches, etc.  I ended up
building my system around 1.3.9.  Disk and everything else
works great, except for LILO.  I ended up using a 40MB IDE disk
in addition to my AHA2490 just for boot purposes.  It`s a waste, I
know(the 40mb disk or using it to boot?) but you could probably
get away with booting from floppy and using the option to mount
the scsi as root.  i.e. mount root=/dev/sdx.  I have it running
like this and seems to handle it`s own for now.  Be careful when
using the 1.3.x kernels, PPP doesn`t work right and I haven`t gotten
a new version that compiles properly with 1.3.9.

Good Luck!------------------
Dave Macolino
"We`ll either find a way, or make one!"

 
 
 

AHA2940 SCSI and Linux Setup, Help!

Post by Michiel van Lo » Sat, 06 Jan 1996 04:00:00


On Wed, 3 Jan 1996 12:42:32 GMT

>Folks,
>    I have the Nov '95 release of InfoMagic's Linux.  I'm trying
>to get it to boot (even off of the root, boot diskettes) and recognise
>my Adaptec 2940 SCSI controller.  It says that it is an unrecognised
>PCI device and ignores it completely.  Any ideas?  Please respond to


What is your BIOS version, mine is 1.21.
I contact InfoMagic's Technical Support and they told me they are
working to get things working for this version.

Michiel

Quote:>--

--
______________________________________________________________________________
                               Michiel van Loon

 Bicycling along the Digital Highway - - - http://www.dds.nl/~michiel/fiets/

DISCLAIMER:
          Normally my employer does not agree with what I am saying
______________________________________________________________________________
 
 
 

AHA2940 SCSI and Linux Setup, Help!

Post by Erich E. Sing » Mon, 08 Jan 1996 04:00:00




>I spent three days on this and this is what I believe to be the
>the answer.  After battling with patches, etc.  I ended up
>building my system around 1.3.9.  Disk and everything else
>works great, except for LILO.  I ended up using a 40MB IDE disk
>in addition to my AHA2490 just for boot purposes.  It`s a waste, I
>know(the 40mb disk or using it to boot?) but you could probably
>get away with booting from floppy and using the option to mount
>the scsi as root.  i.e. mount root=/dev/sdx.  I have it running
>like this and seems to handle it`s own for now.  Be careful when
>using the 1.3.x kernels, PPP doesn`t work right and I haven`t gotten
>a new version that compiles properly with 1.3.9.
>Dave Macolino

.

I did exactly the same except I boot off of a floppy.
Haven't had a kernel problem yet.

Darrell Tschekrt


.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.

 
 
 

AHA2940 SCSI and Linux Setup, Help!

Post by Paul Wagena » Tue, 09 Jan 1996 04:00:00


On Wed, 3 Jan 1996 12:42:32 GMT

>>Folks,
>>        I have the Nov '95 release of InfoMagic's Linux.  I'm trying
>>to get it to boot (even off of the root, boot diskettes) and recognise
>>my Adaptec 2940 SCSI controller.  It says that it is an unrecognised
>>PCI device and ignores it completely.  Any ideas?  Please respond to


Hi,
Dealing with the same problem (same release of Infomagic),
I found this:  

ftp://ftp.ims.com/pub/Linux/aic7xxx/linux-1.3.52/

A bootdisk made with the diskimage aic7xxx will recognize
your scsi-controller and the devices.
Boot-off with <mount root=/dev/sda1> at the boot-prompt
(where /dev/sda1 must be the correct device for your Linux root partition).

After a complete slackware install, copy the /vmlinuz from the bootdisk:
1) mount -t minix /dev/fd0 /mnt
2) cp /mnt/vmlinuz /vmlinuz

and reboot from Lilo

Succes!
(and thanks to Dean W. Gehnert, who helped *me* over
this treshold)

--
Paul Wagenaer

Homepage: http://www.xs4all.nl/~paulwag/
finger for Public PGP-key

 
 
 

AHA2940 SCSI and Linux Setup, Help!

Post by Jens Utech » Tue, 09 Jan 1996 04:00:00


Hey,
you can use the bootdisk on
ftp.ims.com /pub/Linux/aic7xxx/experiment.
(Create with gzip and rawrite!)
The controller has a new BIOS.

But how can I install the kernel on my fixed disk
into LILO ?
If you know the way, please mail me.

Jens

--
Jens Utecht
Physics on technical university of Darmstadt, Germany


 
 
 

AHA2940 SCSI and Linux Setup, Help!

Post by Adrian Blu » Sat, 13 Jan 1996 04:00:00


  I had the same problem, which didn't help me seeing as it the machine
  was supposed to run news :) and the bootdisk doesn't support any networking.

  Anyway, it was solved by using the 1.3.x kernels. I'm currently using
  1.3.9, though i don't know if i needed to patch it up that far or not.

: Hey,
: you can use the bootdisk on
: ftp.ims.com /pub/Linux/aic7xxx/experiment.
: (Create with gzip and rawrite!)
: The controller has a new BIOS.

: But how can I install the kernel on my fixed disk
: into LILO ?
: If you know the way, please mail me.

--
          Adrian Blues          |          HYPEREALITY SYSTEMS LTD            

  http://www.ecafe.org/~adrian  |Specialists in Interactive and Dynamic Pages
 -------------------------------| Tel: (01248) 750 555  Fax: (01248) 722 566  
 If life is a highway...        |        http://www.hypereality.co.uk        

 
 
 

1. Help: aha2940 SCSI controller, Redhat Linux 5

I installed Redhat Linux 5 without a SCSI card.
I'm trying to implement tape backup using a Tandberg
4/8MB QIC drive and Adaptec aha2940 host adapter.
Drive and host adapter hardware physically installed, but
how do I make Linux know about this SCSI host adapter and
the drive?

-------------------------------------------------
Village Computing (Co-op)Limited

-------------------------------------------------

2. sed question

3. SCSI HD on AHA2940,IDE-CDROM setup

4. 3D Blaster

5. SCSI timeouts during setup (aha2940)

6. STARTING A LINUX SERVER

7. HELP: aha2940 + 2Gb Seagate SCSI hard drives

8. Unix / NT connection

9. Adaptec AHA2940 SCSI-2 and Linux

10. Linux and Adaptec AHA2940 PCI Scsi

11. Linux SCSI shopping HOWTO? BT-948 vs. AHA2940

12. Matrox Mystique ands X.

13. HELP: Linux setup/mount & FD TMC SCSI BIOS...