SIIG Trio 2S1P Plus PCI multiple 16650 serial port setup?

SIIG Trio 2S1P Plus PCI multiple 16650 serial port setup?

Post by Mike McDona » Sun, 31 Dec 1899 09:00:00



  I picked up one of these boards so that I could get an extra serial port on
my Dell (it only comes with one!). I can sort of get it to work but only real
SLOW! I need it to work 19200baud. When I set it up that way, some of the
input coming into the port is lost. All of the output seems to make it.
Unforunately, there's a tens of seconds delay between each character. Here's
my setup info in case anyone can spot what I'm doing wrong:

=>cat /proc/pci
  ...
  Bus  0, device  17, function  0:
    Communication controller: Unknown vendor Unknown device (rev 0).
      Vendor id=131f. Device id=2061.
      Medium devsel.  Fast back-to-back capable.  IRQ 10.  
      I/O at 0x1420 [0x1421].
      I/O at 0x1418 [0x1419].
      I/O at 0x1410 [0x1411].
      I/O at 0x1408 [0x1409].
  ...
=>cat /etc/serial.conf
#
/dev/ttyS1 port 0x1420 irq 10 uart 16650V2 spd_cust baud_base 115200 divisor 4
=>setserial -g /dev/ttyS?
/dev/ttyS0, UART: 16550A, Port: 0x03f8, IRQ: 4
/dev/ttyS1, UART: 16650V2, Port: 0x1420, IRQ: 10, Flags: spd_cust
/dev/ttyS2, UART: unknown, Port: 0x03e8, IRQ: 4
/dev/ttyS3: Permission denied

  I don't know what ttyS2 is?

  If anyone could straighten me out, I'd appreciate it!

  Mike McDonald

 
 
 

SIIG Trio 2S1P Plus PCI multiple 16650 serial port setup?

Post by Mark Clayto » Sun, 31 Dec 1899 09:00:00


Did you first boot with a DOS disk and set the port speed with the siig
utility?  I think this step is required to get anything other than 115200.
How did you get the parallel port to work?  Or have you tried yet?

Regards,
Mark


>I picked up one of these boards so that I could get an extra serial port on
>my Dell (it only comes with one!). I can sort of get it to work but only real
>SLOW! I need it to work 19200baud. When I set it up that way, some of the
>input coming into the port is lost. All of the output seems to make it.
>Unforunately, there's a tens of seconds delay between each character. Here's
>my setup info in case anyone can spot what I'm doing wrong:

>=>cat /proc/pci
>  ...
>  Bus  0, device  17, function  0:
>    Communication controller: Unknown vendor Unknown device (rev 0).
>      Vendor id=131f. Device id=2061.
>      Medium devsel.  Fast back-to-back capable.  IRQ 10.  
>      I/O at 0x1420 [0x1421].
>      I/O at 0x1418 [0x1419].
>      I/O at 0x1410 [0x1411].
>      I/O at 0x1408 [0x1409].
>  ...
>=>cat /etc/serial.conf
>#
>/dev/ttyS1 port 0x1420 irq 10 uart 16650V2 spd_cust baud_base 115200 divisor 4
>=>setserial -g /dev/ttyS?
>/dev/ttyS0, UART: 16550A, Port: 0x03f8, IRQ: 4
>/dev/ttyS1, UART: 16650V2, Port: 0x1420, IRQ: 10, Flags: spd_cust
>/dev/ttyS2, UART: unknown, Port: 0x03e8, IRQ: 4
>/dev/ttyS3: Permission denied

>  I don't know what ttyS2 is?

>  If anyone could straighten me out, I'd appreciate it!

>  Mike McDonald



 
 
 

SIIG Trio 2S1P Plus PCI multiple 16650 serial port setup?

Post by Mike McDona » Sun, 31 Dec 1899 09:00:00




Quote:

> Did you first boot with a DOS disk and set the port speed with the siig
> utility?  I think this step is required to get anything other than 115200.
> How did you get the parallel port to work?  Or have you tried yet?

> Regards,
> Mark

  I turns out that my problem was an interrupt conflict with my Promise UDMA66
controller. Once I removed it, the serial ports work fine. Ans since I'm only
interested in running the port at 19200, I didn't need to run the dos config
program. (Although I did just to see what it did.)

  As for the parallel port, it is configured into Linux but I haven't plugged
anything into it yet to see if it actually works.

  Mike McDonald

 
 
 

1. SIIG CyberPro dual-port 16650 board

I bought one of these last night hoping that even if it couldn't
function as a 460kbps board, at least I could trick Linux (kernel
2.0.30) into seeing it as a 16550A while I looked for a 16650 driver.
So far, no dice.  I get no response out of it whatsoever.  I'm
starting to fear I have a bad board.  Anyone else have one working?
Is there support for the 16650 UART out there?

----------------
Scott Taylor

To send me email, remove the 'f' from in front of my address.
It's just there to fool automated spammers.

2. TN5250 emulator for Linux

3. SIIG Quartet Serial plus PCI support

4. CGI password security question.

5. Trying to setup 16650 UART serial card in FreeBSD 3.3

6. Me Too!!!

7. 16650 Serial port w/ Startech 16c650J UART

8. Free RemoteBoot ROM needed

9. 16650 Serial ports drivers?

10. 16650 Serial port drivers and boards for Linux?

11. 16650 UART based serial port

12. Serial port speeds with 16650

13. 3com Impact IQ with Lavaport-ISA 16650 UART serial