slapd & openldap // can't connect to ldap server

slapd & openldap // can't connect to ldap server

Post by Andre » Thu, 26 Jun 2003 07:48:26



Hello Everyone,

I am fairly new to Linux and I have run into a bit of a problem.  I
successfully configured openldap and slapd on a redhat 7.2 box.  I was
able to add/delete/change/search the ldap database just fine.
Yesterday when I was attempting to add another user using the same
ldapadd command I used successfully in the past, it never completed
the operation.  I had to ctrl-z in order to get back to a prompt.

When this happened, the slapd proccess died. Since then I have been
unable to get slapd to run successfully.  The slapd service starts but
I am unable to search the ldap database.  The error I get is "can't
connect to ldap server (81)".  When I run "top" the slapd proccess is
using 98%-99% of the CPU.

I can kill (9) the slapd proccess but restarting it doesn't help.  The
status of the slapd process is "running".  I noticed some zombies when
I was trying to get it to work, but they have since disappeared.

I hope I provided enough information.

Thanks!

Reed

 
 
 

1. slapd & openldap // can't connect to ldap server

Hello Everyone,

I am fairly new to Linux and I have run into a bit of a problem.  I
successfully configured openldap and slapd on a redhat 7.2 box.  I was
able to add/delete/change/search the ldap database just fine.
Yesterday when I was attempting to add another user using the same
ldapadd command I used successfully in the past, it never completed
the operation.  I had to ctrl-z in order to get back to a prompt.

When this happened, the slapd proccess died. Since then I have been
unable to get slapd to run successfully.  The slapd service starts but
I am unable to search the ldap database.  The error I get is "can't
connect to ldap server (81)".  When I run "top" the slapd proccess is
using 98%-99% of the CPU.

I can kill (9) the slapd proccess but restarting it doesn't help.  The
status of the slapd process is "running".  I noticed some zombies when
I was trying to get it to work, but they have since disappeared.

I hope I provided enough information.

Thanks!

Reed

2. problem with tar on solaris

3. LDAP over SSL using OpenLDAP/OpenSSL/Cyrus SASL with Netscape's LDAP server

4. Mediavision Reno CD on Linux

5. SUN LDAP, Netscape LDAP (SUN), OPENLDAP, which one?????

6. Local mail goes to unknow offsite machine???

7. OpenLDAP or SUN ONE DS5.2 HOW-TO updated with sudo+LDAP and apache+LDAP info

8. catman??????

9. Who should run Slapd (OpenLDAP deamon)?

10. solaris ldap client to linux openldap server

11. FreeBSD 4.3 LDAP Authentication to OpenLDAP ver2 Servers

12. Solaris Native LDAP Client + OpenLDAP Server + SSL

13. Solaris 9 LDAP Client, OpenLDAP Server, and TLS