A problem installing emacs 19.34

A problem installing emacs 19.34

Post by Sergio Anto » Sun, 07 Jun 1998 04:00:00



I downloaded and installed emacs 19.34 from sunsite.
To install it I simply untarred the files in "/".

When I start emacs I get the following messages.

    sgray:/home/antoy/jde[501] Warning: arch-dependent data dir
(/usr/local/libexec/emacs/19.34/i586-pc-linux-gnu/) does not exist.
    Warning: arch-independent data dir
(/usr/local/share/emacs/19.34/etc/) does not exist.
    Warning: Lisp directory `/usr/local/share/emacs/19.34/site-lisp'
does not exist.
    Warning: Lisp directory `/usr/local/share/emacs/site-lisp' does not
exist.
    Warning: Lisp directory `/usr/local/share/emacs/19.34/lisp' does not
exist.
    Cannot open load file: term/x-win

that I corrected with a symbolic link as follows

    gray:/usr/local[503] ln -s /usr/share .
    gray:/usr/local[504] ln -s /usr/libexec .

Also, when I tried to load info I get the message

    Can't find the info directory node

I have not found a solution to this one.

Did I do something wrong or is it a problem with the distribution?

Regards,
Sergio Antoy

 
 
 

A problem installing emacs 19.34

Post by D.D. Elli » Wed, 10 Jun 1998 04:00:00



> I downloaded and installed emacs 19.34 from sunsite.
> To install it I simply untarred the files in "/".

> When I start emacs I get the following messages.

>     sgray:/home/antoy/jde[501] Warning: arch-dependent data dir
> (/usr/local/libexec/emacs/19.34/i586-pc-linux-gnu/) does not exist.
>     Warning: arch-independent data dir
> (/usr/local/share/emacs/19.34/etc/) does not exist.
>     Warning: Lisp directory `/usr/local/share/emacs/19.34/site-lisp'
> does not exist.
>     Warning: Lisp directory `/usr/local/share/emacs/site-lisp' does not
> exist.
>     Warning: Lisp directory `/usr/local/share/emacs/19.34/lisp' does not
> exist.
>     Cannot open load file: term/x-win

> that I corrected with a symbolic link as follows

>     gray:/usr/local[503] ln -s /usr/share .
>     gray:/usr/local[504] ln -s /usr/libexec .

> Also, when I tried to load info I get the message

>     Can't find the info directory node

> I have not found a solution to this one.

> Did I do something wrong or is it a problem with the distribution?

> Regards,
> Sergio Antoy

Did you compile the program, or did you install the binaries? It looks
like you installed the full source version, which you need to compile
before you can use it.

HTH

 
 
 

1. RedHat's Emacs 19.34: h_errno_ problem

I downloaded RedHat's emacs19.34 and got
./emacs: can't resolve symbol '_h_errno'
Segmentation fault      

I have CND 1.0 with various packages updated.
I tested Slackware's emacs19.34 and it worked just fine.

Does anyone know what could be the problem?

Yan

2. New User -- Still Persevering"" .. "X" windows help please ..

3. networking problem with emacs 19.34, RH 4.2, AFS

4. RH 5.1 FTP installation Failure

5. Problems compiling emacs 19.34 on Solaris 2.6

6. perl conversion in ksh

7. Emacs 19.34 problems compiling in Linux

8. Amaya: Small startup problem.

9. Emacs 19.34 compile problem: getpagesize

10. ssh/emacs 19.34 on Solaris/XF863.2A combo kills X server

11. Emacs 19.34

12. Emacs 19.34 on linux 2.2.15

13. emacs 19.34 and FBSD 4.0