Big serial problem (long)

Big serial problem (long)

Post by Luc Saint-El » Wed, 21 Feb 1996 04:00:00



I was playing around with the ppp-on script and now i've no more acces to
my modem serial port.

* I've NO LCK.. fil in /var/lock
* I shutdown and restarted my machine without success
* My modem works (I use it with two machines, a Mac and the Linux box,
i'm posting this message with the same modem from the Mac)
* I've uninstalled and reinstalled Minicom but no change
* When I launch Minicom the modem blinks a very short time and them
desn't move anymore..

here are some tests :

# ls -alt /dev/cua*
crw-rw-rw-   1 root     root       5,  65 Feb 13 22:29 /dev/cua1
crw-rw-rw-   1 root     root       5,  64 Jan  1  1980 /dev/cua0
crw-rw-rw-   1 root     root       5,  66 Jan  1  1980 /dev/cua2
crw-rw-rw-   1 root     root       5,  67 Jan  1  1980 /dev/cua3

This answer is strange as it appeasr that my /dev/cua1 is from today and
that's not the case, it was set by the Install a month ago in same time
that other /dev/cua*

#ls - alt /dev/modem
lrwxrwxrwx   1 root     root            4 Feb 13 22:27 /dev/modem -> cua1

# /bin/setserial -bg /dev/cua1
/dev/cua1 at 0x02f8 (irq = 3) is a 16450

# stty -a </dev/cua1
speed 9600 baud; rows 24; columns 80; line = 0;
intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = <undef>;
eol2 = <undef>; start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R; werase = ^W;
lnext = ^V; flush = ^O; min = 1; time = 0;
-parenb -parodd cs8 -hupcl -cstopb cread -clocal -crtscts
-ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl ixon
-ixoff
-iuclc -ixany -imaxbel
opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0
vt0 ff0
isig icanon iexten echo echoe echok -echonl -noflsh -xcase -tostop
-echoprt
echoctl e*

If anybody as a solution..

Thanks in advance

 Luc Saint-Elie                    Paris                  France

 CIS: 100341,3156                  tel: (int + 33-1) 42 59 08 94

 
 
 

Big serial problem (long)

Post by Vern Hox » Sat, 24 Feb 1996 04:00:00




>I was playing around with the ppp-on script and now i've no more acces to
>my modem serial port.

>* I've NO LCK.. file in /var/lock
>* I shutdown and restarted my machine without success
>* My modem works (I use it with two machines, a Mac and the Linux box,
>i'm posting this message with the same modem from the Mac)
>* I've uninstalled and reinstalled Minicom but no change
>* When I launch Minicom the modem blinks a very short time and them
>desn't move anymore..

>here are some tests :

># ls -alt /dev/cua*
>crw-rw-rw-   1 root     root       5,  65 Feb 13 22:29 /dev/cua1
>crw-rw-rw-   1 root     root       5,  64 Jan  1  1980 /dev/cua0
>crw-rw-rw-   1 root     root       5,  66 Jan  1  1980 /dev/cua2
>crw-rw-rw-   1 root     root       5,  67 Jan  1  1980 /dev/cua3

The date changes each time the device is changed.  The taylor uucp changes
the ownership to 'uucp', hence a new date.

Quote:>This answer is strange as it appeasr that my /dev/cua1 is from today and
>that's not the case, it was set by the Install a month ago in same time
>that other /dev/cua*

I don't use cua*.  I have found that all the functionality of any serial
operation can be made via ttyS*

- Show quoted text -

Quote:>#ls - alt /dev/modem
>lrwxrwxrwx   1 root     root            4 Feb 13 22:27 /dev/modem -> cua1

># /bin/setserial -bg /dev/cua1
>/dev/cua1 at 0x02f8 (irq = 3) is a 16450

># stty -a </dev/cua1
>speed 9600 baud; rows 24; columns 80; line = 0;
>intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = <undef>;
>eol2 = <undef>; start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R; werase = ^W;
>lnext = ^V; flush = ^O; min = 1; time = 0;
>-parenb -parodd cs8 -hupcl -cstopb cread -clocal -crtscts
>-ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl ixon
>-ixoff
>-iuclc -ixany -imaxbel
>opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0
>vt0 ff0
>isig icanon iexten echo echoe echok -echonl -noflsh -xcase -tostop
>-echoprt
>echoctl e*

These parameters are changed by virtually every program which uses the
port.  What you see here is only a transient configuration.

Try the getty and ppp_call programs I have in a collection of serial port
utilities I have generated.  The name of the collection is
'serial-suite.tgz' and is available via 'anonymous' ftp from
'scicom.alphacdc.com'.  You must use your complete e-mail address as the

The names of the programs are 'getty_em' and 'call_em'.  'Call_em' uses the
HDB type configuration files you may already have on your system.  If you
don't heve these, they can be generated by running taylor's 'uuconv'.

This collection is 'under construction', hence the local access instead of
uploading to 'sunsite'.  Additions I am working on are:
   A.  Using taylor type configuration files.  I am suffering a serious
       writer's block on this as I have bias about the contorted manner in
       which the entries are defined.
   B.  A start up "shell" to be run on the server when a ppp login is
       attempted.  My server is a Sun and his serial port is screwed up
       each I run his 'pppd' by logging in.  I have to call back with
       'Uutry' to flush his port after I have disconnected.
   C.  A security check above and beyond the standard password check.  This
       is for those sites which have a problem with crackers or just
       paranoid.   I have generated the security check but haven't wrapped
       it into the programs which will use it.
   D.  Have 'getty_em' switch to a 'efax' instead of 'login' when a fax is
       detected by the modem.  I have just learned that the modem I am
       using  does not support the AT+FAA=1 command. Arrgh!!

vern

--
Vernon C. Hoxie                                           scicom!zebra!vern

Denver, Colo., 80212        uucp: 303-455-2670          voice: 303-477-1780

 
 
 

1. I have a BIG, BIG,BIG problem with DOSEMU 0.98.5.

Hello,

Please can some one help me with this:

I have Red Hat 5.2, kernel 2.0.36, dosemu 0.98.5.
When i start DOSEMU then the config.sys and autoexec.bat will not load into
the computer his memory in DOSEMU.
I have placed the config.sys and the autoexec.bat on c:\
I have set the var. $_emusys = "sys" and $_emubat = "bat" into the
dosemu.conf.

But it will not work, can some one help me, what do i wrong?

Greatings Jarno

2. Oudeis - call for participation

3. Big IDE HD problems with lilo (long)

4. How to set reply-to in mail

5. big disk problems - or: big-disk problems?

6. Cyclades 4 port serial ISA card?

7. Serial Port Problems (the big bad SPP)

8. Fast CD-ROM Mounting

9. Big Problem with serial lines/Modems

10. Big Big Big CORE Image !!

11. Big, Big Very BIG SCSI DISK

12. long long & long double types in Linux GCC

13. RH7.2 2.4.X off_t: long or long long?