help! startX hangs up

help! startX hangs up

Post by arie » Mon, 03 Sep 2001 19:42:44



I've installed RedHat 7.1 on a Pentium 120 MHz, with Trident graphics
card, 3Com network card and NO soundcard.
Install works fine, also the test (with mouse) of the monitor, and
after install Linux boots fine.
Then I log in a root on terminal 1 and give the 'startx' command.
The KDE desk comes up with a window and mouse pointer, alas, the mouse
doesn't respond.
After Ctrl-Alt-F2 - Ctrl-Alt-F1 I come in the terminal 1 text mode
where the following messages are displayed:

(II) TRIDENT(0): Using XFree86 Acceleration Architecture (XAA)
        Screen to screen bit blits
        Solid filled rectangles
        8x8 mono pattern filled rectangles
        Indirect CPU to Screen color expansion
        Solid Lines
        Dashed Lines
(==) TRIDENT(0): Backing store disabled
(**) TRIDENT(0): DPMS enabled
(**) Mouse0: Protocol: "Microsoft"
(**) Mouse0: Core Pointer
(==) Mouse0: Buttons: 3
(**) Mouse0: Emulate3Buttons, Emulate3Timeout: 50
(**) Mouse0: ZAxisMapping: buttons 4 and 5
(**) Mouse0: BaudRate: 1200
(II) Keyboard "Keyboard0" handled by legacy driver
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
X Error of falied request: 86
        Major opcode of failed request: 51 (X_XetFontPath)
        Serial number of failed request: 9
        Current serial number in output stream: 11
Error while initializing the sound driver:
device /dev/dsp can't be opened (No such device)
QSocketNotifier: Multiple socket notifiers for same socket 6 and type
read

and then only a blinking underscore on the next line, and terminal 1
hangs.
Is this a mouse problem? and if so: how can I solve it?
And why the sound driver error? Does RedHat in fact require a sound
card? Won't it work without sound card?

If someone has suggestions, please let me know,
thanks a lot on beforehand.

arie