Trouble upgrading from glibc-2.1.2 to glibc-2.2.2 (rpm failed dependencies)

Trouble upgrading from glibc-2.1.2 to glibc-2.2.2 (rpm failed dependencies)

Post by Eri » Mon, 24 Sep 2001 04:34:10



I know this problem has been batted around a few times, but I haven't
been able to find information to help me complete my upgrade
successfully.

I've got an old install of Redhat 5.1 which I have since partially
upgraded upon demand.  I currently want to install glibc-2.2.2, but am
having trouble upgrading it with rpm.  Installing a version greater
than 2.1.3 seems to comflict with rpm-4.0.

#root:# rpm -i --test glibc-2.2.2-10.i386.rpm
error: failed dependencies:
        glibc-common = 2.2.2-10 is needed by glibc-2.2.2-10
        glibc > 2.1.3 conflicts with rpm-4.0-6x

If I try to upgrade to a newer version of rpm (ie: rpm-4.0.3), I get
dependency errors asking for a newer version of the glibc library.

#root:# rpm -U --test rpm-4.0.3-1.04.i386.rpm
error: failed dependencies:
        popt = 1.6.3 is needed by rpm-4.0.3-1.04
        libbz2.so.1   is needed by rpm-4.0.3-1.04
        libc.so.6(GLIBC_2.1.3)   is needed by rpm-4.0.3-1.04
        libc.so.6(GLIBC_2.2)   is needed by rpm-4.0.3-1.04
        libc.so.6(GLIBC_2.2.3)   is needed by rpm-4.0.3-1.04

How am I supposed to install GLIBC_2.2 or GLIBC_2.2.3 if installing it
conflicts with my RPM package?  Is there a mid-step that I should be
doing first?  If I install the newer version of glibc, then I'll break
rpm, and won't be able to install the newer version of rpm4.0.3!  Am I
missing something?

Thanks for the help!

Eric

 
 
 

Trouble upgrading from glibc-2.1.2 to glibc-2.2.2 (rpm failed dependencies)

Post by Artem S. Tashkino » Thu, 27 Sep 2001 00:57:17



> I know this problem has been batted around a few times, but I haven't
> been able to find information to help me complete my upgrade
> successfully.

> I've got an old install of Redhat 5.1 which I have since partially
> upgraded upon demand.  I currently want to install glibc-2.2.2, but am
> having trouble upgrading it with rpm.  Installing a version greater
> than 2.1.3 seems to comflict with rpm-4.0.

> #root:# rpm -i --test glibc-2.2.2-10.i386.rpm
> error: failed dependencies:
>         glibc-common = 2.2.2-10 is needed by glibc-2.2.2-10
>         glibc > 2.1.3 conflicts with rpm-4.0-6x

> If I try to upgrade to a newer version of rpm (ie: rpm-4.0.3), I get
> dependency errors asking for a newer version of the glibc library.

> #root:# rpm -U --test rpm-4.0.3-1.04.i386.rpm
> error: failed dependencies:
>         popt = 1.6.3 is needed by rpm-4.0.3-1.04
>         libbz2.so.1   is needed by rpm-4.0.3-1.04
>         libc.so.6(GLIBC_2.1.3)   is needed by rpm-4.0.3-1.04
>         libc.so.6(GLIBC_2.2)   is needed by rpm-4.0.3-1.04
>         libc.so.6(GLIBC_2.2.3)   is needed by rpm-4.0.3-1.04

> How am I supposed to install GLIBC_2.2 or GLIBC_2.2.3 if installing it
> conflicts with my RPM package?  Is there a mid-step that I should be
> doing first?  If I install the newer version of glibc, then I'll break
> rpm, and won't be able to install the newer version of rpm4.0.3!  Am I
> missing something?

> Thanks for the help!

> Eric


U must have both glibc-2.2.x.rpm glibc-common-2.2.x.rpm in the same dir.
Then rpm -U *
That's all