ldconfig: warning: /lib/libc.so.4.6.27 is not a ZMAGIC file, skipping

ldconfig: warning: /lib/libc.so.4.6.27 is not a ZMAGIC file, skipping

Post by Ken Fisl » Tue, 15 Oct 1996 04:00:00



Hi, all!

After putting libc.so.4.6.27 in /lib and running ldconfig, I got
this error message:

ldconfig: warning: /lib/libc.so.4.6.27 is not a ZMAGIC file, skipping

So I got libc.so.4.7.6 and put it in /lib --  ran ldconfig and got:

ldconfig: warning: /lib/libc.so.4.6.27 is not a ZMAGIC file, skipping
ldconfig: warning: /lib/libc.so.4.7.6 is not a ZMAGIC file, skipping

After each of these upgrade attempts libc.so.4 remains a symlink to
my old libc.so.4.5.19.

What's the problem here?

How do I fix it...??  i.e., upgrade to libc.so.5 ??

I'm (still)using Linux 1.2.13  ...

[Yes, yes, I'm planning/hoping to move up to 2.0 any week now.
First, though, I need to get a couple things working/done.]

Ken

-------------------------------------------------------------
Ken Fisler

-------------------------------------------------------------

 
 
 

1. /lib/libc.so.4.5.26 and /lib/libc.so.4.6.27

: I recently upgraded to GCC 2.6.2 which requires the c library version
: 4.6.27.  So I installed this, and it stuck libc.so.4.6.27 in my /lib
: directory.  But libc.so.4.5.26 still exists there, and when I run gcc, it
: says 'using incompatible library 'lib/libc.so.4.5.26'.  I mistakenly
: removed 4.5.26 and had big problems.  So how do I tell gcc to recognize
: 4.6.27?, I must be missing a step.  (I just used pkgtool to load both gcc
: and the new libc (and libg++, include, image, and extralib).)  Anyway,
: any help would be appreciated.

I have the same problem but with 4.5.26. I run 4.4 now and have
installed all 4.5-files(I have copied all the files from a machine
with 4.5 from /lib). I have made the symlink libc.so.4 point to my new
library, but it still uses 4.4. Anyone?

--

2. installing RH4.0 on ide/scsi system ?

3. Flat database

4. Help, installed 3.1.2b, now incompatible library error '.lib/libc.so.4.6.27'

5. Term and Minicom dialup

6. ldconfig: warning: ../../ is not a ZMAGIC file - skipping -- help!

7. Basic kernel module help needed!

8. ghostscript and libc 4.6.27 not work together?

9. login breaks w. libc.4.6.27

10. Problems after installation of libc.4.6.27

11. Found+fixed bug libc 4.6.27 - please comment

12. Linux 1.1.77 & libc 4.6.27 & system()