problem configuring 1.2.13 kernel

problem configuring 1.2.13 kernel

Post by SCB » Fri, 23 Feb 1996 04:00:00



Hi,

I have a GUS soundcard so I want to configure my kernel.
I have installed the 1.2.13 sources, but the 'make' command fails:
Here is the output at the point that it goes wrong.

ld -qmagic -Ttext 0xfffe0 arch/i386/kernel/head.o init/main.o init/version.o \  
        arch/i386/kernel/kernel.o arch/i386/mm/mm.o kernel/kernel.o mm/mm.o fs/fs.o net/net.o
        ipc/ipc.o \
        fs/filesystems.a \
        drivers/block/block.a drivers/char/char.a drivers/net/net.a drivers/sound/sound.a \
        /usr/src/linux/lib/lib.a -o vmlinux
ld: warning: cannot find entry symbol _start; defaulting to 00fffe0
arch/i386/kernel/head.o(.text+0x18): undefined reference to `__edata'
arch/i386/kernel/head.o(.text+0x1d): undefined reference to `__end'
arch/i386/kernel/head.o(.text+0x7f): undefined reference to `_x86'
.
.
.

Can anyone tell me what's wrong??? Personally I thing that it has something to do with the
unreferenced sybol _start.

Robert

 
 
 

1. strange problems 1.2.13 --> 2.0.0 --> 1.2.13

Hi,

I have some strange problems with the new kernel source tree...

after the installation of the new sysvinit-2.62 the linux-2.0.0 kernel
complains sh:/bin/bash cannot execute...
with 1.99.7 this works fine
and at least I'm totally unable to recompile the 1.2.13 source tree due
some strange asm errors in main occurring in asm/io.h referenced by
bugs.h  (also within the asm tree). Of course I checked the appropriate
links to for the linux source tree /usr/include/linux
                                                asm

Please help....
 Michael

-------------------------------------------------------------------------------
        Michael Rietz                   |       Office: 13

        Werner Heisenberg Institut      |       phone:+49-(0)89-32354-242,
        Foehringer Ring 6               |                             415,411
        D-80805 Muenchen                |       fax:    +49 (0)89 3226704
                                        |
                            is there anybody OUT there...
-------------------------------------------------------------------------------

2. windows - linux network problem

3. 1.2.13 kernel is slower than 1.2.1 kernel

4. changing the CD in the CDROM

5. IP alias - Kernel crash - 1.2.13 kernel, 3com 3c590 module

6. sup server

7. Problem compiling wu-ftpd (2.4) on Redhat 3.0.3 (1.2.13 Kernel)

8. Setting Konqueror Profile for "man:"

9. Kernel problem 1.2.13 & 1.3.73

10. Problem Compiling kernel 1.2.13 + SB16PnP

11. Problem with NCSA-Telnet and kernel > 1.2.13

12. kernel 1.2.13 compile problems

13. Strange Ftape 2.03b problem with Kernel 1.2.13