Bus Mouse - MS Inport Bus mouse will not work

Bus Mouse - MS Inport Bus mouse will not work

Post by SW Stea » Sat, 24 Apr 1999 04:00:00



I have an MS InPort Mouse. It is from an early vintage, a "Dove Bar" SN
1177542.
I have it hardware configured at Interrupt 5.
The mouse works correctly under the DOS mouse driver and passes hardware
diagnostics.

I am Running RedHat Linux i386 v 5.2
I have read through and tried the combinations from the BusMouse-HOWTO
Specifically, I have booted with the LILO parameter > linux bmouse=5
Startup messages confirm that interrupt 5 is assigned to the bus mouse:
"Logitech bus mouse detected, using IRQ 5" Followed by:
"ATI Inport Bus mouse detected and installed."
gpm gives an error on startup " gpm: /dev/mouse : Operation not supported by
device"
My /dev/mouse is a link to /dev/inport which is at major device number 10,
minor 2.
I have tried using XF86Setup and configuring the mouse as:
Busmouse, Microsoft, Logitech as suggested by the HOWTO

None of it works.
Any ideas making the little beast operate?

 
 
 

1. Bus Mouse - MS Inport Bus mouse will not work

I have an MS InPort Mouse. It is from an early vintage, a "Dove Bar" SN
1177542, with Teflon glides
I have it hardware configured at Interrupt 5.
The mouse works correctly under the DOS mouse driver and passes hardware
diagnostics. I have also
tried several other diagnostic packages. Each allows operation of the mouse
and the mouse has no hardware errors.

I am running RedHat Linux i386 v 5.2 (2.0.36)
I have read through and tried the combinations from the BusMouse-HOWTO you
wrote.
Specifically, I have booted with the LILO parameter > linux bmouse=5 and I
have tried msmouse=5
In each instance, the Startup messages confirm that interrupt 5 is assigned
to the bus mouse:
"Logitech bus mouse detected, using IRQ 5"
Followed by:
"ATI Inport Bus mouse detected and installed."
BTW: I checked my kernel and the inport mouse is configured for IRQ 5.
gpm gives an error on startup " gpm: /dev/mouse : Operation not supported by
device"
My /dev/mouse is a link to /dev/inport which is at major device number 10,
minor 2.
I have tried using XF86Setup and configuring the mouse as:
Busmouse, Microsoft, Logitech as suggested by the HOWTO

None of it works.
Any ideas making the little beast operate?

Thank you.
Stan Stead

2. Microsoft Acess on Samba

3. MS-INPORT bus mouse not working.

4. xmotif

5. Is an InPort Mouse a Bus Mouse?

6. BYE BYE LINUX...

7. Help with X and MS Inport Bus Mouse

8. sleep utility question

9. MS Bus Mouse Not Working

10. Slackware Linux 2.3 does not see Microsoft "Inport" Bus Mouse

11. MS Bus Mouse not working properly

12. Mouse Systems PC Mouse 3D/6D Bus Mouse driver?