Boot Problem

Boot Problem

Post by Bob » Sun, 23 Sep 2001 00:09:03



I'm trying to install RH 7.1.  I go through the entire installation
OK, then on boot it fails at "calibrating delay loops".  The system
keeps looping 4f>] - then different numbers and letters in brackets.
Is there anyway to skip this step or any other fixes.  I have tried
linux emergency, linux single.

Thanks
Bob

 
 
 

1. dual-HD, dual-boot problem ... booting Win98 fails on hdb

I put one harddisk in my computer and installed Mandrake7.2.  I then
popped this disk out, popped a new disk in, and installed Windoze 98
on it. I then made this disk the slave (hdb) and put back in my
Mandrake disk as hda, and then booted into Linux (using grub).
Mandrake recognizes my /dev/hdb when I mount it automatically as
/mnt/win98. So, the problem I'm about to describe doesn't seem to be a
problem with the harddisk, slave setting, etc.

I then used DrakConf to change my grub configuration so that it
associated win98 with /dev/hdb1. I then tried rebooting, booting linux
through grub still works fine, but when I choose win98 through grub, I
got the following error:

Booting 'win98'
root(hd1,0)
Error: selected disk does not exist.

I assume that this error is related to the fact that when win98 was
installed on hdb, it was actually hda at the time.  Now it's confused
b/c it's hdb. ??  (said another way: I think the problem is confusion
over the fact that windows was originally installed when that disk was
hda, but now it's hdb.)

I recently read (somewhere on usenet) the following suggestion:

the "map" command under GRUB would trick this second drive (hd1) to
think
that it owned the first partiition, thereby allowing it to dual boot.

#################################
# /boot/grub/menu.lst - generated by Lizard

*** Linux lines cut out to save space

# for booting Windows 98

title  = win98
root  = (hd1,0)
makeactive
map (hd0) (hd1)
map (hd1) (hd0)
chainloader +1
###################################

So, I tried this, but not knowing anything about grub, I
think I used the grub command to install it incorrectly,
because when I tried to reboot, grub failed to work properly
at all, and I had to boot with my boot floppy.

So, how can I solve this? Is the grub map approach the
right direction? If so, how do I do it correctly (e.g.,
what do I need to type on the command line after editing
the menu.lst file?)

If not, is there another way. I had a similar problem a couple
of years ago, and someone suggested that I use a program
(which I don't remember the name of) that allowed me to
go in and (I believe) edit the master boot record on my
windows hard drive to tell it that it was now the hdb
drive. I did that successfully that time. Should I try
that again, and if so, what's the program called that
allows me to edit it?

Sent via Deja.com
http://www.deja.com/

2. 686's and BogoMIPS

3. Lilo boot problem: doesn't boot dos (invalid media type)

4. Seyon terminal emulation.

5. Slackware Boot Disks booting problems

6. 2.5.57 ALSA sound/core/pcm_lib.c

7. Boot problem of the 2nd disk: defective boot record

8. Modem Access - Please Help!

9. booting problems: linux dual boot

10. 2.2-GAMMA-0225 boot floppy causing boot problem

11. Win95 boot problems on multi-boot LILO system

12. NT/LIINUX dual boot problem: NT boot failed

13. boot problem with boot floppy