my 3c509b not detected by installed kernel, IS detected when I use net root disk.

my 3c509b not detected by installed kernel, IS detected when I use net root disk.

Post by Rakesh Kumar Agraw » Thu, 11 Jan 1996 04:00:00



I recently installed slackware 3.0 on my machine and for some reason the
installed kernel does not detect the network interface card in my
computer, a 3com 3c509b.  But, when I boot from a seperate root disk (the
net root disk) and then type mount root=/dev/hdb2 it detects the card
just fine.  What is the problem?

--Rakesh

 
 
 

my 3c509b not detected by installed kernel, IS detected when I use net root disk.

Post by MB. Tayl » Thu, 11 Jan 1996 04:00:00



Quote:>I recently installed slackware 3.0 on my machine and for some reason the
>installed kernel does not detect the network interface card in my
>computer, a 3com 3c509b.  But, when I boot from a seperate root disk (the
>net root disk) and then type mount root=/dev/hdb2 it detects the card
>just fine.  What is the problem?
>--Rakesh

Have you set up the 3C509B properly?
You need to disable Plug and Play and possibly select the output media.

-----------------------------------------------------------------------
| Mark Beauchamp Taylor  -  physicist trapped in a chemist's body.    |

| Department of Chemistry, University of Bristol, UK                  -------
-----------------------------------------------------| ... It's the future! |
                                                     ------------------------

 
 
 

my 3c509b not detected by installed kernel, IS detected when I use net root disk.

Post by Rakesh Kumar Agraw » Fri, 12 Jan 1996 04:00:00




>Have you set up the 3C509B properly?
>You need to disable Plug and Play and possibly select the output media.

Yeah.  I have it set up properly.  Plug and play is disabled and the
output media has been selected.
--Rakesh
 
 
 

my 3c509b not detected by installed kernel, IS detected when I use net root disk.

Post by Louis POT » Sat, 13 Jan 1996 04:00:00



> I recently installed slackware 3.0 on my machine and for some reason the
> installed kernel does not detect the network interface card in my
> computer, a 3com 3c509b.  But, when I boot from a seperate root disk (the
> net root disk) and then type mount root=/dev/hdb2 it detects the card
> just fine.  What is the problem?

> --Rakesh

Did you build a new kernel with 3Com 3c509 support ?

The default kernel installed from setup doesn't
have that driver included.

--
Louis POTY              |  Just some words for |

From Strasbourg, FRANCE |    ( An old dream)   |
************************************************

 
 
 

my 3c509b not detected by installed kernel, IS detected when I use net root disk.

Post by Vic Hoov » Sun, 14 Jan 1996 04:00:00



: I recently installed slackware 3.0 on my machine and for some reason the
: installed kernel does not detect the network interface card in my
: computer, a 3com 3c509b.  But, when I boot from a seperate root disk (the
: net root disk) and then type mount root=/dev/hdb2 it detects the card
: just fine.  What is the problem?

: --Rakesh

I don't believe the default Slackware kernel has 'compiled in' support
for the 3C509 cards (I know that the 1.2.x kernels I've used did not).
You'll have to reconfigure and recompile your kernel to support the card.

Generally, this is a good idea any time you load a new kernel.  It makes
sure that everything you need is installed and gets rid of unecessary
drivers you don't need that are just wasting space.

        - Vic

     +-----------------------+----------------------------------------+
     |     Vic Hoover        |   My new home since the takeover and   |

     +-----------------------+----------------------------------------+