Newbie needs help with library upgrade (dependency problem)

Newbie needs help with library upgrade (dependency problem)

Post by sh » Tue, 23 Feb 1999 04:00:00




>Help! I'm trying to upgrade libstdc++.so.2.9 from 2.8, when I used
the
>command "rpm -Uvh filename" I got a depedency error (mostly kde
>packges depended on it), using --force didn't help, using --nodeps
end
>up breaking the thing so I went back to 2.8.

What are you error messages? Please describe it.

Don't use --force and --nodep unless you know what you are doing. You
may end up breaking another part of your system.

Quote:>So the question is: how do I upgrade from the old version to the new
>version without breaking dependency?

Again, what are the error/dependency messages? It will help if you
show them. They will give you an idea of what to do (eg.
upgrading/uninstalling other packages). Personally I don't know a
bullet-proof procedure for upgrading except by interpreting the
error/dependency messages.
 
 
 

Newbie needs help with library upgrade (dependency problem)

Post by Sunny Wo » Wed, 24 Feb 1999 04:00:00


Help! I'm trying to upgrade libstdc++.so.2.9 from 2.8, when I used the
command "rpm -Uvh filename" I got a depedency error (mostly kde
packges depended on it), using --force didn't help, using --nodeps end
up breaking the thing so I went back to 2.8.

I've had the same problem with glib-1.1.15 as well.

So the question is: how do I upgrade from the old version to the new
version without breaking dependency?

 
 
 

Newbie needs help with library upgrade (dependency problem)

Post by Sunny Wo » Wed, 24 Feb 1999 04:00:00


On Mon, 22 Feb 1999 17:43:54 -0800, "sh"



>>Help! I'm trying to upgrade libstdc++.so.2.9 from 2.8, when I used
>the
>>command "rpm -Uvh filename" I got a depedency error (mostly kde
>>packges depended on it), using --force didn't help, using --nodeps
>end
>>up breaking the thing so I went back to 2.8.

>What are you error messages? Please describe it.

Thanks for the reply.

All it says is:

failed dependencies:
libstdc++so.2.8 is needed by xxxxx

And a list of apps where xxxxx is.

 
 
 

Newbie needs help with library upgrade (dependency problem)

Post by Boyd Meie » Sat, 27 Feb 1999 04:00:00


What I ended up doing was installing the new libstdc so that the old and
new versions coexist (rpm -i libstdc++-2.9-0.i386.rpm), and upgrading
the development package (rpm -U libstdc++-devel-2.9-0.i386.rpm) so that
I can recompile apps against the new version.  It seems to work - I can
run the apps that it complained about w/o problems, as well as new apps
compiled against 2.9.  YMMV.

Good luck.
        Boyd


> On Mon, 22 Feb 1999 17:43:54 -0800, "sh"


> >>Help! I'm trying to upgrade libstdc++.so.2.9 from 2.8, when I used
> >the
> >>command "rpm -Uvh filename" I got a depedency error (mostly kde
> >>packges depended on it), using --force didn't help, using --nodeps
> >end
> >>up breaking the thing so I went back to 2.8.

> >What are you error messages? Please describe it.

> Thanks for the reply.

> All it says is:

> failed dependencies:
> libstdc++so.2.8 is needed by xxxxx

> And a list of apps where xxxxx is.

 
 
 

Newbie needs help with library upgrade (dependency problem)

Post by Sunny Wo » Sat, 27 Feb 1999 04:00:00


Thanks, that worked.

But still, it'd be nice to know how to get the apps to link to the
newer libraries so that I can get rid of the old libraries (not much
disk space taken up, but stil...)



Quote:>What I ended up doing was installing the new libstdc so that the old and
>new versions coexist (rpm -i libstdc++-2.9-0.i386.rpm), and upgrading
>the development package (rpm -U libstdc++-devel-2.9-0.i386.rpm) so that
>I can recompile apps against the new version.  It seems to work - I can
>run the apps that it complained about w/o problems, as well as new apps
>compiled against 2.9.  YMMV.

 
 
 

1. Help with building shared libraries with dependencies on other shared libraries

Hi all,

I'm having problems running my application in Linux (RedHat 7.1) that loads
up ten shared libraries, all but one have dependencies with the other shared
libraries. The application is written in Java, so in the code I load up the
libraries using

System.loadLibrary("lib1");

The libraries are written in C++ and I'm using VIDE (integrated development
environment) to create my makefile. The complier is g++ and for linking
flags I have: -fPIC -shared.

When I try to run my application on Linux, it loads up the first shared
library lib1 correctly but when it tries to load the second one lib2 it
complains about unresolved symbols, the ones that were defined in lib1. When
I compiled all the code and made it lib1, the application worked but for
this project it is required that I have multiple shared libraries. So is
there a way to build these libraries that are dependent on each other so
that I won't have the unresolved symbols problem or is there a way in Java
to load up all the libraries simultaneously? Any help is appreciated.
Thanks,

Johnny

2. 2.5.47-ac6 : drivers/media/video/saa7185.c

3. Newbie needs help: Makefile Dependencies

4. automount problems

5. Help, newbie upgrading shared libraries

6. dosemu - I'm curious

7. Need help upgrading GCC and related libraries

8. Help with Linux basicfile set (newbe)

9. Library dependencies coded into the libraries?

10. Linux newbie needs help with libraries

11. Newbie needs help with libraries

12. Newbie needs help with upgrade to 2.0.31

13. Newbie need help - Upgrade RAM