Make error when trying to install expect with Slackware Linux

Make error when trying to install expect with Slackware Linux

Post by Gary Nielso » Mon, 17 Aug 1998 04:00:00



I've been trying to install expect in Slackware Linux. Installed tcl
first, of course, and whenever I run "make" or "make expect", I get the
following error:

/bin/sh: autoconf: command not found
make *** [configure] Error 127

and it aborts. I definitely have sh and /bin is in the pathway. I am new
to compiling programs in Unix and this may very well be an easy one to
solve. Can anyone help me?

Please email reply as well.

Gary
C*te NC

 
 
 

Make error when trying to install expect with Slackware Linux

Post by walt moffe » Mon, 17 Aug 1998 04:00:00



>I've been trying to install expect in Slackware Linux. Installed tcl
>first, of course, and whenever I run "make" or "make expect", I get the
>following error:

>/bin/sh: autoconf: command not found
>make *** [configure] Error 127

>and it aborts. I definitely have sh and /bin is in the pathway. I am new
>to compiling programs in Unix and this may very well be an easy one to
>solve. Can anyone help me?

you need autoconf and probably libtool which you can pick up in source at:

sunsite.unc.edu/pub/gnu/ (or any gnu mirror)

get autoconf-2.12.tar.gz and libtool-1.2.tar.gz.  tar xvfz into /usr/src
read the docs and you'll learn a lot.

 
 
 

1. comps 0.1 expected error message when trying to install

I downloaded the Linuxppc package and am installing it on a Starmax 3180
with a g3 upgrade.  I'm installing on a separate hardrive and have followed
the directions on the Linuxppc Guide.  I'm put into the Red Hat installer
and get to the point where the installation of the program begins and I get
the message that comps 0.1 is expected and can't be found.  I downloaded the
file again from linuxppc.org and the the results were the same.  Is there a
simple solution.  Thanks for your help.

2. "Unable to handle kernel paging request" x 3

3. I get this error when I try to install Slackware v3.0.

4. Kpilot and Korganizer

5. any hints, bewares: will try making antiword-0.35 install for solaris9/sparc

6. Unix Backup Software and Suggestions

7. Ever Tried Expect Program on Linux???

8. Problem using phat linux

9. made a reall mess trying to install the new gcc c compiler (please help)

10. Trying to install RedHat Linux 5.2, I/O errors!!!

11. Install error: "comps file is not version 0 as expected"

12. iBCS and ppp problems after installing slackware 3 and making new kernal 1.3.74

13. HELP - Slackware crashes in kernel while trying to install