After recompiling kernel with PPP support, pppd says the kernel has no PPP support!

After recompiling kernel with PPP support, pppd says the kernel has no PPP support!

Post by Ivan Fet » Sun, 07 Feb 1999 04:00:00



Hello,
   I have recompiled my 2.0.35 (Slackware 3.6) kernel with PPP support
(directly in to the kernel), but after copying my zImage file to /vmlinuz,
and re-running lilo, and rebooting the machine, pppd says that there is no
ppp support in my kernel.  I know I'm booting with my new kernel - Any
ideas out there?

Thanks a alot for your help, in advance -- Ivan.
5

 
 
 

After recompiling kernel with PPP support, pppd says the kernel has no PPP support!

Post by Clone Rang » Mon, 08 Feb 1999 04:00:00




Quote:>Hello,
>   I have recompiled my 2.0.35 (Slackware 3.6) kernel with PPP support
>(directly in to the kernel), but after copying my zImage file to /vmlinuz,
>and re-running lilo, and rebooting the machine, pppd says that there is no
>ppp support in my kernel.  I know I'm booting with my new kernel - Any
>ideas out there?

1. Did you compile PPP to be included in your kernel?
2. Did you 'make modules' and 'make modules_install' after compiling
your kernel?
3. Did you 'make' and 'make install' in your PPP main directory AFTER
step 3 above?

 
 
 

After recompiling kernel with PPP support, pppd says the kernel has no PPP support!

Post by Tim Dea » Tue, 09 Feb 1999 04:00:00


this is the same problem i am having!! YES i have compiled it _with_ PPP
support, i even get the nice messages saying so at boot-up and i have done all
the steps below as well!! argh



> >Hello,
> >   I have recompiled my 2.0.35 (Slackware 3.6) kernel with PPP support
> >(directly in to the kernel), but after copying my zImage file to /vmlinuz,
> >and re-running lilo, and rebooting the machine, pppd says that there is no
> >ppp support in my kernel.  I know I'm booting with my new kernel - Any
> >ideas out there?

> 1. Did you compile PPP to be included in your kernel?
> 2. Did you 'make modules' and 'make modules_install' after compiling
> your kernel?
> 3. Did you 'make' and 'make install' in your PPP main directory AFTER
> step 3 above?

 
 
 

After recompiling kernel with PPP support, pppd says the kernel has no PPP support!

Post by dmorgan1REMOVET.. » Tue, 09 Feb 1999 04:00:00


There's a little discussion of this in section 18.1 of the PPP HOWTO.


>Hello,
>   I have recompiled my 2.0.35 (Slackware 3.6) kernel with PPP support
>(directly in to the kernel), but after copying my zImage file to /vmlinuz,
>and re-running lilo, and rebooting the machine, pppd says that there is no
>ppp support in my kernel.  I know I'm booting with my new kernel - Any
>ideas out there?

>Thanks a alot for your help, in advance -- Ivan.
>5

 
 
 

After recompiling kernel with PPP support, pppd says the kernel has no PPP support!

Post by Tim Dea » Tue, 09 Feb 1999 04:00:00


yes, i've read the HOWTO, the MINI-HOWTO, and the FAQ, now can someone give me
some adviec for when the doco'd say I should have ppp, the kernel says its
there, but then gives me the same error msg?!?! please, no more 'read the FAQ'
responses!!!

-Tim


> There's a little discussion of this in section 18.1 of the PPP HOWTO.


> >Hello,
> >   I have recompiled my 2.0.35 (Slackware 3.6) kernel with PPP support
> >(directly in to the kernel), but after copying my zImage file to /vmlinuz,
> >and re-running lilo, and rebooting the machine, pppd says that there is no
> >ppp support in my kernel.  I know I'm booting with my new kernel - Any
> >ideas out there?

> >Thanks a alot for your help, in advance -- Ivan.
> >5

 
 
 

After recompiling kernel with PPP support, pppd says the kernel has no PPP support!

Post by dmorgan1REMOVET.. » Wed, 10 Feb 1999 04:00:00


Tim-- ask Ivan

>yes, i've read the HOWTO, the MINI-HOWTO, and the FAQ, now can someone give me
>some adviec for when the doco'd say I should have ppp, the kernel says its
>there, but then gives me the same error msg?!?! please, no more 'read the FAQ'
>responses!!!

>-Tim


>> There's a little discussion of this in section 18.1 of the PPP HOWTO.


>> >Hello,
>> >   I have recompiled my 2.0.35 (Slackware 3.6) kernel with PPP support
>> >(directly in to the kernel), but after copying my zImage file to /vmlinuz,
>> >and re-running lilo, and rebooting the machine, pppd says that there is no
>> >ppp support in my kernel.  I know I'm booting with my new kernel - Any
>> >ideas out there?

>> >Thanks a alot for your help, in advance -- Ivan.
>> >5