help: "emacs:can't load library 'libXt.so.6'" . . .

help: "emacs:can't load library 'libXt.so.6'" . . .

Post by Young-jong Y » Sun, 30 Mar 1997 04:00:00



Today, I installed Redhat 4.0 on my machine. Since my machine has
S3 Virge Video card, I had to download XFree3.2 and install it instead of
XFree 3.1.2 that is included with Redhat 4.0. After I install XFree 3.2
and configure it,  many programs that starts with "x" don't seem to run
anymore along with some others (emacs, xtetris, etc). When I type "emacs",
linux says, "emacs: 'usr/X11R6/lib/libXt.so.6' is not an ELF file"
"emacs: can't load library 'libXt.so.6'"  And, when I type "xtetris" and
some others, linux says, "xtetris: can't load library 'libXt.so.6'"
Does anyone have any idea what seems to be wrong and how to correct it?

Please let me know via e-mail.

Thank you in advance.

young

 
 
 

help: "emacs:can't load library 'libXt.so.6'" . . .

Post by Huang » Sat, 05 Apr 1997 04:00:00



: Today, I installed Redhat 4.0 on my machine. Since my machine has
: S3 Virge Video card, I had to download XFree3.2 and install it instead of
: XFree 3.1.2 that is included with Redhat 4.0. After I install XFree 3.2
: and configure it,  many programs that starts with "x" don't seem to run
: anymore along with some others (emacs, xtetris, etc). When I type "emacs",
: linux says, "emacs: 'usr/X11R6/lib/libXt.so.6' is not an ELF file"
                       ^^^^^^^^^^^^^^^^^^^^^^^^
I got the same problem,any one can help???

: "emacs: can't load library 'libXt.so.6'"  And, when I type "xtetris" and
: some others, linux says, "xtetris: can't load library 'libXt.so.6'"
: Does anyone have any idea what seems to be wrong and how to correct it?
: Please let me know via e-mail.
: Thank you in advance.
: young


 
 
 

help: "emacs:can't load library 'libXt.so.6'" . . .

Post by Mr.La » Sun, 06 Apr 1997 04:00:00



> =

> : Today, I installed Redhat 4.0 on my machine. Since my machine has
> : S3 Virge Video card, I had to download XFree3.2 and install it instea=
d of
> : XFree 3.1.2 that is included with Redhat 4.0. After I install XFree 3=
=2E2
> : and configure it,  many programs that starts with "x" don't seem to r=
un
> : anymore along with some others (emacs, xtetris, etc). When I type "em=
acs",
> : linux says, "emacs: 'usr/X11R6/lib/libXt.so.6' is not an ELF file"
>                        ^^^^^^^^^^^^^^^^^^^^^^^^
> I got the same problem,any one can help???
> =
> : "emacs: can't load library 'libXt.so.6'"  And, when I type "xtetris" =
and
> : some others, linux says, "xtetris: can't load library 'libXt.so.6'"
> : Does anyone have any idea what seems to be wrong and how to correct i=
t?
> : Please let me know via e-mail.
> : Thank you in advance.
> : young


The problem is that you've got the wrong destribution of XFree 3.2. You
have to get the ELF version which support shared library.
 
 
 

1. Help: "tcsh: can't load library 'libc.so.5'" ??

Hi all, Anyone have any ideas about where this comes from?
Whenever I telnet in to my machine or su to another user, I get
this abrupt message and then the shell dies.

I get it after entering username & password. Anyone have a thought
about this? What might be causing it?

/lib/libc.so.5 is a valid link to /lib//libc.so.5.3.12
I ran ldconfig and ldconfig -v.
binutils 2.6.0.14
kernel 2.0.0

Thanks,
Zo
--
ack

2. s390 (1/7): base fix.

3. Can't load library 'libXt.so.6'

4. how to disable laptop's mouse "tap" capability

5. "can't load library 'libXmu.so.6'"

6. Signal 10 on SCSI Disk during boot

7. "Can't load library 'foo'" messages

8. Change fonts ?

9. StarOffice Error: can't load library 'libXt.so.6'

10. xinit : can't load library 'libXt.so.6' error msg.

11. Q: can't load library 'libXt.so.6'

12. "can't load library 'libXpm.so.4'"

13. Help [2nd]: can't find library 'libXt.so.6'