Lilo Help: How do I default Lilo to Dos Partition?

Lilo Help: How do I default Lilo to Dos Partition?

Post by Jeff Fulfor » Wed, 20 Sep 1995 04:00:00



As the subject says.  I would like Lilo to start in Dos if I
am not around to hit "Control" and type "Dos".  
thanx
jeff


 
 
 

Lilo Help: How do I default Lilo to Dos Partition?

Post by Al Longye » Fri, 22 Sep 1995 04:00:00



>As the subject says.  I would like Lilo to start in Dos if I
>am not around to hit "Control" and type "Dos".  

Lilo loads the first system listed in the lilo.config as the default
operating system.

I hope that this is enough information for you to determine how to do
the operation. If not, it is in the documentation.

--

The above opinions do not necessarily represent the management of
System Integrators nor any of its subsideraries.

 
 
 

Lilo Help: How do I default Lilo to Dos Partition?

Post by Christian T » Mon, 25 Sep 1995 04:00:00



> Lilo loads the first system listed in the lilo.config as the default
> operating system.

> I hope that this is enough information for you to determine how to do
> the operation. If not, it is in the documentation.

A long time ago, when I used the SLS distribution, I had a LILO version
wich remembered which OS it had booted. Zo it would boot DOS everytime
until you pressed shift, and choose Linux. Then it would boot Linux
everytime until you pressed shift dooring booting, and choose DOS etc.

It would be great if this would be possible again, this doesn't work
with my current version of LILO.

--
Christian Tan, Business Management, Erasmus University Rotterdam.
WWW:URL:http://xs4all.nl/~pigeon/

Destroy the Church of Scientology.

 
 
 

1. Help: Cannot access DOS partition after installing 2.0 & new LILO

Hi,

Yesterday I installed kernel 2.0 and LILO 19. The installation is successful,
and I can boot my new kernel. However, it destroyed the superblock of one of
my DOS/Win95 partition. Here is my configuration:

        /dev/hda1:      C:, Windows 95 Driver Space 3 Compressed
                        Before compression, ~800M.
        /dev/hda2:      D:, no compression, ~250M.
        /dev/hdb1:      Swap for Linux, ~20M
        /dev/hdb2:      Linux native (everything for Linux), ~400M.

I can mount /dev/hda2 and access the files there, but mounting /dev/hda1
gives the error message like "incorrect fs type or bad superblock". Since
/dev/hda1 is also the bootable for DOS, LILO is unable to boot to DOS also.

When I try dosfsck on /dev/hda1, it says it only supports 2 FATs, but /dev/hda1
has 194 FATs.

When I try fdisk on /dev/hda, partition 1 is still there with correct blcok
size and id, also, with a * to indicate it is bootable.

I don't want to lose my data on /dev/hda1, could anybody give any hints on
how to fix this problem?

Thanks.

Jinan Lou

2. How to open a socket under FreeBSD?

3. Help: DOS Partition Won't Boot from LILO

4. Reading is much more interesting than TV (0325/1708)

5. RH9 - Lilo scrambled DOS partition tables (fat32) - help

6. What happened to "top" in S8????

7. LILO+not LBA, Ext. DOS partitions? help!

8. CDE errors using Reflection on PC

9. lilo problem, dos partition won't boot, HELP!

10. How to Uninstall LILO -o How to boot DOS once LILO is installed?

11. LILO error: Can only boot from floppy, LILO will only start dos not linux

12. LILO: Linux + DOS-W311 + DOS/W95-Upgrade

13. Q: Lilo booting DOS as default