LILO Help Please, giving correct drive geometry?

LILO Help Please, giving correct drive geometry?

Post by J. S. Jense » Wed, 11 Nov 1998 04:00:00



My IDE hd geometry is 917/12/48.  The kernel reports that as well,
however on partition checking, the geometry is given as 917/12/63 is the
line:

hda:
    EZD (remap 0->1) [917/12/63] hda1 hda2

at boot time.  (what does this mean?)

Now I set my partitions (in fdisk) to operate with 48 sectors instead of
63, and I have appended the line:

append="hd=917,12,48

to /etc/lilo.conf, ran lilo, but lilo still gives me just the `LI' and
then nothing more.  By documentation, this means that the secondary boot
loader is not being loaded, but no read error is returned (as would it
with hex codes being sent after the LI).

The partitions are fine, and check out fine, so how to I get LILO to
boot from the MBR into this strange partition arrangement.

--
J. S. Jensen

http://www.paramin.com

 
 
 

1. help needed: problems with LILO, kernel panic, drive geometries

Greetings:

  I recently acquired a P166 PCI motherboard with on-board IDE
controller. I've been using a 486/120 VLB board with two drives, one for
Win95 (a Seagate 1.5G) and one for Linux (a Maxtor 5.2G). I had hoped
that simply switching the drives into the new box would be okay, but I've
got problems.

  The machine no longer recognized my LILO, so after much tribulation I
removed it via 'fdisk /mbr' and am now able to boot into Win95 directly.
Of course, that's not what I want to do. However, my attempts to rebuild
LILO have consistently failed. I can use my ancient boot/root disks to
get Linux 1.2.8 up and running, but for some reason LILO won't install.
I can run liloconfig all right, but no joy at boot-up, it goes right into
Win95. So there's the first problem.

  I have a boot floppy for my kernel version (2.0.29) but when I try
using it I receive the 'Unable to mount root fs at 03:41' error. This is
distressing, to say the least, and I don't know how to solve the problem.
Am I right in guessing that there's a conflict with the drive geometries
as reported by the BIOS (an Award PnP) ?

  Now, I've done some homework on Deja News but I'm not finding the
answers. Basically, I don't care at all about the Win95 drive, it can go
and I won't miss it. But how then will I be able to boot from the Maxtor
directly into Linux if I can't install LILO ? I would be happy to boot
from the floppy, but that doesn't work.

  And there's more. For some reason my CD-ROM drive (a Philips CM206)
isn't seen by Win95. I've upgraded my video from a Cirrus 5428 VLB card
to an S3 PCI card (a Diamond Stealth) but I can't retrieve the necessary
components from the Win95 CD. So I can boot into Win95 but it's running
in less-than-glorious 16 colors. I don't care for Win95, but now it even
looks bad.

  I really miss my Linux. I hope I can avoid a total re-install,
especially since my system is a real mongrel, so if anyone can help out
it would be vastly appreciated. Thanks !

Anxiously,


 http://www.bright.net/~dlphilp/index.html
 http://www.bright.net/~dlphilp/linux_soundapps.html

2. Different Caps Lock problem!

3. LILO won't give me back my origional MBR, please help!!!

4. set prompt

5. How to specify drive geometry w/ LILO

6. KDE says localhost not found

7. Non-standard Drive geometry and LILO

8. IPNAT/IPF + SERVER = HEADACHE

9. Hard drive geometry, boot-time parameters for LILO

10. lilo.conf - How do you set drive geometry?

11. HELP (PLEASE) LILO needed fix-table to install on IDE drive

12. HELP please! Lilo setup on SCSI drive...

13. win95 killed lilo on scsi drive. Please help!