can't compile gtk 1.1.2 with new glib 1.1.4!

can't compile gtk 1.1.2 with new glib 1.1.4!

Post by David Cougl » Fri, 30 Oct 1998 04:00:00



I just got and installed glib 1.1.4 after uninstalling 1.1.3, and am
trying to recompile gtk 1.1.2 now, but it wont compile anymore!
rh5.1
pgcc 1.1

 -L/usr/X11R6/lib -lXext -lX11 -L/usr/local/lib -rdynamic -lgmodule -lglib
-ldl -lm
.libs/libgtk.so: undefined reference to `g_datalist_set_destroy'
.libs/libgtk.so: undefined reference to `g_datalist_id_set_destroy'
make[2]: *** [testgtk] Error 1

???

--
http://www.geocities.com/vienna/1628
ICQ #3795561
lunarbard on AOL(Instant Messenger)
Proverbs 15:3
"We will not be the alternative, we will set the trend"

 
 
 

1. New glib won't compile

When I try to upgrade to glib-1.2.1 I run into a problem. I type ./configure in
the right directory and it goes it's merry little way until it gets to this:

<snip>
checking for dlopen... no
checking for dlopen in -ldl... yes
checking for dlsym in -ldl... yes
checking for preceeding underscore in symbols... no
checking for dlerror... yes
checking for pthread.h... yes
checking for thread implementation... posix
checking for pthread_attr_init in -lpthread... yes
checking necessary linker options... -lpthread
checking necessary compiler options...  -D_REENTRANT
checking for localtime_r... yes
checking for rand_r... yes
checking for getpwuid_r... yes
checking whether getpwuid_r is posix like... yes
checking whether pthread_getspecific is posix like... yes
checking whether pthread_mutex_trylock is posix like... yes
checking whether pthread_cond_timedwait is posix like...      

And it hangs there for hours until I control-c it. Whats wrong?

thanks
Mike Dombrowski

2. How can I check FSP???

3. rpm -i doesnt recognize new gtk and glib version

4. Diald Problems..

5. Compiling Mozilla with glib-2.x and gtk+-2.x ???

6. Arnet Smartport 8 drivers??

7. Compile/Install problem with glib-1.2.10 and gtk+1.2.10

8. What would you do here if there is no wintroll?

9. Compiling mozilla source with gtk+2.0.6 and glib-2.0.6

10. Need help compiling Glib + Gtk

11. Idiot Seeks Help 3: compiling problems (gtk+/glib)

12. Can't install glib and gtk 1.2.1

13. gtk-1.2.0 and glib-1.2.0 won't configure... any suggestions?