Something messing up my serial ports

Something messing up my serial ports

Post by Jon Ear » Sun, 30 Jul 1995 04:00:00



I have a really irritating problem that just popped up out of the blue.  I
have been running my Lionux system now for close to a year, and have survived
various little glitches that have come out of the woodwork.

This one stumps me.

Until now, my modem, slip, ppd, etc have been working perfectly.  Today, I
tried to establish a slip connection to my provider, and nothing but errors
occured.  Same with ppp.  Looking in the syslog, I found this:

Jul 29 13:11:41 freebeer pppd[110]: tcgetattr: I/O error
Jul 29 13:11:53 freebeer dip[111]: DIP: tty: get_state: I/O error

I cannot make any kind of connection out of here via the modem... I have tried
minicom, slip, pp and nothing works.   Now, it gets interesting.  When i exit
linux, and start up Trumpet Winsock, I find that the modem is completely
unresponsive.  I have to reset the machine, or power it off to restore proper
serial port operation under dos/win.  

Aside from adding a second hard drive (modifying fstab accordingly) and
exchanging a Logitech busmouse for a MS serial mouse, I haven't changed a
thing in my Linux setup.

The serial ports are located on a Promise 2300 Plus EIDE card, and are both
16550's (even now, Linux still reports them correctly).

Any advice would be appreciated.

Jon

 
 
 

1. Something messing up my serial ports

I have a really irritating problem that just popped up out of the blue.  I
have been running my Lionux system now for close to a year, and have survived
various little glitches that have come out of the woodwork.

This one stumps me.

Until now, my modem, slip, ppd, etc have been working perfectly.  Today, I
tried to establish a slip connection to my provider, and nothing but errors
occured.  Same with ppp.  Looking in the syslog, I found this:

Jul 29 13:11:41 freebeer pppd[110]: tcgetattr: I/O error
Jul 29 13:11:53 freebeer dip[111]: DIP: tty: get_state: I/O error

I cannot make any kind of connection out of here via the modem... I have tried
minicom, slip, pp and nothing works.   Now, it gets interesting.  When i exit
linux, and start up Trumpet Winsock, I find that the modem is completely
unresponsive.  I have to reset the machine, or power it off to restore proper
serial port operation under dos/win.  

Aside from adding a second hard drive (modifying fstab accordingly) and
exchanging a Logitech busmouse for a MS serial mouse, I haven't changed a
thing in my Linux setup.

The serial ports are located on a Promise 2300 Plus EIDE card, and are both
16550's (even now, Linux still reports them correctly).

Any advice would be appreciated.

Jon

2. Comment character in tcsh

3. Changed serial ports messed up /dev/modem...

4. kerberos authentification

5. More Serial Ports/Terminal and UPS

6. Printer created with foomatic-configure prints more than I need

7. Configuring serial port for PowerChute UPS

8. Wierd problem trying to install from "mini" ISO-image

9. Serial port -> TrippLite UPS

10. UPS does not want to connect to serial port...

11. monitoring a UPS from a serial port

12. FYI: APC UPS with Sun Blade 100 on 2nd serial port ttyb

13. HELP needed with connecting UPS to serial port w/o "getty"