Java applets don't show up in Netscape.

Java applets don't show up in Netscape.

Post by Azunna Anyanw » Tue, 07 Jan 1997 04:00:00



I have a problem with Netscape.  I have Netscape 3.01 and followed the
instructions at www.blackdown.org/java-linux and got gnumalloc and set
up a script like they said.  In addition, my java_301 file is in
usr/local/java (can't remember; I used the first location that was
specified in the readme).  When I view a page with java applets (like
www.javasoft.com), I don't get a segfault or bus error, I just don't see
anything.  Where the applet is supposed to be is blank.  I read every
linux newsgroup there is and have even searched them but all that keeps
on turning up is how java crashes Netscape.  And before it's suggested,
yes, I've enabled java and javascript in Netscape.
        I'll be indebted to your for any help provided.  FWIW, I've got
Slackware 3.1 kernel 2.0.25.  I've got 32MB RAM and a 32MB swap
partition, so I know I've got free memory (nothing else running in
FVWM-95-2).  I've also got the jdk-1.0.2 but I don't think that's
involved in this at all.  If there are any files that you need to see,
ask and I'll get it ASAP.  Thanks.  

--
Azunna Anyanwu '00
Computer Science Concentrator / Pre-med

"To err is human but to really foul things up requires a computer."

 
 
 

Java applets don't show up in Netscape.

Post by Robert Lync » Tue, 07 Jan 1997 04:00:00


[Newsgroups list trimmed]

After you view a "blank applet" are there any messages in the Netscape
"Java Console"?  (Found by pulling down Options/Show Java Console.)

posted/mailed
--

http://www.veryComputer.com/~rm*/
--


> I have a problem with Netscape.  I have Netscape 3.01 and followed the
> instructions at www.blackdown.org/java-linux and got gnumalloc and set
> up a script like they said.  In addition, my java_301 file is in
> usr/local/java (can't remember; I used the first location that was
> specified in the readme).  When I view a page with java applets (like
> www.javasoft.com), I don't get a segfault or bus error, I just don't see
> anything.  Where the applet is supposed to be is blank.  I read every
> linux newsgroup there is and have even searched them but all that keeps
> on turning up is how java crashes Netscape.  And before it's suggested,
> yes, I've enabled java and javascript in Netscape.
>         I'll be indebted to your for any help provided.  FWIW, I've got
> Slackware 3.1 kernel 2.0.25.  I've got 32MB RAM and a 32MB swap
> partition, so I know I've got free memory (nothing else running in
> FVWM-95-2).  I've also got the jdk-1.0.2 but I don't think that's
> involved in this at all.  If there are any files that you need to see,
> ask and I'll get it ASAP.  Thanks.

> --
> Azunna Anyanwu '00
> Computer Science Concentrator / Pre-med

> "To err is human but to really foul things up requires a computer."


 
 
 

Java applets don't show up in Netscape.

Post by Spar » Thu, 09 Jan 1997 04:00:00


Hi,
this problem is a little tricky. I have Netscape3.0 installed in my
/usr/local/bin directory with java_30 installed in /usr/local/lib/netscape
(I guess) dir. Due to JITC Kaffe and JDBC appl.  developing, I had to set
the CLASSPATH directory to develop Java applications. However, Netscape
doesn't like it. When no CLASSPATH is set, applets show up, but
with CLASSPATH set to JDK and JDBC files, Netscape doesn't show any tiny
message and 'ignores' the applets. Try this: in xterm type 'unset
CLASSPATH' and run netscape or set the CLASSPATH to where the netscape's
classes (java_301) are. This helps in my case.

                                        Spark


> I have a problem with Netscape.  I have Netscape 3.01 and followed the
> instructions at www.blackdown.org/java-linux and got gnumalloc and set
> up a script like they said.  In addition, my java_301 file is in
> usr/local/java (can't remember; I used the first location that was
> specified in the readme).  When I view a page with java applets (like
> www.javasoft.com), I don't get a segfault or bus error, I just don't see
> anything.  Where the applet is supposed to be is blank.  I read every

 
 
 

1. Arrow Keys don't work in Java Applet on Netscape on SunOS

I'm running a Java applet inside of a Netscape browser under SunOS 4.1.3
type 5 keyboard and I'm having a problem getting arrow keys, and
function keys recognized.  BTW this works fine under Windows/Mac.  When
you press an arrow key or function key there is NO event
generated/intercepted in Java.  I suspect it's either a Java bug or a
problem with key mappings.  I'm pointing to the correct XKeysymDB but
that makes no difference (aside from eliminating the annoying startup
error messages).  

Any ideas?

Cliff

--
Remove .nospam at the end of e-mail address to reply. Sorry for the
inconvenience but the junk mail ratio is getting too high.

2. Merge 3.2.2 (UnixWare 2.1) win32s??

3. Java applets don't work in Netscape on RH 6.0

4. The Gimp

5. Netscape Wrapper .. java applets don't run

6. mktime has a bug in solaris

7. RedHat 6 and Netscape fix for Java for things like yahoo Java chat applet

8. modem: how to measure bandwidth

9. Shape Ups,Men's Shape Ups,Men's Skechers Shape Ups - new styles!

10. Netscape don't show up on KDE???

11. Q: Netscape + Java + Solaris2.5 don't work

12. Netscape helpers and plug-ins, also java help

13. RH7.1 and Netscape 4.78 don't do java