tcl/tk botched upgrade even while using RPM

tcl/tk botched upgrade even while using RPM

Post by David Ishe » Fri, 26 Jul 1996 04:00:00



I saw some time ago about a new version of tcl/tk on the Red Hat
announce mailing list so I decided to upgrade. I don't use tcl/tk
other than to run programs every once in awhile that need it. Now no
tcl/tk programs work.

I got the RPM's from the Red Hat ftp site, ran rpm -Uvh on them and
they seemed to install just fine. If I try to run tclhelp I get this:

wishx: can't load library 'libtk4.0.so.1'

I try to run glint and get this:

Traceback (innermost last):
  File "./glint.py", line 22, in ?
    from Tkinter import *
  File "/usr/lib/python/tkinter/Tkinter.py", line 3, in ?
    import tkinter
ImportError: File not found    

OK. I've still got my Red Hat 3.0.3 cd so I can re-install the
original version. I run rpm -e tk-4.1-0.i386.rpm and get:

package tk-4.1-0.i386.rpm is not installed  

Huh? If I run rpm -Uvh tk-4.1-0.i386.rpm I get:

tk                          package tk-4.1-0 is already installed
error: tk-4.1-0.i386.rpm cannot be installed    

but you just said it wasn't installed! Lets try
rpm -ivh tk-4.1-0.i386.rpm

tk                          package tk-4.1-0 is already installed
error: tk-4.1-0.i386.rpm cannot be installed        

Whatever.

I try to run rpm -e tcl-7.5-0.i386.rpm and get:

package tcl-7.5-0.i386.rpm is not installed  

How about we try rpm -Uvh tcl-7.5-0.i386.rpm ....

tk                          package tk-4.1-0 is already installed
error: tcl-7.5-0.i386.rpm cannot be installed

or how about: rpm -ivh tcl-7.5-0.i386.rpm

tk                          package tk-4.1-0 is already installed
error: tcl-7.5-0.i386.rpm cannot be installed

If I go to my Red Hat cdrom and run: rpm -ivh tcl-7.4-5.i386.rpm

tcl                         /usr/lib/libtcl.so conflicts with file from tcl-7.5-
0
error: tcl-7.4-5.i386.rpm cannot be installed  

I have no idea what to do now. Any ideas? Here are the basics:

Red Hat 3.0.3 , upgraded to kernel 2.0.0 with RPM's from Red Hat
486DX4-100, 16 megs RAM
RPM version 2.0.7    

This may also be useful: ls /usr/lib/libtk*



I would appreciate any pointers on what to do next.....

--

David

+--------------------------------------------------------------------+

| Mechanical Engineering Senior                                      |
| Mississippi State University             OS/2 and Linux user       |
|                                                                    |
|        "I'd explain it, but there's a lot of math." -- Calvin.     |
|                                                                    |
+------------- http://www2.msstate.edu/~dmi1/index.html -------------+

 
 
 

1. RPM/Tcl-Tk Question: Right Upgrade Procedure?

I think I may be screwing up somehow as I attempt to upgrade the
Tk-Tcl packages in RH 4.2 to the latest versions (8.1-1, I think).

Using Glint, should I be doing an INSTALL, or an UPGRADE?  Or does it
matter?  I used INSTALL and ended up with what appears to be both the
new and the old packages installed. This manifests itself when I
attempt to start FileRunner, which fails to run and reports problems
executing the initialization script.

Anyone else run into this? Suggestions?

TIA,
TL
"There's a lot to learn
 from wasting time."   -Mr. Neil Young

2. help !!!

3. how can I upgrade tk/tcl with rpm

4. suse 6.1 newbie question

5. how can i upgrade tk/tcl with rpm

6. Lpd hangs at startup when remote printer is offline and there are jobs for the printer

7. Redhat RPM wont upgrade/install tcl/tk/tclx

8. Trouble with utmp enteries

9. RPM of tk/tcl 8.

10. TCL/TK and RPM

11. TCL/TK v8.0 rpms wanted

12. Trouble with RPM, tk and tcl.

13. tcl/tk 8.2 rpms?