Problem with XFree86-4.0.2?

Problem with XFree86-4.0.2?

Post by OrangeDin » Sat, 07 Apr 2001 14:53:32



I have upgraded my XFree86 from 3.3.6 to 4.0.2 with rpms for RedHat 6.x.
My display card is Sis6326. After the installation, I cannot configure
XFree86 with Xconfigurator, XFree86 -configure, xf86config. They all
cannot select the "sis" driver for my card and give the workable setting
for my card. I should edit the XF86Config file manually to make my card
work. As it work with my card, it cannot work with the X-fonts server,
the rpms included. Whenever I startx, it has problem with the FontPath
"unix/:-1" and remove it from the list. If I include the TTF font path
in the xfs to the XF86Config file, everything look fine until display
something with Chinese Big5 character and it would crash immediately.
Without the TTF font path included, all Big5 character can display in
KDE2.1, Gnome1.2, but not Netscape, correctly with no crash. One thing
wrong with startx is if I startx from one virtual terminal, the display
would be a mess, no fonts diplay and wrong graphic. I should return to
the virtual terminal screen with Ctrl+Alt+F1 first and then return to
display with Ctrl+Alt+F7 to have the correct display. As the XFree86
start, it claims that cannot load the kernel module of "SiS" support but
I have compiled my 2.4.2 kernel to include "SiS" support already.
Any one have idea to edit the XF86Config file to make XFree86 to work
better with display card for my linux box?
Thanks for your kindly concern!
 
 
 

1. Problem with XFree86-4.0.2?

I have upgraded my XFree86 from 3.3.6 to 4.0.2 with rpms for RedHat 6.x.
My display card is Sis6326. After the installation, I cannot configure
XFree86 with Xconfigurator, XFree86 -configure, xf86config. They all
cannot select the "sis" driver for my card and give the workable setting
for my card. I should edit the XF86Config file manually to make my card
work. As it work with my card, it cannot work with the X-fonts server,
the rpms included. Whenever I startx, it has problem with the FontPath
"unix/:-1" and remove it from the list. If I include the TTF font path
in the xfs to the XF86Config file, everything look fine until display
something with Chinese Big5 character and it would crash immediately.
Without the TTF font path included, all Big5 character can display in
KDE2.1, Gnome1.2, but not Netscape, correctly with no crash. One thing
wrong with startx is if I startx from one virtual terminal, the display
would be a mess, no fonts diplay and wrong graphic. I should return to
the virtual terminal screen with Ctrl+Alt+F1 first and then return to
display with Ctrl+Alt+F7 to have the correct display. As the XFree86
start, it claims that cannot load the kernel module of "SiS" support but
I have compiled my 2.4.2 kernel to include "SiS" support already.
Any one have idea to edit the XF86Config file to make XFree86 to work
better with display card for my linux box?
Thanks for your kindly concern!

2. Help? Kensington trackball 3 button mouse emulation

3. Debian kdm Xfree86-4.0.2 problem

4. null STREAMS driver

5. XFree86-4.0.2 changes permissions to /dev/null

6. Tip for setting up X-windows with Trident 975 3DImage AGP

7. Xwrapper error from Xfree86-4.0.2 at SuSE-7.0/update

8. tar backups

9. ATI Radeon, XFree86-4.0.2, and hardware acceleration

10. XFree86-4.0.2 colordepths

11. SiS6326 and XFree86-4.0.2?

12. DRI Drivers with XFree86-4.0.2