Problem with module versioning

Problem with module versioning

Post by Joe Hanc » Fri, 03 Jul 1998 04:00:00



I'm attempting to upgrade from 2.0.27 to 2.0.34.  I've compiled everything
including the modules and I have a /lib/modules/2.0.34 directory with the
files in it.  When I boot, however, I get:

Jul  1 20:08:40 www insmod: skb_copy_datagram_iovec: wrong version or
undefined
Jul  1 20:08:40 www insmod: sock_register: wrong version or undefined
Jul  1 20:08:40 www insmod: dev_get: wrong version or undefined
Jul  1 20:08:40 www insmod: sock_setsockopt: wrong version or undefined
Jul  1 20:08:40 www insmod: dev_remove_pack: wrong version or undefined
Jul  1 20:08:40 www insmod: skb_recv_datagram: wrong version or undefined
Jul  1 20:08:40 www insmod: dev_add_pack: wrong version or undefined
Jul  1 20:08:40 www insmod: make_EII_client: wrong version or undefined
Jul  1 20:08:40 www insmod: datagram_select: wrong version or undefined
Jul  1 20:08:40 www insmod: Loading failed! The module symbols (from
linux-2.0.34) don't match your linux-2.0.34
Jul  1 20:08:49 www syslogd: exiting on signal 15
Jul  1 20:09:31 www kernel: Cannot find map file.

Many (but not all) of the modules report errors like this.  I I try to load
them manually with modprobe, I get a similar message.

Where am I going wrong?

Thanks,

JH