RedHat 4.2 and ld.so-1.9.5-2.rpm or greater

RedHat 4.2 and ld.so-1.9.5-2.rpm or greater

Post by Mike McLe » Thu, 18 Dec 1997 04:00:00



I am having trouble getting ld.so-1.9.5-2 or higher to install via rpm
on redhat 4.2.  I need it so I can install libc-5.4.38.  The problem
is that it says I need filesystem.  I have filesystem 1.3 installed.

Please help me

Mike.
Lightning Bolt Software:
-----------------------------------------------
A new bolt of shareware E*MENT!!!!

Check us out at:
 -----------------------------------------
| www.geocities.com/SiliconValley/Lab/3944 |
 -----------------------------------------

 
 
 

RedHat 4.2 and ld.so-1.9.5-2.rpm or greater

Post by Riley William » Sat, 20 Dec 1997 04:00:00


Hi Mike.

 > I am having trouble getting ld.so-1.9.5-2 or higher to install via
 > rpm on redhat 4.2. I need it so I can install libc-5.4.38. The
 > problem is that it says I need filesystem. I have filesystem 1.3
 > installed.

In my case, I had lots of problems upgrading RPM's with RedHat 4.2,
usually with the complaint "..... needs /bin/sh" which I was never able
to resolve. On my system, /bin/sh was a SymLink to /bin/bash and was
most certainly present.

However, since I upgraded to RedHat 5.0, at least THAT problem has
vanished. Other problems have replaced it, but they're solvable and I'm
working my way through them...

Best wishes from Riley.

 
 
 

RedHat 4.2 and ld.so-1.9.5-2.rpm or greater

Post by Phil DeBecke » Sat, 20 Dec 1997 04:00:00



> I am having trouble getting ld.so-1.9.5-2 or higher to install via rpm
> on redhat 4.2.  I need it so I can install libc-5.4.38.  The problem
> is that it says I need filesystem.  I have filesystem 1.3 installed.

> Please help me

The ld.so-1.9.5-2 RPM is a binary RPM compiled with glibc on RH 4.9.x
or 5.0.  It cannot be installed on a 4.2 system as all of the required
packages are older in 4.2 than on 4.9.x or 5.0.

The simplest thing to do is to get the ld.so-1.9.5-x.src.rpm from
the contrib/SRPMS directory and install it.  You then can use rpm -ba
on its specfile to produce an RPM of ld.so-1.9.5 which is tailored to
your system.

Hope this helps,
Phil

--
All opinions expressed in this post are mine alone and do not represent
those of my employer or of the Lexmark corporation.

 
 
 

RedHat 4.2 and ld.so-1.9.5-2.rpm or greater

Post by Henrik Storn » Sun, 21 Dec 1997 04:00:00



Quote:>I am having trouble getting ld.so-1.9.5-2 or higher to install via rpm
>on redhat 4.2.  I need it so I can install libc-5.4.38.  The problem
>is that it says I need filesystem.  I have filesystem 1.3 installed.

RPM files for RH 4.2 with libc-5.4.38, ld.so-1.9.6 and some other
stuff can be found at ftp://sslug.imm.dtu.dk/pub/rpm/i386/

NOTE: Upgrading ld.so and libc should be done in single-user mode.
I'd recommend that you

a) Reboot the system
b) At the LILO command prompt, enter the name you use for booting
   linux followed by "single" (no quotes).
c) At the root prompt, enter
      rpm -U ld.so-1.9.6-0.i386.rpm
      /sbin/ldconfig
d) Reboot, or "exec telinit 3" to get into multi-user mode.

--
Henrik Storner                               http://www.image.dk/~storner/
"The POP3 server service depends on the SMTP server service, which
 failed to start because of the following error:
 The operation completed successfully." -Windows NT Server v3.51

 
 
 

RedHat 4.2 and ld.so-1.9.5-2.rpm or greater

Post by Left Hand of Xe » Fri, 26 Dec 1997 04:00:00


On Fri, 19 Dec 1997 11:42:42 -0500, Phil DeBecker Pronounced:


>> I am having trouble getting ld.so-1.9.5-2 or higher to install via rpm
>> on redhat 4.2.  I need it so I can install libc-5.4.38.  The problem
>> is that it says I need filesystem.  I have filesystem 1.3 installed.
>The ld.so-1.9.5-2 RPM is a binary RPM compiled with glibc on RH 4.9.x
>or 5.0.  It cannot be installed on a 4.2 system as all of the required
>packages are older in 4.2 than on 4.9.x or 5.0.

I have RedHat 4.2, ld.so-1.9.5-2, libc-5.4.36 and a recent binutils
running together right now. ldd shows /lib/ld.so.1.9.5 to be
statically linked. I had to use rpm --nodeps to get around the errors
concerning "sh" and "filesystem" but all was well after that.

--
I am:               *   I Think Not,       * I love humanity,

                    *                      * can't tolerate
finger --> PGP key  *                      *

 
 
 

1. RedHat 4.2 and ld.so-1.9.5-5.i386.rpm

I just downloaded the Java jdk1.1.4 for Linux.  The instructions
say that I need ld.so-1.9.5.  I'm running RedHat 4.2.  I found
ld.so-1.9.5 in the RedHat 5.0 distribution at Sunsite.  Can I
install it on my RedHat 4.2 system or will I get a conflict?

Thanks for help.

BTW, the jdk is at:

    ftp://lagrange.la.asu.edu/pub/Linux_jdk/JDK-1.1.4

-- Dave

--
Remove NOSPAM before replying by email.

2. Commercial: Linux Products From Universal CD-ROM(9/97)

3. install ld.so-1.9.7 over ld.so-1.8.12 on a glibc system?

4. prob compiling amd (automount), 2.0.22

5. ld.so-1.9.5 upgrade ld.so segfault

6. callbcak modems

7. RedHat 4.2 'rpm' whoo's

8. how to run oracle program on linux with c?

9. RedHat 4.2 RPM problem

10. More on RedHat rpm and 4.2

11. prob w/ bind-4.9.6-1.1 (RedHat 4.2 rpm)

12. RedHat 4.2 install via FTP + updated .rpm files

13. How to install rpms from Redhat 5.0 on 4.2