SiS6236 video card and Caldera 1.3 (weird X win probs)

SiS6236 video card and Caldera 1.3 (weird X win probs)

Post by Troy Topni » Sun, 31 Dec 1899 09:00:00



Hello all,

I've recently installed Caldera Open Linux 1.3.  After some hair-raising
moments with the Master Boot Record.  All is well at the command prompt.

HOWEVER, after carefully configuring the XFree86 SVGA server to what I
thought were the right settings for my video card (SiS 6236) and monitor
(Trinitron 15" whatever), XFree86 launches with HUGE icons, fonts and
objects and only a very small part of the desktop visible.  Otherwise the
settings seem fine (ie. no flicker, no alignment problems etc).

Accdording to the XF86 documentation, the standard SVGA server
SHOULD work (the default VGA server does not) with the SiS chipset.
I've run Xconfig (Xsetup will not work because the VGA server is used at the
start) several times changing the options in "modes" but this hasn't worked
so-far.  I've also tried to navigate around the cumbersome X desktop to use
an XFree86 setup utility there - also to no avail.

Have any of you heard of these types of problems?  Any advice?  I would be
eternally grateful.  I know there's probably something out there in a F.A.Q.
document, but I haven't found it yet - and I have looked.

Cheers,
TT

Troy Topnik

 
 
 

SiS6236 video card and Caldera 1.3 (weird X win probs)

Post by Sterlin » Sun, 31 Dec 1899 09:00:00


I'v created a couple of Web pages to help
get the XFree86 and SiS 6326 working together.

http://rampages.onramp.net/~slywolf

Hope this saves some hair pulling.

Have Fun :-)
Sterling


> Hello all,

> I've recently installed Caldera Open Linux 1.3.  After some hair-raising
> moments with the Master Boot Record.  All is well at the command prompt.

> HOWEVER, after carefully configuring the XFree86 SVGA server to what I
> thought were the right settings for my video card (SiS 6236) and monitor
> (Trinitron 15" whatever), XFree86 launches with HUGE icons, fonts and
> objects and only a very small part of the desktop visible.  Otherwise the
> settings seem fine (ie. no flicker, no alignment problems etc).

> Accdording to the XF86 documentation, the standard SVGA server
> SHOULD work (the default VGA server does not) with the SiS chipset.
> I've run Xconfig (Xsetup will not work because the VGA server is used at the
> start) several times changing the options in "modes" but this hasn't worked
> so-far.  I've also tried to navigate around the cumbersome X desktop to use
> an XFree86 setup utility there - also to no avail.

> Have any of you heard of these types of problems?  Any advice?  I would be
> eternally grateful.  I know there's probably something out there in a F.A.Q.
> document, but I haven't found it yet - and I have looked.

> Cheers,
> TT

> Troy Topnik



 
 
 

SiS6236 video card and Caldera 1.3 (weird X win probs)

Post by gnu_u.. » Sun, 31 Dec 1899 09:00:00


Hello, I don't have the info now, I'm not at the right place, but do a
search on the internet for SiS 6326 there are two small sites I've
found, Sterling's SiS 6326 Support page, and jon's ?? site, I found info
at SuSE's site previous to finding the other two, and used that to fix
my video, search at SuSE for SIS 6326, I did NOT use their driver, it is
harder to get set up, but has higher performance from what I've read.  I
could NOT get COL 1.3 to work with my new card at all, COL 1.3 has an
old version of XFree86.
I have posted on alt.os.linux.mandrake (I think) the URL's.
HTH
Rollie



> Hello all,

> I've recently installed Caldera Open Linux 1.3.  After some
hair-raising
> moments with the Master Boot Record.  All is well at the command
prompt.

> HOWEVER, after carefully configuring the XFree86 SVGA server to what I
> thought were the right settings for my video card (SiS 6236) and
monitor
> (Trinitron 15" whatever), XFree86 launches with HUGE icons, fonts and
> objects and only a very small part of the desktop visible.  Otherwise
the
> settings seem fine (ie. no flicker, no alignment problems etc).

> Accdording to the XF86 documentation, the standard SVGA server
> SHOULD work (the default VGA server does not) with the SiS chipset.
> I've run Xconfig (Xsetup will not work because the VGA server is used
at the
> start) several times changing the options in "modes" but this hasn't
worked
> so-far.  I've also tried to navigate around the cumbersome X desktop
to use
> an XFree86 setup utility there - also to no avail.

> Have any of you heard of these types of problems?  Any advice?  I
would be
> eternally grateful.  I know there's probably something out there in a
F.A.Q.
> document, but I haven't found it yet - and I have looked.

> Cheers,
> TT

> Troy Topnik


Sent via Deja.com http://www.deja.com/
Before you buy.
 
 
 

SiS6236 video card and Caldera 1.3 (weird X win probs)

Post by L. Friedma » Sun, 31 Dec 1899 09:00:00


Just wondering what is so hard about setting up an RPM?  SuSE has the
driver available in both TGZ & RPM formats.

-L


>Hello, I don't have the info now, I'm not at the right place, but do
a
>search on the internet for SiS 6326 there are two small sites I've
>found, Sterling's SiS 6326 Support page, and jon's ?? site, I found
info
>at SuSE's site previous to finding the other two, and used that to
fix
>my video, search at SuSE for SIS 6326, I did NOT use their driver, it
is
>harder to get set up, but has higher performance from what I've read.
I
>could NOT get COL 1.3 to work with my new card at all, COL 1.3 has an
>old version of XFree86.
>I have posted on alt.os.linux.mandrake (I think) the URL's.
>HTH
>Rollie



>> Hello all,

>> I've recently installed Caldera Open Linux 1.3.  After some
>hair-raising
>> moments with the Master Boot Record.  All is well at the command
>prompt.

>> HOWEVER, after carefully configuring the XFree86 SVGA server to
what I
>> thought were the right settings for my video card (SiS 6236) and
>monitor
>> (Trinitron 15" whatever), XFree86 launches with HUGE icons, fonts
and
>> objects and only a very small part of the desktop visible.
Otherwise
>the
>> settings seem fine (ie. no flicker, no alignment problems etc).

>> Accdording to the XF86 documentation, the standard SVGA server
>> SHOULD work (the default VGA server does not) with the SiS chipset.
>> I've run Xconfig (Xsetup will not work because the VGA server is
used
>at the
>> start) several times changing the options in "modes" but this
hasn't
>worked
>> so-far.  I've also tried to navigate around the cumbersome X
desktop
>to use
>> an XFree86 setup utility there - also to no avail.

>> Have any of you heard of these types of problems?  Any advice?  I
>would be
>> eternally grateful.  I know there's probably something out there in
a
>F.A.Q.
>> document, but I haven't found it yet - and I have looked.

>> Cheers,
>> TT

>> Troy Topnik

>Sent via Deja.com http://www.deja.com/
>Before you buy.

 
 
 

SiS6236 video card and Caldera 1.3 (weird X win probs)

Post by L. Friedma » Sun, 31 Dec 1899 09:00:00


        Well, no offense intended but you really need to learn how to do some
command line work in linux if you expect to be able to maintain a linux
box.  If for whatever reason you suddenly can't get back into KDE (or
whatever GUI mandrake has), you're going to need to find your way
arround from the command line in order to fix things.

-L




> > Just wondering what is so hard about setting up an RPM?  SuSE has the
> > driver available in both TGZ & RPM formats.

> > -L

> I had the RPM & the file you sent re: setting it up. If, as I am, you
> are not familiar with the command line, it *is* hard to figure out.
> (BTW *thanks* for that file, & sorry I didn't reply before - lost
> mail with update to Nav 4.7 :o )

> For newbies like me (lazy) ,  the easy way to cope with SiSxxx
> & i740 etc chips is get Mandrake/RH 6.1, which have  X3.3.5.

> I got a cheapbytes type CD for about US$ 7.50 (inc postage)
> & it worked "straight out of the box".

> -Warren

 
 
 

SiS6236 video card and Caldera 1.3 (weird X win probs)

Post by warren done » Sun, 31 Dec 1899 09:00:00



Quote:> Just wondering what is so hard about setting up an RPM?  SuSE has the
> driver available in both TGZ & RPM formats.

> -L

I had the RPM & the file you sent re: setting it up. If, as I am, you
are not familiar with the command line, it *is* hard to figure out.
(BTW *thanks* for that file, & sorry I didn't reply before - lost
mail with update to Nav 4.7 :o )

For newbies like me (lazy) ,  the easy way to cope with SiSxxx
& i740 etc chips is get Mandrake/RH 6.1, which have  X3.3.5.

I got a cheapbytes type CD for about US$ 7.50 (inc postage)
& it worked "straight out of the box".

-Warren

 
 
 

1. Caldera Open Linux 1.3 Fips ; installation probs help please ;-)

Here Generic IDE FAT32 6.4GB  hard drive.

Fips README txt advises run diskscan>Defrag>diskscan then uninstall windows
swap file.

Question. Given Win swap file is WIN386.SWP [Correct me if I am wrong
please} this file cannot be uninstalled or removed only disabled as
follows..control panel>systems>Performance Tab>virtual memory button then
Disable Virtual memory.

Trying to run scandisk with virtual memory disabled results in windows
winging there is not enough memory. Attempting to run defrag with virtual
memory disabled results in the system freezing after several hours.

Attempting to run FIPS to create space (Standard install) for Linux results
in the error message 'unknown file system 0CH only DOS partitions can be
split [system indicator byte must be 4 or 6].

I assume my FAT32 system and LBA logical block addressing is creating
problems ?????

Reluctant to install a second hard disk just for Linux or purchase a
commercial product such as partition magic as there must be some way round
this ???????

Your comments/advice would be much appreciated..
Regards  Shaun County Durham

2. RH 6.2 Printers

3. Caldera 1.3 vs Caldera 2.3

4. Killing KDE sessions under lockups

5. Please Help w/RH 5.0 - Video prob when starting X Server but using supported video card

6. error compiling RELENG_3_0_0_RELEASE

7. Video Card probs. - Gateway STB, AGP 4MB Graphics Card ????

8. problems with Ghostscript-installation - need help

9. Caldera Open Linux 1.3 Install Crash

10. Trouble installing Caldera 1.3 open linux

11. DHCP client (dhcpcd) for Caldera 1.3?

12. Caldera OpenLinux 1.3-Boot from floppy

13. Mouse troubles with Caldera 1.3