Printing Problem-Powerpoint 97 -> Linux Printserver

Printing Problem-Powerpoint 97 -> Linux Printserver

Post by Graeme Woollet » Thu, 23 Jul 1998 04:00:00



A have a Epson Stylus 800 printer attached to a linux machine running
MARS_NWE.  From a NT client machine I can print to this printer using
the print test page utility, MS Word, Excel, MS Photo Editor and other
non MS apps.  When I try to do the same from Powerpoint 97 all I get is
the banner page, the body of the print job is missing!

Any help appreciated.
--
Regards
Graeme Woollett
Electrical/Time Standards
Industrial Research Ltd
Ph 64-04-569-0193
Fax 64-04-569-0194

 
 
 

Printing Problem-Powerpoint 97 -> Linux Printserver

Post by Max Wheatle » Thu, 23 Jul 1998 04:00:00



> the banner page, the body of the print job is missing!

Just a guess ..... what is in your printcap, there is an entry there
that can limit the size of print jobs ......

something like.......mx#0

Here is mine for what it is worth ....

--


[ printcap 1K ]
#
# Copyright (c) 1983 Regents of the University of California.
# All rights reserved.
#
# Redistribution and use in source and binary forms are permitted
# provided that this notice is preserved and that due credit is given
# to the University of California at Berkeley. The name of the University
# may not be used to endorse or promote products derived from this
# software without specific prior written permission. This software
# is provided ``as is'' without express or implied warranty.
#

#
#
#smb|Prints on win95 using bash:\
#      :sd=/usr/spool/smb:\
#      :if=/usr/spool/smb/smbprint:\
#      :mx#0:\
#      :lp=:\
#      :lf=/var/adm/lpd-errs:
#
matrix|Dot Matrix on chuck:\
      :lp:\
      :sd=/usr/spool/lpd:\
      :rm=chuck:\
      :mx#0:\
      :lf=/var/adm/lpd-errs:
#
laser| laser on intel box:\
      :lp:\
      :sd=/usr/spool/intel-p1:\
      :rm=intel-p1:\
      :rp=TEXT:\
      :mx#0:\
      :lf=/var/adm/lpd-errs:
#      
intel-p1|Intel print server Parrallel port 1:\
      :lp:\
      :sd=/usr/spool/intel-p1:\
      :rm=intel-p1:\
      :rp=PASSTHRU:\
      :mx#0:\
      :lf=/var/adm/lpd-errs:

intel-p2|Intel print server Parrallel port 2:\
      :lp:\
      :sd=/usr/spool/intel-p2:\
      :rm=intel-p2:\
      :rp=PASSTHRU:\
      :mx#0:\
      :lf=/var/adm/lpd-errs:

intel-s1|Intel print server Serial port 1:\
      :lp:\
      :sd=/usr/spool/intel-p1:\
      :rm=intel-s1:\
      :rp=PASSTHRU:\
      :mx#0:\
      :lf=/var/adm/lpd-errs:      
#  

 
 
 

1. Q: Print problem: Win95 -> Linux/Samba -> Linux/Netatalk -> LaserWriter

I've collected more info on the problem I described earlier:

I've got a PC with Win95 running on it.

I've got a Linux machine running a pretty stock RedHat 5.1 installation.

The Linux machine is running Netatalk and Samba.  It's got printcap
entries for a bunch of Netatalk printers, as well as a direct-connect
Canon BJ-100 and a raw network HP DeskJet 1600CM.

Our UNIX machines can print to all of the Linux print queues with no
problem.  Looks beeeeautiful.

Our Win95 machines have problems:

Printing to the BJ-100 and the HP DeskJet 1600CM works great.  Test
pages are great, documents look great.

Printing to the Netatalk printers doesn't work great.  The test page
prints, but the printer then spits out a blank page followed by a page
with the following message on it:

-----

ERROR: undefined
OFFENDING COMMAND:

STACK:

-----

Any ideas?  I've tried a variety of drivers on the Win95 machines, but
haven't had any luck getting it to print without the blank pages and
error pages.

Thanks,

Tom

2. Pamela Samuelson panelist at Open Source town meeting 8/21/98 San Jose, CA

3. Printing from Win/pctcp and Linux to a Linux printserver

4. Solaris X Terminals

5. FTP problem: linux>>win/SGI slow win/SGI>>linux fast

6. Multiplatform .profile/.cshrc/.login

7. Solaris 2.5.1 HW >= 11/97 for U5

8. "Magic" MIME types obsolete?

9. Upgrade 2.5.1 -> 2.5.1 HW11/97 by pkgadd?

10. access 97 -> mysql,php3

11. View and print Word 97 docs. on Solaris??

12. average load of > 1 and 97% idle time???

13. Remote printing from MVS / VM to Solaris 2.4 printserver problem