Ati rage pro and 3d accelaration (freeze my system)

Ati rage pro and 3d accelaration (freeze my system)

Post by Cyril Zorma » Thu, 29 Aug 2002 16:48:34



really need help (i going crazy)
It's been 2 day that i'm trying to configure my ati rage pro on my woody
and can't find the answer. every time glxgears make all the system
freeze like all the other open gl application
maybe it's because i'm not using the frame buffer?

using lspci  i have :

01:00.0 VGA compatible controller: ATI Technologies Inc Rage 128 PF/PRO
AGP 4x TMDS (prog-if 00 [VGA])
              Subsystem: ATI Technologies Inc: Unknown device 0404
              Flags: bus master, stepping, 66Mhz, medium devsel, latency 64,
IRQ 11
              Memory at f0000000 (32-bit, prefetchable)
              I/O ports at c800
              Memory at ff8fc000 (32-bit, non-prefetchable)
              Capabilities: [50] AGP version 2.0
              Capabilities: [5c] Power Management version 2

lsmod give me :

Module                  Size  Used by    Not tainted
r128                   88696  12
apm                     9148   2  (autoclean)
agpgart                29824   3
printer                 5632   0  (unused)
isa-pnp                27432   0  (unused)
es1371                 27840   0
gameport                1308   0  [es1371]
ac97_codec              9568   0  [es1371]
soundcore               3236   4  [es1371]
keybdev                 1664   0  (unused)
usbkbd                  2848   0  (unused)
input                   3072   0  [keybdev usbkbd]
usb-uhci               20708   0  (unused)
usbcore                48032   0  [printer usbkbd usb-uhci]

glxinfo give me :

ame of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
          GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
client glx vendor string: SGI
client glx version string: 1.2
client glx extensions:
          GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
GLX extensions:
          GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
OpenGL vendor string: VA Linux Systems, Inc.
OpenGL renderer string: Mesa DRI Rage128 20010405 Pro AGP 4x x86/MMX
OpenGL version string: 1.2 Mesa 3.4.2
OpenGL extensions:
          GL_ARB_multitexture, GL_ARB_transpose_matrix, GL_EXT_abgr,
          GL_EXT_clip_volume_hint, GL_EXT_compiled_vertex_array,
GL_EXT_histogram,
          GL_EXT_packed_pixels, GL_EXT_polygon_offset,
GL_EXT_rescale_normal,
          GL_EXT_stencil_wrap, GL_EXT_texture3D, GL_EXT_texture_env_add,
          GL_EXT_texture_object, GL_EXT_texture_lod_bias,
GL_EXT_vertex_array,
          GL_MESA_window_pos, GL_MESA_resize_buffers,
GL_NV_texgen_reflection,
          GL_PGI_misc_hints, GL_SGIS_pixel_texture,
GL_SGIS_texture_edge_clamp
glu version: 1.3
glu extensions:
          GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

         visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
       id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x23 24 tc  0 24  0 r  y  .  8  8  8  0  0 24  0  0  0  0  0  0 0 None
0x24 24 tc  0 24  0 r  y  .  8  8  8  0  0 24  8  0  0  0  0  0 0 Slow
0x25 24 tc  0 24  0 r  y  .  8  8  8  0  0 24  0 16 16 16  0  0 0 Slow
0x26 24 tc  0 24  0 r  y  .  8  8  8  0  0 24  8 16 16 16  0  0 0 Slow
0x27 24 dc  0 24  0 r  y  .  8  8  8  0  0 24  0  0  0  0  0  0 0 None
0x28 24 dc  0 24  0 r  y  .  8  8  8  0  0 24  8  0  0  0  0  0 0 Slow
0x29 24 dc  0 24  0 r  y  .  8  8  8  0  0 24  0 16 16 16  0  0 0 Slow
0x2a 24 dc  0 24  0 r  y  .  8  8  8  0  0 24  8 16 16 16  0  0 0 Slow

here is my /etc/X11/XF86Config-4

Section "Files"
              FontPath        "unix/:7100"                    # local font
server
              # if the local font server has problems, we can fall back on
these
              FontPath        "/usr/lib/X11/fonts/misc"
              FontPath        "/usr/lib/X11/fonts/cyrillic"
              FontPath        "/usr/lib/X11/fonts/100dpi/:unscaled"
              FontPath        "/usr/lib/X11/fonts/75dpi/:unscaled"
              FontPath        "/usr/lib/X11/fonts/Type1"
              FontPath        "/usr/lib/X11/fonts/Speedo"
              FontPath        "/usr/lib/X11/fonts/100dpi"
              FontPath        "/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
              Load    "GLcore"
              Load    "bitmap"
              Load    "dbe"
              Load    "ddc"
              Load    "dri"
              Load    "extmod"
              Load    "freetype"
              Load    "glx"
              Load    "int10"
              Load    "pex5"
              Load    "record"
              Load    "speedo"
              Load    "type1"
              Load    "vbe"
              Load    "xie"
EndSection

Section "InputDevice"
              Identifier      "Generic Keyboard"
              Driver          "keyboard"
              Option          "CoreKeyboard"
              Option          "XkbRules"      "xfree86"
              Option          "XkbModel"      "pc104"
              Option          "XkbLayout"     "fr"
EndSection

Section "InputDevice"
              Identifier      "Configured Mouse"
              Driver          "mouse"
              Option          "CorePointer"
              Option          "Device"                "/dev/psaux"
              Option          "Protocol"              "ImPS/2"
              Option          "Emulate3Buttons"       "true"
              Option          "ZAxisMapping"          "4 5"
EndSection

Section "InputDevice"
              Identifier      "Generic Mouse"
              Driver          "mouse"
              Option          "SendCoreEvents"        "true"
              Option          "Device"                "/dev/input/mice"
              Option          "Protocol"              "ImPS/2"
              Option          "Emulate3Buttons"       "true"
              Option          "ZAxisMapping"          "4 5"
EndSection

Section "Device"
              Identifier      "ATI Rage 128"
              Driver          "ati"
              Option      "AGPMode" "4"
EndSection

Section "Monitor"
              Identifier      "hp L1720"
              HorizSync       30-80
              VertRefresh     56-75
              Option          "DPMS"
EndSection

Section "Screen"
              Identifier      "Default Screen"
              Device          "ATI Rage 128"
              Monitor         "hp L1720"
              DefaultDepth    24
              SubSection "Display"
                      Depth           1
                      Modes           "1280x1024" "1024x768" "800x600"
"640x480"
              EndSubSection
              SubSection "Display"
                      Depth           4
                      Modes           "1280x1024" "1024x768" "800x600"
"640x480"
              EndSubSection
              SubSection "Display"
                      Depth           8
                      Modes           "1280x1024" "1024x768" "800x600"
"640x480"
              EndSubSection
              SubSection "Display"
                      Depth           15
                      Modes           "1280x1024" "1024x768" "800x600"
"640x480"
              EndSubSection
              SubSection "Display"
                      Depth           16
                      Modes           "1280x1024" "1024x768" "800x600"
"640x480"
              EndSubSection
              SubSection "Display"
                      Depth           24
                      Modes           "1280x1024" "1024x768" "800x600"
"640x480"
              EndSubSection
EndSection

Section "ServerLayout"
              Identifier      "Default Layout"
              Screen          "Default Screen"
              InputDevice     "Generic Keyboard"
              InputDevice     "Configured Mouse"
              InputDevice     "Generic Mouse"
EndSection

Section "DRI"
              Mode    0666
EndSection

thank for your help