cdrom

cdrom

Post by Siva Kumaran Nadaraja » Sun, 31 Dec 1899 09:00:00



I have the following problem with my cdrom:

When I try to mount it with %mount /dev/cdrom
I get the following response:
 mount: /dev/cdrom is not a valid block device

My fstab file contains the following line
/dev/cdrom              /mnt/cdrom              iso9660 user,noauto,ro  0 0

Could you please provide me with some suggestions to fix this problem?

Thank You

 
 
 

cdrom

Post by David . » Sun, 31 Dec 1899 09:00:00



> I have the following problem with my cdrom:

> When I try to mount it with %mount /dev/cdrom
> I get the following response:
>  mount: /dev/cdrom is not a valid block device

> My fstab file contains the following line
> /dev/cdrom              /mnt/cdrom              iso9660 user,noauto,ro  0 0

> Could you please provide me with some suggestions to fix this problem?

> Thank You

Try to mount the mount point instead of the device like:

 mount /mnt/cdrom

--
Registered with the Linux Counter.  http://counter.li.org
ID # 123538

 
 
 

cdrom

Post by E J » Sun, 31 Dec 1899 09:00:00


Could it be that /dev/cdrom is linked to wrong /dev/hdX (IDE) or /dev/sdX
(SCSI)?
Put in an CDROM and as root try to mount it.  (My CDROM is IDE secondary
master, /dev/hdc)
# mount /dev/hdc /mnt/cdrom
If this solves your problem,
relink your cdrom
# mv /dev/cdrom /dev/cdrom.orig
# ln -s /dev/hdc /dev/cdrom

> I have the following problem with my cdrom:

> When I try to mount it with %mount /dev/cdrom
> I get the following response:
>  mount: /dev/cdrom is not a valid block device

> My fstab file contains the following line
> /dev/cdrom              /mnt/cdrom              iso9660 user,noauto,ro  0 0

> Could you please provide me with some suggestions to fix this problem?

> Thank You

 
 
 

1. ATAPI cdrom cdda not supported for some cdrom drive?

TAPI cdrom cdda not supported for some cdrom drive?

Hi, There,
  I have a ATAPI IDE cdrom that I wish to get the
cdda2wav working. ont the same machine, I have a
scsi cdrom and I was able to get the data from it.
but I have difficulty extracting data from the
IDE cdrom. I have linux 2.0.33 kernel and have the
IDE cdrom driver compiled and I also have the
ssound blaster driver compiled. I am able to mount
data cdrom on the ide cdrom drive. but can't extract audio data
from it. I tried to use:
cdda2wav -D /dev/cdrom temp.wav
for the ide atapi cdrom and it complained that the cdrom
or driver doesn't support cdda. can anybody tell me the
problem ? I tried to figure out how to put the cdda support into
the driver but can't see the option in the driver feature list.
(2.0.33 kernel), or simply my cdrom hardware is to be blamed ?
can any body tell me what to do ?
Jinsong

2. pppd on Suse 6.1

3. ide cdrom and cdrom writer with scsi harddisk using cdrecord can't find cd reader

4. X-Windows from win98

5. HELP: installing CDROM Linux on non-CDROM notebook

6. UNIX crypt() source - the problem solved

7. only root can mount /dev/cdrom on /mnt/cdrom

8. HELP needed sessions automatically terminated with Debian

9. PCMCIA CDROM unable to identify cdrom

10. mount /mnt/cdrom ==> mount: the kernel does not recognize /dev/cdrom as a block device

11. Problem with mounting CDROM on a SCSI CDROM drive

12. Help with mounting Mitsumi FX001DE CDROM [D [D [D [D [DIDE CDROM.

13. CDROM Problem: "mount point /cdrom does not exist"