Gaby database won't compile -"Cannot find GTK"

Gaby database won't compile -"Cannot find GTK"

Post by ncr.. » Sun, 31 Dec 1899 09:00:00



I've tried various versions of Gaby and can't get any of them to compile.
I wish there were an RPM that I could use.  I tried the newest release on
the Gaby webpage, and several older versions.  I'm running Mandrake6.0.

As root, the compile process stops during ./configure.   It says "cannot
find GTK - is gtk-config in path?"  My system doesn't have that file,
although it does have gtk.

I know that gtk is on my system (gtk+-1.2.6-6mdk) I've even tried to
upgrade to a higher version, but all versions of Gaby halt during
compiling.

How do I edit path, or get it to compile?  I'd really like to get this
working, and greatly appreciate any pointers.

Thanks

Chip.

 
 
 

Gaby database won't compile -"Cannot find GTK"

Post by Colin Wats » Sun, 31 Dec 1899 09:00:00



>I've tried various versions of Gaby and can't get any of them to compile.
>I wish there were an RPM that I could use.  I tried the newest release on
>the Gaby webpage, and several older versions.  I'm running Mandrake6.0.

>As root, the compile process stops during ./configure.   It says "cannot
>find GTK - is gtk-config in path?"  My system doesn't have that file,
>although it does have gtk.

>I know that gtk is on my system (gtk+-1.2.6-6mdk) I've even tried to
>upgrade to a higher version, but all versions of Gaby halt during
>compiling.

You'll need to find the development libraries for GTK. They'll be in the
gtk+-devel package (gtk+-devel-1.2.6-6mdk.i586.rpm).

The gtk+ package lets you *run* GTK-based programs, but you need a
little extra to be able to build them.

--

"But in your dreams, whatever they be / Dream a little dream of me."

 
 
 

1. can't compile gnome - "'gtk-config' script not found"

I'm trying to compile my entire system from the ground up - it's been an
interesting challenge, but I'm pretty surprised as to how (relatively)
easy it's been.  However, I'm trying to compile Mozilla, and I keep
getting the error message (when I run "./configure"):

**** The gtk-config script installed by GTK could not be found
**** if gtk was installed in PREFIX, make sure...

blah-blah-blah

I'm sure I have GTK installed (GTK+, in fact), and it's in the
LD_LIBRARY_PATH and PKG_CONFIG_PATH (else I wouldn't have been able to
compile PAN).  I've searched far and wide and can't find "gtk-config"
anywhere in either my system nor in the GTK distribution.

Any idea what it's looking for?

Thanks!

2. Using dprof to compile HPL/ATLAS

3. STARTX: "No Screens Found"/"Can't find Display"

4. /usr/bin/gcc not found, but I can see it there.

5. """"""""My SoundBlast 16 pnp isn't up yet""""""""""""

6. Problems compiling courier-imap

7. GETSERVBYNAME()????????????????????"""""""""""""

8. VX Pro MB, Seagate Hard Drive, Linux, FreeBSD and Dos. HD or MB problems?

9. X won't start "could not find font 'fixed'"

10. Cant compile applications: "make" cant find "cc"

11. Second drive (/dev/fd1) won't "DO IT" and "DO IT"

12. Does select return "read ready" or "won't block" status?

13. "syslogd: unknown priority "24" " error - won't boot!