REAL PLAYER AND LD_LIBRARY PATH IN RHL 5.0

REAL PLAYER AND LD_LIBRARY PATH IN RHL 5.0

Post by Velanche Lashawn Stewar » Mon, 02 Feb 1998 04:00:00



Hello:

I'm trying to setup the Real Player. I had added a path in my bash
.profile in the /etc directory of my Red Hat Linux 5.0 program. I have
added the path just below the PS1 line. Since there wasn't a
LD_LIBRARY_PATH line, I've added it manually.

When I tried to run the program, it gave me an error. In the
documentation, it means that it could not find the environmental variable.

Where about in this version of Linux must I add the paths so that the *.so
libraries that came with the Real Player would be found? Any help would be
appreciated.

Regards,
Velanche

Velanche Lashawn Stewart
Cal Poly State University  San Luis Obispo, California
http://www.calpoly.edu/~vstewart                      

ICQ #1578548

 
 
 

REAL PLAYER AND LD_LIBRARY PATH IN RHL 5.0

Post by Brion Vibbe » Wed, 04 Feb 1998 04:00:00


Quote:> I'm trying to setup the Real Player. I had added a path in my bash
> .profile in the /etc directory of my Red Hat Linux 5.0 program. I have
> added the path just below the PS1 line. Since there wasn't a
> LD_LIBRARY_PATH line, I've added it manually.

> When I tried to run the program, it gave me an error. In the
> documentation, it means that it could not find the environmental variable.

> Where about in this version of Linux must I add the paths so that the *.so
> libraries that came with the Real Player would be found? Any help would be
> appreciated.

Put it in /etc/profile, like this:

    LD_LIBRARY_PATH="$LD_LIBRARY_PATH:/opt/rvplayer"

(assuming that you have other stuff already in your library parth, and that
you're installing in /opt/rvplayer... if you don't have anything else, don't
include '$LD_LIBRARY_PATH:', and of course include the proper path)

And then make sure you've got this:

    export LD_LIBRARY_PATH

If you don't export the variable it will be local to the profile script, and
nothing will see it!



 
 
 

REAL PLAYER AND LD_LIBRARY PATH IN RHL 5.0

Post by E. Kevin Hal » Mon, 09 Feb 1998 04:00:00


Hmm, had the same problem, tried all of this, and it still
doesn't work. Also had dir in /etc/ld.so.conf, tried setting
LD_LIB... to _just_ that in a window... Still can't find it.
Screwy.


> > I'm trying to setup the Real Player. I had added a path in my bash
> > .profile in the /etc directory of my Red Hat Linux 5.0 program. I have
> > added the path just below the PS1 line. Since there wasn't a
> > LD_LIBRARY_PATH line, I've added it manually.

> > When I tried to run the program, it gave me an error. In the
> > documentation, it means that it could not find the environmental variable.

> > Where about in this version of Linux must I add the paths so that the *.so
> > libraries that came with the Real Player would be found? Any help would be
> > appreciated.

> Put it in /etc/profile, like this:

>     LD_LIBRARY_PATH="$LD_LIBRARY_PATH:/opt/rvplayer"

> (assuming that you have other stuff already in your library parth, and that
> you're installing in /opt/rvplayer... if you don't have anything else, don't
> include '$LD_LIBRARY_PATH:', and of course include the proper path)

> And then make sure you've got this:

>     export LD_LIBRARY_PATH

> If you don't export the variable it will be local to the profile script, and
> nothing will see it!



--
E. Kevin Hall

 
 
 

REAL PLAYER AND LD_LIBRARY PATH IN RHL 5.0

Post by Andy Rabaglia » Thu, 12 Feb 1998 04:00:00



Quote:> Hmm, had the same problem, tried all of this, and it still
> doesn't work. Also had dir in /etc/ld.so.conf, tried setting
> LD_LIB... to _just_ that in a window... Still can't find it.
> Screwy.

Try (in sh-flavored shell)

bash% LD_LIBRARY_PATH=/opt/lib rvplayer

Actually, what I do is put the shared library in /usr/lib, the
application rvplayer in /usr/local/bin, run (as root)

bash# /sbin/ldconfig

So you don't need to mess with LD_LIBRARY_PATH

Cheers,     Andy!

 
 
 

REAL PLAYER AND LD_LIBRARY PATH IN RHL 5.0

Post by gippa » Thu, 12 Feb 1998 04:00:00



> Hmm, had the same problem, tried all of this, and it still
> doesn't work. Also had dir in /etc/ld.so.conf, tried setting
> LD_LIB... to _just_ that in a window... Still can't find it.
> Screwy.

Yeah, there's definitely a bug in the software, I've tried everything it
says to do as well.  I've even tried doing it the "normal" way rather
than all the path rubbish (putting the libs where the libs should be and
doing ldconfig).

However, I discovered that it DOES work if you open up rvplayer on its
own -- not from within netscape -- and then you can click the link that
you want in netscape and it will pipe it through to the process you've
opened.

For some reason, it just won't work if you try to execute the program
through netscape.  (I use NS 3.04).

 
 
 

REAL PLAYER AND LD_LIBRARY PATH IN RHL 5.0

Post by gippa » Thu, 12 Feb 1998 04:00:00




> > Hmm, had the same problem, tried all of this, and it still
> > doesn't work. Also had dir in /etc/ld.so.conf, tried setting
> > LD_LIB... to _just_ that in a window... Still can't find it.
> > Screwy.

> Try (in sh-flavored shell)

> bash% LD_LIBRARY_PATH=/opt/lib rvplayer

> Actually, what I do is put the shared library in /usr/lib, the
> application rvplayer in /usr/local/bin, run (as root)

> bash# /sbin/ldconfig

> So you don't need to mess with LD_LIBRARY_PATH

Tried that.
 
 
 

REAL PLAYER AND LD_LIBRARY PATH IN RHL 5.0

Post by Kevin Mart » Fri, 13 Feb 1998 04:00:00



?  Try (in sh-flavored shell)
?  
?  bash% LD_LIBRARY_PATH=/opt/lib rvplayer
?  
?  Actually, what I do is put the shared library in /usr/lib, the
?  application rvplayer in /usr/local/bin, run (as root)
?  bash# /sbin/ldconfig  
?  So you don't need to mess with LD_LIBRARY_PATH

Cool!  Thanks.  That's one less directory cluttering up my regular
PATH, too.  What do you do with the .class files?  I put them in
/usr/local/bin along with the rvplayer executable.  (This is
RealPlayer 5.0.0.33 Beta 3, fresh off their Web site.)

I'm actually having some unrelated sound card problems, so it's up
in the air whether the thing actually works or not... but at least
I'm not getting any "LD_LIBRARY_PATH" errors.  :-)

 
 
 

REAL PLAYER AND LD_LIBRARY PATH IN RHL 5.0

Post by Mark Smit » Sun, 15 Feb 1998 04:00:00


I had some trouble also, until I appended a forward slash to the
LD_LIBRARY_PATH variable al la :

LD_LIBRARY_PATH=/usr/local/rvplayer5.0b3/

Everything works now, including seeing Bill Gates get pie on his face
:-)

 
 
 

REAL PLAYER AND LD_LIBRARY PATH IN RHL 5.0

Post by Mark Vojkovi » Mon, 16 Feb 1998 04:00:00




>> Hmm, had the same problem, tried all of this, and it still
>> doesn't work. Also had dir in /etc/ld.so.conf, tried setting
>> LD_LIB... to _just_ that in a window... Still can't find it.
>> Screwy.

>Yeah, there's definitely a bug in the software, I've tried everything it
>says to do as well.  I've even tried doing it the "normal" way rather
>than all the path rubbish (putting the libs where the libs should be and
>doing ldconfig).

>However, I discovered that it DOES work if you open up rvplayer on its
>own -- not from within netscape -- and then you can click the link that
>you want in netscape and it will pipe it through to the process you've
>opened.

>For some reason, it just won't work if you try to execute the program
>through netscape.  (I use NS 3.04).

   Works fine as a helper app over here.  NS 3.04 and 4.04.

                                Mark.

 
 
 

1. RedHat 5.0 and Real Player 5.0 for Linux

I am having real trouble with Real Player! When I click on a link for a
Real Audio or Real Video file in Netscape, the player comes up and
receives data. But it only skips through it and makes an occasional
"gurgle" of audio or blip of video. I have plenty of speed and 128 megs
of RAM, plus a very good sound card. Other audio apps sound great. Any
ideas out there on the cause of this?

2. Mp3-player better then amp for AIX available ?

3. Real Player 5.0 on Solaris (depth problem)

4. Binaries for Khoros (1.0.5 or 2.0) available?

5. Real Player 5.0

6. Graphical Backup/Restore Program for Linux???

7. REAL PLAYER 5.0

8. Connection sharing

9. Problem with using the Real Video player 5.0 on Redhat Linux 5.2

10. Real Player 5.0

11. Real Player 5.0 in Debian Linux

12. Real Player 5.0