gtk-config glib-config and configure

gtk-config glib-config and configure

Post by Narbey Derbekya » Sun, 31 Dec 1899 09:00:00



        Greetings, I'm having some issues with gtk-config and
glib-config when used by the configure scripts when compile various
gtk software. I'm receiving the following error:

*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB was incorrectly installed
*** or that you have moved GLIB since it was installed. In the latter case, you
*** may want to edit the glib-config script: /usr/bin/glib-config

Exact same error for gtk-config. This was working just fine. The same
software that compiled just fine are now breaking when I run
./configure

I have the following system:
RedHat 6.2 upgraded with Helix Gnome.

        I had run into some lilo problems the other week and the only
thing I could do was reinstall. Ever since then gtk-config and
glib-config have been giving problems when I run ./configure. I did
not know they existed until they broke.
        The scripts are there and I can run them from the command line
and receive the various output meant to be used with gcc. But I
receive the above error when I run ./configure as the same user.
        I installed Helix Gnome on top of all this hoping that the gtk
and glib rpms from the Helix cd would clear things up. Well Helix
Gnome is working just fine but I'm still running into the same
problem. I check and the new gtk and glib libraries from the helix cd
were installed.

        I can't make heads or tales of what's broken. If someone could
give some pointers, I'll be eternally greatfull.

        thanks

        narbey

 
 
 

gtk-config glib-config and configure

Post by Narbey Derbekya » Sun, 31 Dec 1899 09:00:00


        I forgot I had made this posting. Well the problem was finally
fixed and here's hoping the explanation will help someone else.

        It looks like the problem was related to the complete
non-existance of /usr/include/linux (and /usr/include/asm) on my
system. The configure script actually compiles a small C test program
with the libraries that the software depends on. It seems during my
kernel upgrade those two links under /usr/include went away and hence
causing problems. Things were compiling just fine and dandy before
then. A symlinking to the appropriate directories under
/usr/src/linux/include fixed it.

        config.log had the appropriate clues as mentioned in the error
message below (imagine that :)

        narbey

:       Greetings, I'm having some issues with gtk-config and
: glib-config when used by the configure scripts when compile various
: gtk software. I'm receiving the following error:

: *** Could not run GLIB test program, checking why...
: *** The test program failed to compile or link. See the file config.log for the
: *** exact error that occured. This usually means GLIB was incorrectly installed
: *** or that you have moved GLIB since it was installed. In the latter case, you
: *** may want to edit the glib-config script: /usr/bin/glib-config

: Exact same error for gtk-config. This was working just fine. The same
: software that compiled just fine are now breaking when I run
: ./configure

: I have the following system:
: RedHat 6.2 upgraded with Helix Gnome.

:       I had run into some lilo problems the other week and the only
: thing I could do was reinstall. Ever since then gtk-config and
: glib-config have been giving problems when I run ./configure. I did
: not know they existed until they broke.
:       The scripts are there and I can run them from the command line
: and receive the various output meant to be used with gcc. But I
: receive the above error when I run ./configure as the same user.
:       I installed Helix Gnome on top of all this hoping that the gtk
: and glib rpms from the Helix cd would clear things up. Well Helix
: Gnome is working just fine but I'm still running into the same
: problem. I check and the new gtk and glib libraries from the helix cd
: were installed.

:       I can't make heads or tales of what's broken. If someone could
: give some pointers, I'll be eternally greatfull.

:       thanks

:       narbey

 
 
 

1. glib-config, gtk-config

hi,
i am using Suse-8.1 and tried to upgrade the Mplayer and add a few video
plugins to xmms, but all the configuration scripts i ran gave the same
error.
glib ver >= 1.2 not found .
similar error for gtk as well.
i checked out and found that these two libraries are installed but the
glib-config and gtk-config files are not there in /usr/bin/.
i checked other linux versions RH-7.3 for ex and found these two files. i
copied these two files to the /usr/bin/ dir and changed the perms
accordingly. but still the scripts give the same error which was quite
expected. i did not try to edit those two files in ne way as i understood
little of what was written in it.
ne help will be appreciated
Mainak

--
-------------------------------------------------------------------------------------------------------

We are the people our parents warned us about...

2. Forgotten password

3. gtk+ && glib-config?

4. AHA-2940 Solaris 7

5. glib-config returned 1.2.10 but glib 2.0.3 found error.

6. RH 7.3 Stalls install

7. Missing gtk-config while blding gvim w/ gtk

8. LMSI CDROM drives any good?

9. glib-config path not found

10. Problem installing xdelta-1.1.3 [glib-config not found]

11. what & where is glib-config?

12. can't compile gnome - "'gtk-config' script not found"

13. gtk-config not found?