NE2000 setup in Slackware 96

NE2000 setup in Slackware 96

Post by Mike Jasperso » Tue, 11 Feb 1997 04:00:00



I'm having a problem setting up a NE2000 card for linux.  I compiled a
kernel (2.0.0) with ne support, but I get:

SIOCSIFADDR: No such device.

... and a couple more.  I read the HOWTO included, and it said to read
thru the 'dmesg | less' and it really didn't tell me much... Does anyone
have a little more insight into what may be the problem?

 
 
 

NE2000 setup in Slackware 96

Post by Brian La » Tue, 11 Feb 1997 04:00:00


On Mon, 10 Feb 1997 00:07:16 -0600, Mike Jasperson


>I'm having a problem setting up a NE2000 card for linux.  I compiled a
>kernel (2.0.0) with ne support, but I get:

>SIOCSIFADDR: No such device.

>... and a couple more.  I read the HOWTO included, and it said to read
>thru the 'dmesg | less' and it really didn't tell me much... Does anyone
>have a little more insight into what may be the problem?

  Did the dmesg tell you if your card was found? It should show the
ioport and irq, as well as the hardware serial number. Sounds like the
card wasn't detected, which will happen if you don't have the ioport
set to one of the addresses that the kernel expects it to be in. (Off
the top of my head, 0x300 and 0x360 are two of them).

  Brian

+-------------------------+
|  Nexus Computing        |

|  www.eskimo.com/~nexus  |
+-------------------------+

 
 
 

NE2000 setup in Slackware 96

Post by Tim Barn » Wed, 12 Feb 1997 04:00:00


: On Mon, 10 Feb 1997 00:07:16 -0600, Mike Jasperson

: >I'm having a problem setting up a NE2000 card for linux.  I compiled a
: >kernel (2.0.0) with ne support, but I get:
: >
: >SIOCSIFADDR: No such device.
: >
: >... and a couple more.  I read the HOWTO included, and it said to read
: >thru the 'dmesg | less' and it really didn't tell me much... Does anyone
: >have a little more insight into what may be the problem?

:   Did the dmesg tell you if your card was found? It should show the
: ioport and irq, as well as the hardware serial number. Sounds like the
: card wasn't detected, which will happen if you don't have the ioport
: set to one of the addresses that the kernel expects it to be in. (Off
: the top of my head, 0x300 and 0x360 are two of them).

... if it doesn't find it you need to force detection with a boot
parameter ether=IRQ,0xADDR,0,0,eth0
cheers,
--
Tim Barnes                              |   Dept. of Mathematics,

http://holly.maths.bris.ac.uk/~BarnesT  |   Bristol, U.K.
Tel: +44 (0)117 928 7780                |   BS8 1TW

 
 
 

NE2000 setup in Slackware 96

Post by Altman » Thu, 13 Feb 1997 04:00:00



> On Mon, 10 Feb 1997 00:07:16 -0600, Mike Jasperson

> >I'm having a problem setting up a NE2000 card for linux.  I compiled a
> >kernel (2.0.0) with ne support, but I get:

HiYa,

at the lilo prompt add an appending:
lilo: linux ether=IRQ,Adress,0,0,eht0

IRQ: whatever
ADR: 0x300 or what ever

Winf
--
     |\/\/\/|      Hahn-Meitner-Institut Berlin GmbH    |
     |      |      Bereich DS                           |
     |      |                                           |
     | (o)(o)      Glienicker Str. 100                  |
     c      _)     D 14109 Berlin                       |
     |  ,__|                                            |
     |   /         Winfried Altmann                     |
     /   \         (030) 8062 2618                      |

 
 
 

NE2000 setup in Slackware 96

Post by Tim Barn » Fri, 14 Feb 1997 04:00:00


: >
: > On Mon, 10 Feb 1997 00:07:16 -0600, Mike Jasperson
: >
: > >I'm having a problem setting up a NE2000 card for linux.  I compiled a
: > >kernel (2.0.0) with ne support, but I get:
: > >

: HiYa,

: at the lilo prompt add an appending:
: lilo: linux ether=IRQ,Adress,0,0,eht0

make that

lilo: linux ether=IRQ,Address,0,0,eth0

: IRQ: whatever
: ADR: 0x300 or what ever

Just in case ....

--
Tim Barnes                              |   Dept. of Mathematics,

http://holly.maths.bris.ac.uk/~BarnesT  |   Bristol, U.K.
Tel: +44 (0)117 928 7780                |   BS8 1TW

 
 
 

NE2000 setup in Slackware 96

Post by Michael Shil » Mon, 17 Feb 1997 04:00:00




>: On Mon, 10 Feb 1997 00:07:16 -0600, Mike Jasperson

>: >I'm having a problem setting up a NE2000 card for linux.  I compiled a
>: >kernel (2.0.0) with ne support, but I get:
>: >
>: >SIOCSIFADDR: No such device.
>: >

Every time I've seen this I was using a kernel that did not
have network support.
--
Thank you,

Michael Shiloh