ne.o needs PCIBIOS ???

ne.o needs PCIBIOS ???

Post by Z-Y [Jerry » Tue, 05 May 1998 04:00:00



greet all,
I installed Debian 2.0 two days ago. Today I recompiled the kernel with
network enabled for a ne2000 compitable card. It is an old 486sx
manufactured around October 1992.  I mean it should not know anything
about PCIbios, right?? At least I thought so, so I answer 'N' when 'make
config'. Now at boot, loading of ne.o reported a bounch of unresolved
symbols for PCIbios.sth. (please refer to the attachment).
My questions is:
1. how come? How come ne.o needs symbols from pcibios?!
2. Is there anyway I can get around without recompiling the kernel?
Modprobe to load ne at least reports the same error. Wonder if I modprobe
sth like pcibios.o before I modprobe ne can work.
Fortunately, the old kernel is still around:-)
BTW, another error is sth like "lp can not get major 6". However, the
later line reports "lp0 at 0x3bc, polling". What does it mean can't get
major 6?
Thanks.
 YU, Zhongbin                                   In Nature I believe:-)
--------------------------------------------------------------------
    Chem. Dept., Emory University      |  Surface Chem. Lab, Fudan U.
http://userwww.service.emory.edu/~zyu  |     Shanghai, 200433  

[ ne.oProblem < 1K ]
root:/home/zyu# modprobe ne io=0x240 irq=10
/lib/modules/2.0.33/net/ne.o: unresolved symbol pcibios_read_config_byte_R978eb902
/lib/modules/2.0.33/net/ne.o: unresolved symbol pcibios_present_Ra67d0654
/lib/modules/2.0.33/net/ne.o: unresolved symbol pcibios_find_device_R53c20343
/lib/modules/2.0.33/net/ne.o: unresolved symbol pcibios_read_config_dword_R9c25afd5